Mv1C repair?

Unessential

New Challenger
Joined
Sep 23, 2015
Posts
25
Ages (years) ago I was hooking up a mv1c at an event, and I being stupid, hooked up the power supply wrong and sent +5v to ground, Killed the mv1c and (luckly) a cheap 161 in 1 (thank goodness my windjammers wasn't in it!)

I never threw it out, especially since a friend said it might not be broken beyond repair due to it booting up to the green screen which is apparently most of the boot sequence?

Can anyone confirm or deny this?

I suspected that the board is damaged beyond repair because ground goes *everywhere* but maybe there's a fuse somewhere protecting it?

I don't have an oscilloscope or anything. Just a multimeter. Does anybody know if there's any hope for this board? And if there's someone that can do a diagonostic/repair in Southern Ontario / Upstate newyork?
 

ggallegos1

Cholecystectomy Required.,
Joined
Oct 1, 2013
Posts
4,362
There is a fuse right above where the JAMMA edge power pins are (left side). A 5 amp fuse should be able to do it, assuming it's just the fuse that took the brunt of the power.
 

shadowkn55

Genbu's Turtle Keeper
Joined
Dec 9, 2006
Posts
2,386
Probably a calendar error if it's stuck on the green screen. You can use a unibios to bypass that issue if you can't find a replacement calendar chip.
 

Unessential

New Challenger
Joined
Sep 23, 2015
Posts
25
Thanks for the replies!

Without taking off the outer casing, It looks like the fuse wasn't burnt out... which is probably a bad thing, But I can't see it too well...

So I'll order a neobiosmasta, check the fuse, and put in a unibios. (I'm guessing it's straight forward to bypass once I install it?)

googling "neo geo calendar chip" seems like the issue can be caused by a few things... Will the unibios be able to bypass it regardless of what the cause is?

Hopefully nothing else is broken...

I still have 2 working neo geos, I never tossed out the broken one because I had hope it would be an easy fix. and it doesn't hurt to have a 3rd as a backup or just for more setups for events... I guess if it doesn't end up working I can use the neobiosmasta on my working mv1c...
 

Unessential

New Challenger
Joined
Sep 23, 2015
Posts
25
So, I finally got the neobiosmasta in the mail, installed it. and... The neo geo still won't boot. Now it's just a solid colour screen. (different solid colour very time, usually white or pink, but has been orange, cyan, blue, and yellow)

I'm guessing that I probably killed way more components than just the calendar chip/crystal when I hooked up the power wrong...

At this point I should just toss it right?
 

BIG BEAR

SHOCKbox Developer,
Joined
Dec 14, 2001
Posts
7,321
NevEr toss it. if you want to sell as parts I may be interested.
BB
 
Top