Xeno Crisis coming to Neo Geo

GadgetUK

Ace Ghost Pilot
Joined
Sep 27, 2013
Posts
1,320
I think all the "hack" is doing is correcting the banking for the ADPCM. So the YM2610 suddenly sees the correct data. I cannot see how any difference to the 1C architecture could cause that to not work tbh. What I would say is there is a bias on bass like sounds to left side regardless, so if testing with a monitor or CRT etc, you might think it hasn't work when it has. The best way to test this is with headphones, let intro start - listen to how it sounds, then do the patch and there will be a click right side and right side "pops in". But certainly on the intro and level 1, bass is left side biased. As the music plays out there clearly stuff right channel only, and some tracks are more balanced across both sides - it varys with each track.
 

le geek

Haomaru's Blade Shiner
Joined
Jun 25, 2004
Posts
683

Attachments

  • xenocrisis-legeek306-thumb.png
    xenocrisis-legeek306-thumb.png
    1.9 MB · Views: 32
Last edited:

Neo Alec

,
20 Year Member
Joined
Dec 7, 2000
Posts
9,328
I think all the "hack" is doing is correcting the banking for the ADPCM. So the YM2610 suddenly sees the correct data. I cannot see how any difference to the 1C architecture could cause that to not work tbh. What I would say is there is a bias on bass like sounds to left side regardless, so if testing with a monitor or CRT etc, you might think it hasn't work when it has. The best way to test this is with headphones, let intro start - listen to how it sounds, then do the patch and there will be a click right side and right side "pops in". But certainly on the intro and level 1, bass is left side biased. As the music plays out there clearly stuff right channel only, and some tracks are more balanced across both sides - it varys with each track.
I tested with all three boards. I noticed it worked immediately on the MV1FS, while the MV4F seems to need the next music track to begin before it takes effect.

I'm testing the stereo modded MV1C on a stereo receiver. It exhibits the issue, and the patch definitely doesn't have any noticeable effect.
 

arbormatt

B. Jenet's Firstmate
Joined
Aug 27, 2010
Posts
403
Pretty happy with this release. Hopefully this was a great learning experience and things go easier in the future. Can’t wait to get more Neo games. Beat em up next please. Shooters can wait. The only issue besides the sound I had was the shipping packaging and the fit of the pcbs. My box was smashed. I honestly don’t care much as it will be going into a shock box. The rattle of the boards bother me though. Sounds like standoffs might be broken.D947CFA4-C695-4F7F-AAD1-4DE92D89E763.jpeg
 

traveno

Kuroko's Training Dummy
Joined
Feb 29, 2020
Posts
77
football2.jpgfootball.jpg

Oh joy it's here!

I'll test it on my consolized MV1C that has stereo line out. I hope the cart still works...
 
Last edited:

traveno

Kuroko's Training Dummy
Joined
Feb 29, 2020
Posts
77
Music is coming only from one side on my MV1C. Sound effects are fine though. The memory patch has no effect.
 

ysselcneogeo

Hardened Shock Trooper
Joined
Jun 8, 2012
Posts
438
Did anyone get the NGCD version yet?

Got it and played it. I much preferred playing it on my cdz with a neo controller than I did a year or so ago on xbox. Just like the controller better.

I do have to say that while the geometry on my tv isnt fantastic by any means this is literally the only neogeo game where things get cut off. Its like this game didnt account for crt overscan. Granted with so many things on this tv I cant get the screen perfect for everything and it's just a happy medium. Seems like it could have been a easy fix had the stuff just been slightly more adjusted towards the middle of the screen.

Also a hugggge let down is no arranged ost. Its like the only advantage the cd system has and its not used.

overscan.jpgcase.jpgover2.jpg
 

TMOSteel

,
20 Year Member
Joined
Nov 28, 2000
Posts
609
The was a recommendation to enable to patch as soon as the game loads on the MV1C, but it made no difference, it still doesn't work.
 

gameofyou

Crossed Swords Squire
Joined
Mar 3, 2007
Posts
184
Received my AES copy today! I have a mono AV cable, so music sounds fine. I haven’t noticed any graphical issues, so that is a relief.

My tv also cuts off some of the text on both the right and left (like in ysselcneogeo’s photo). I think I noticed this happen on Gunlord, also.
 

Neo Alec

,
20 Year Member
Joined
Dec 7, 2000
Posts
9,328
I had adjusted the overscan on my arcade monitor for this game. Guess it wasn't just my setup.

Two posts of smashed boxes in a row. I was concerned about that when I saw how mine was packed. I got lucky -- my outer packaging was a bit concave, but the inner MVS kit box seems more or less okay.
 

avramce

Cheng's Errand Boy
Joined
Sep 24, 2019
Posts
113
Tried the fixed on both an AES and a MV1C kit, as reported by others, has zero effect on the MV1C. Tried soft reboot, test menu reboots, nada.

AES is great with the fix, a little sad that I'm still getting that video curl on top on the RetroTink 5X
 

GadgetUK

Ace Ghost Pilot
Joined
Sep 27, 2013
Posts
1,320
The 1C might need the cart updating - what I do know is more testing is ongoing, but fixes are being worked on too. I am hoping to help them test at some point today. It's a shame a few boxes got squashed there =/ I cannot remember what the shipping options were, mine came in the larger box as it was the collectors edition, and that larger box makes a huge difference I think (and perhaps added cost on shipping?). If you contact BB, I am sure they can arrange something to replace that box. They might be able to send a box (in flat unfolded form perhaps) - just let them know, see what they can do!
 

GadgetUK

Ace Ghost Pilot
Joined
Sep 27, 2013
Posts
1,320
The was a recommendation to enable to patch as soon as the game loads on the MV1C, but it made no difference, it still doesn't work.
Thanks for testing! The reason I pointed this out - I tested the 1FZ again yesterday and found depending on when I applied the patch made a difference. For instance, if I wait for the music to start and you hear the narration on intro, then patch that address - I found it made no difference, but several seconds later it suddenly popped in the right channel. It then remained stereo after eitther soft or hard reset. And likewise I found if I patched it ASAP just after unibios allowed, stereo was there right away. I could repeat that every time on the 1FZ.

The guru at BB suggested perhaps the YM2610 is processing the block of ADPCM and cannot correct itself due to the fact it started with borked banking, but on some boards it seems to correct itself, perhaps as it starts the next block. There could be other things going on with the 1C, but lots of work and testing is ongoing. I am hoping to test the perma fix shortly (I just need to feel well enough first so I can concentrate on what I am doing so I dont create myself problems lol).
 

yagamikun

,
20 Year Member
Joined
Oct 10, 2000
Posts
1,856
Got my AES cart yesterday. I did the Unibios patch on the BB splash screen at boot and music/sound was fine in the intro and my play though there after. Quite happy with this fix for now as it just takes a second. I just put a paper with the "codes" in the case with the game. It's kinda like when I was a kid and I'd have papers with passwords in my game cases. :)

@GadgetUK Thanks for all your hard work communicating with and helping out BB get the word out to this unforeseen issue. I'm sure they're working their asses off right now after they thought the work on the Neo version was over. Appreciate it, man!
 

GadgetUK

Ace Ghost Pilot
Joined
Sep 27, 2013
Posts
1,320
Got my AES cart yesterday. I did the Unibios patch on the BB splash screen at boot and music/sound was fine in the intro and my play though there after. Quite happy with this fix for now as it just takes a second. I just put a paper with the "codes" in the case with the game. It's kinda like when I was a kid and I'd have papers with passwords in my game cases. :)

@GadgetUK Thanks for all your hard work communicating with and helping out BB get the word out to this unforeseen issue. I'm sure they're working their asses off right now after they thought the work on the Neo version was over. Appreciate it, man!
No worries! Glad it worked for you! In other news, I've been helping test my cart at my side with the perma fix - works for me! Lots more testing required but it looks like it's just about testing now, and finding the best way to apply it. Huge thanks to BB for allowing me to apply that fix and help test.
 

le geek

Haomaru's Blade Shiner
Joined
Jun 25, 2004
Posts
683
what kind of paper you use thats close to the official neo geo inserts?
At a print place, like Fed Ex Office, go with "Tabloid, heavy stock". Tell them to NOT stretch to fit, and for a little extra they will cut it to size for you. If you are printing more than one ShockBox Insert, the cut-to-size price is the same since it's "per cut".
 

acem77

Loyal Neo-Disciple
Joined
Apr 11, 2003
Posts
836
Just saw this was posted already well here is dup info..
After theorizing the unibiles can fix this sound issue.
 

vincewy

Loyal Neo-Disciple,
20 Year Member
Joined
Aug 16, 2000
Posts
1,181
At a print place, like Fed Ex Office, go with "Tabloid, heavy stock". Tell them to NOT stretch to fit, and for a little extra they will cut it to size for you. If you are printing more than one ShockBox Insert, the cut-to-size price is the same since it's "per cut".

How do you get Fed Ex to print without asking for permission from owners/publishers?
 

yagamikun

,
20 Year Member
Joined
Oct 10, 2000
Posts
1,856
How do you get Fed Ex to print without asking for permission from owners/publishers?
I've found it just depends on who's working and whether or not they want to follow policy. That's at any print place. The most luck I've had with any retailer not asking questions is Office Depot.
 

wyo

Banned for trolling, misinformation
Joined
May 22, 2013
Posts
7,428
Never had such a problem at FedEx, and they should have paper cutter in the store you can use.
 
Top