CPS2 Black board Revival (What am I doing wrong?)

Lemony Vengeance

Mitt Romney's Hairdresser,
hey all,

I'm trying to revive a black CPS2 SFZ3 board I picked up from ebay.

I'm using Artemio's CPS2Black utility (v1.01) and a SuperBIOS cart to get the ROM (IDC Clean ROM) to the SIMM.

Here's the board:

temporary_zps9a29772b.jpg


Here's the Jumpers (unchanged):

temporary_zps14d61d29.jpg


After writing the ROM to the SIMM, this is what the game looks like:

temporary_zpsa7db0a6d.jpg


I'm missing something here, aren't I? I just need someone to explain in simple terms what I need to do.. I'm either really close or MILES away from this being done.

Thanks in Advance
 

Artemio

Zero's Secretary
That is an issue with the graphics, the game is ok since the code is alright in the SIMM. If you have the means to check them, dump the 4 mask roms on the bottom left of your pic and compare them against the known dumps.

While doing that, you can confirm if they are correctly placed in the sockets with no bent pins.

You didn't nothing wrong, it is a completely different issue.

EDIT: Something seemed off to me, since I remember it uses them. The docs say that the board has 8 such graphics ROMs, but there are only 4 in your board. You are missing 4 more

http://www.progettoemma.net/gioco.php?game=sfz3j
 
Last edited:

Lemony Vengeance

Mitt Romney's Hairdresser,
That is an issue with the graphics, the game is ok since the code is alright in the SIMM. If you have the means to check them, dump the 4 mask roms on the bottom left of your pic and compare them against the known dumps.

While doing that, you can confirm if they are correctly placed in the sockets with no bent pins.

You didn't nothing wrong, it is a completely different issue.

EDIT: Something seemed off to me, since I remember it uses them. The docs say that the board has 8 such graphics ROMs, but there are only 4 in your board. You are missing 4 more

http://www.progettoemma.net/gioco.php?game=sfz3j


thanks for the post and tool, Artemio!

The board uses 64 meg mask roms, and not the normal 32 meg mask roms that the normal CPS2 boards use. I was thinking since I had the OG board, I could get away with re-writing the simm only, but that's not the case I guess :P
 

Artemio

Zero's Secretary
Thanks for the info, I only have MvC at home in the black format and don't even know if that one uses 64MB Mask Roms as well...

Anyway, the only course of action is checking if the graphics Mask ROMs are alright.
 

Dion

Known Scammer, NeoGeoFreak Co-Founder
The Black boards are not as easy to revive.

PM mainman. He's the expert.

It is incredibly easy using a SuperBIOS cart and Artemio's tool. Anyone with a SuperBIOS cart can revive one in less than 5 minutes. I have two Youtube videos about it. The one LV posted is one of them.

Make sure you used the new version of the tool. The first version gives errors on SFA3 but not on MVC.

Definitely looks like a GFX rom issue. I assume you reseated all of the roms? The problem with testing the 64mb SIMMS is that I don't believe there is a dump of them in MAME. You could replace a bad one with two 27c322 but I think you would need to replace two of the mask roms and then adjust one of the jumpers.

And for the record, as stated above, the black pcbs used 64mb roms for all games. Even the ones like MVC that originally used 32mb roms on the b-boards. Later b-boards like Progear and SF2:AE used 64mb roms originally anyways.

I'm surprised you didn't tell me about this problem in PM or email. I just happened to look at the forums tonight which I haven't had much time to do. LEt me know if you need help!
 

Lemony Vengeance

Mitt Romney's Hairdresser,
I made sure to grab the latest tool before I re-flashed the SIMM. Just for kicks, I flashed it with the Hyper Anniversary ROM and got garbled graphics. Probably because the mask roms don't have the HA info on it (LAWL) see, I'm learning :P

My Eprom burner should be here tomorrow so I'll check the roms against MAME although like Mitsu, I don't think the all in ones have been dumped. Man, that would be great if the community did that and shared that info..

I'm surprised you didn't tell me about this problem in PM or email. I just happened to look at the forums tonight which I haven't had much time to do. LEt me know if you need help!

I know, I'm usually pretty quick on the emails to you lately but I didn't want to treat you like my personal tech support. I hate it when people do that to me :P Plus, if there's a thread, more people can see the solution and contribute to the project :D
 

Lemony Vengeance

Mitt Romney's Hairdresser,
I reseated the roms last night and no dice :/

I'm going to go to my electronics shop today. IF they have the right ROMS, which ones should I get?
 

Xian Xi

JammaNationX,
I reseated the roms last night and no dice :/

I'm going to go to my electronics shop today. IF they have the right ROMS, which ones should I get?

You need to verify the roms first. If they test good then don't replace them, the problem would be more down line in the multiplexing.
 

Lemony Vengeance

Mitt Romney's Hairdresser,
I need to get the EEprom programmer in. USPS says expected delivery is today, but we all know it's bullshit :( If not today, tomorrow or thursday.
 

Xian Xi

JammaNationX,
I need to get the EEprom programmer in. USPS says expected delivery is today, but we all know it's bullshit :( If not today, tomorrow or thursday.

Usually it will say out for delivery or sorted through your local PO then it should be delivered today or tomorrow. If it's blank but today is the expected, maybe not.
 

Dion

Known Scammer, NeoGeoFreak Co-Founder
The problem is he has nothing to verify them against. I don't believe the 64mb mask rom version of SFA3 is dumped into MAME.
 

Lemony Vengeance

Mitt Romney's Hairdresser,
ok, so, just to recap:

I've downloaded the IDC clean roms and noticed that there were a few that were named differently:

2013-12-23_1443.png


I tried running the tool but it complained that there wasn't a full romset so I renamed the SZ3JDL to SZ3 to match, ran the tool, then used the file it output to flash the SIMM.

Is this incorrect?
 

Dion

Known Scammer, NeoGeoFreak Co-Founder
ok, so, just to recap:

I've downloaded the IDC clean roms and noticed that there were a few that were named differently:

2013-12-23_1443.png


I tried running the tool but it complained that there wasn't a full romset so I renamed the SZ3JDL to SZ3 to match, ran the tool, then used the file it output to flash the SIMM.

Is this incorrect?

Yes. That is correct. The fact that the game boots tells you that the SIMM is fine. The reason why those particular files are named differently is because they are the ones that needed to be decrypted. Not every program rom has decryption so the ones that do not are untouched across all regions of the game. Meaning in your example, 5-10 are identical across all regions of SFA3 and only rom 3 and 4 had any decryption on them.
 
Top