Neo Geo PRO POW-PAL power adapter problem

CMS

Previously A04_msh.
Joined
Aug 15, 2006
Posts
222
Hi, I'm having trouble with my new official SNK PRO-POW-PAL adapter to replace my old adapter (which works fine but I wanted the official product.)

View attachment 10838
My AES (might be North american version? it's white blood in Metal slug X
View attachment 10839
New adapter which doesn't work, the image is full of green and red pixels and no sound.
View attachment 10840
Old adapter I wanted to replace.

I haven't opened the console but think it's original w no uniBios installed, I have own it for 15 years.
Could it be that it is a PRO-POW-PAL adapter? ...the new PRO-POW-PAL adapter is in working order, it "generates" 7V, tested it at a local electrician shop. It's just not working with my console.
I'm grateful for all suggestions on what official Neo Geo adapter I should try to find..
 
Last edited:

CMS

Previously A04_msh.
Joined
Aug 15, 2006
Posts
222
Perhaps the mainboard was swapped or modified from 5V to 9V but why would you do that?
 

GohanX

Horrible Goose
20 Year Member
Joined
Sep 28, 2001
Posts
11,972
My guess is mobo swap. If you were to use that old 9v adapter on a 5v motherboard you would fry it.
 

CMS

Previously A04_msh.
Joined
Aug 15, 2006
Posts
222
My guess is mobo swap. If you were to use that old 9v adapter on a 5v motherboard you would fry it.

OK, but why would you do that? Is there any advantages with the 9V? If that's the case and I want an official adapter can I use the Pro Pow3 adapter?
 

GohanX

Horrible Goose
20 Year Member
Joined
Sep 28, 2001
Posts
11,972
My guess would be someone had a broken 5v system with a good shell and a good 9v motherboard with a bad shell and transferred it. To be in the safe side you might want to either post a pic of the motherboard or peek through the cart slot to see if you can see the board revision.
 

CMS

Previously A04_msh.
Joined
Aug 15, 2006
Posts
222
My guess would be someone had a broken 5v system with a good shell and a good 9v motherboard with a bad shell and transferred it. To be in the safe side you might want to either post a pic of the motherboard or peek through the cart slot to see if you can see the board revision.


View attachment 10844
I guess this is the revision number. It says 3-3 before Made in Japan...
 

Xian Xi

JammaNationX,
15 Year Member
Joined
Dec 1, 2005
Posts
27,725
You can use a power supply rated 9v-13v with an output of 2-3A and make sure it is a negative tip polarity.
 

CMS

Previously A04_msh.
Joined
Aug 15, 2006
Posts
222
You can use a power supply rated 9v-13v with an output of 2-3A and make sure it is a negative tip polarity.

Great, thank you!
Has the motherboard been swapped you think? Can you tell if it's japanese or american version from the photos?
 

Xian Xi

JammaNationX,
15 Year Member
Joined
Dec 1, 2005
Posts
27,725
It's has a US bios. I'm pretty sure it's been swapped since the case is from a JP one.
 

CMS

Previously A04_msh.
Joined
Aug 15, 2006
Posts
222
Ok. Which official power supply should I have you think? Neo-Pow 3 and Pro-Pow-E both have 10V but only 1A output.
 

Xian Xi

JammaNationX,
15 Year Member
Joined
Dec 1, 2005
Posts
27,725
Ok. Which official power supply should I have you think? Neo-Pow 3 and Pro-Pow-E both have 10V but only 1A output.

For official ones, go for a Pro Pow 3/Neo Pow 3 or Pro Pow-E.
 
Top