mv-1b distorted sound

pier

Crazed MVS Addict
Joined
Jan 24, 2020
Posts
137
Hello, my infamous mv1b, started to have sound issue but this time is different, the initial neogeo jingle sounds good but every game sound is crappy or distorted i tried different carts but the problem is the same: neogeo jingle sounds good and everything else is bad.

f91ab484-4781-4834-96ac-187b1e504e96.jpg
 
Joined
Dec 7, 2000
Posts
9,090
This MV-1B is infamous? Is there another thread about it you can link?

What is that mod with the sub board doing?
 

lachlan

drunk downunder!, aka. Muff Diver.,
Joined
Feb 13, 2005
Posts
17,271
Would have to be a first for me to see heatsinks on the GRC and YM2610. I mean I know the YM2610 can get warm and I suppose the GRC could also...but is that really necessary?
 

pier

Crazed MVS Addict
Joined
Jan 24, 2020
Posts
137
Would have to be a first for me to see heatsinks on the GRC and YM2610. I mean I know the YM2610 can get warm and I suppose the GRC could also...but is that really necessary?
they were not necessary but i had those spare heatsinc and i used to try if the temps would had gone down. by the way i'd like to try also the mkl stereo mod, do you know anyone who can sell me a preassembled smd version?
 

pier

Crazed MVS Addict
Joined
Jan 24, 2020
Posts
137
This MV-1B is infamous? Is there another thread about it you can link?

What is that mod with the sub board doing?
it was an old thread of mine. i bought it for cheap with the z80 error, i finally realized that the issue was the faulty ym2610.
 

DaisyAge

B. Jenet's Firstmate
Joined
Jun 10, 2018
Posts
419
It's SMD but I remember a THT rework on oshpark somewhere: https://oshpark.com/shared_projects/q6nKRQBW
Was that the thread about flattening the MV1B? Thought I sold that board to Finch. Anyway the soldering for audio looks pretty shoddy and you should tap better spots on the board, especially the one you have glued to the connector.
 

pier

Crazed MVS Addict
Joined
Jan 24, 2020
Posts
137
It's SMD but I remember a THT rework on oshpark somewhere: https://oshpark.com/shared_projects/q6nKRQBW
Was that the thread about flattening the MV1B? Thought I sold that board to Finch. Anyway the soldering for audio looks pretty shoddy and you should tap better spots on the board, especially the one you have glued to the connector.
About the smd revision i am searching for a prebuild one because if i would buy parts it will cost me more shippings than a premade one with all components already soldered. I desoldered everything and removed the 5v mod but the problem still persists. neogeo bios opening sound is good but others sounds aren't good.
 

pier

Crazed MVS Addict
Joined
Jan 24, 2020
Posts
137
i fixed it. there was a trace cutted under the cart slot.
 
Top