AV Famicom help needed

FAT$TACKS

Not Average Joe., Not Average Homeowner., Not Aver
As stated in the title I've found myself in need of help with an AV Famicom issue.

This is going to sound strange but here it is.

The games start up but most just are frozen on their title screen. With the exception of Salamander. It starts up and the little fireball comes spinning out and then resets and the same thing happens again. It never gets past the title screen or goes to demo mode.

Also, the controllers do nothing.

I'm curious if anyone has ever seen this issue before.

The console was recently RGB modded and this is the first time I've attempted to use it. It tested good before it was shipped so I don't believe that has anything to do with it. I hope it is just something came loose from shipping, but I've no tool to open the system with.

Any chance this is an issue with the AC adapter? The shell is starting to come off and such and I'm sure as old as it is that has been dropped before it became mine.

Can anyone tell me what that type of security tool is and know where I can get one hopefully shipped here before the holiday.

I would be thankful for any offered suggestions.

If needed I can get some video of it.
 
Last edited:

aha2940

AH, A, COLUMBIAN!,
The first step would be to clean the carts and slot throughly. Then, try a different AC adapter. Remember the AV Famicom is 10V, 850mA, center-negative. A Sega Genesis Model 1 adapter works fine. Anyway, the good part is that AV Famicoms are easy to fix, and components are off the shelf (except for CPU, PPU and that hellish custom chip that only the AV Famicom has) but those parts very rarely fail.

Regards.
 

FAT$TACKS

Not Average Joe., Not Average Homeowner., Not Aver
I've given several carts a good cleaning.

I've done my best to clean the connecter in the unit.

Every cart pretty much acts the same. It will load up and start and ends there.

Also, just gave it a try with the model 1 psu, and swapped out the av cables for different ones.

No change I'm afraid.
 

WoodyXP

Setsuna's Owl Keeper,
I have an AV Famicom that exhibits the same issues. To get around it I pull up on the cart a bit after I plug it in. I wiggle the cart up a mm or two, then the game works fine. Give that a shot.
 

FAT$TACKS

Not Average Joe., Not Average Homeowner., Not Aver
Also here is a quick video of what is going on.

So what the video is. It shows the problem where the game just starts up and just keeps resetting on salamander, There is a bit of a pause at the start but that is my system switching over. Then I load up excitebike. It takes a bit for things to switch over again, so after it loads I hit reset to start it over. Then it plays the music and nothing every happens after that. after that it was just me playing around with another cart but that was unrelated to the issue


Also, no luck on the cart wiggles and such. I've one game that is not in the shell that I've been trying it with also.
 
Last edited:

GohanX

Hollywood Hulk Gohan
Is this using etim's kit? You might want to open it up and reseat the kit and try it out.

The normal way to install the kit is to replace the PPU with a socket, and the kit sits in that socket. It wouldn't take a lot of force to knock the kit out of the socket just enough to cause all kinds of silliness, and the USPS using the package as a soccerball could do it.
 

FAT$TACKS

Not Average Joe., Not Average Homeowner., Not Aver
I'll give that a try. I figured out what tools I need and was able to get them on amazon so I should have them by Wednesday.

I am willing to bet that will fix it. It was 100% working before it was shipped back and we all know how those packages get treated.
 

Kiel

All About Shooters Mod., If you fuck with me, I'll
Is this using etim's kit? You might want to open it up and reseat the kit and try it out.

The normal way to install the kit is to replace the PPU with a socket, and the kit sits in that socket. It wouldn't take a lot of force to knock the kit out of the socket just enough to cause all kinds of silliness, and the USPS using the package as a soccerball could do it.

This is my thought as well, I've had that happen durin shipping for a twin famicom. The board on those is mounted on the underside of the nes so gravity and rough handling caused it to come out of the socket enough to fuck with the works.
 

ebinsugewa

Giga Shock!!
Does the Fami have some sort of watchdog circuitry? Seems like that's what's happening, but I don't know dick about the internals.
 

Skips

Giga Shock!!
If re-seating the RGB kit does not fix the problem I would try replacing the CPU and or PPU. Most problems I run into with the Famicom/NES tend to be a faulty PPU and or CPU (sometimes both). The PPU would be an easy replacement if you can find a spare one since it should be socketed on the RGB kit. The CPU would be more of a pain in the ass since it would need to be desoldered. From what the video is showing I would lean more towards CPU and or possibly a faulty reset switch. You can use a CPU and PPU from the US front loader (since those can be found for dirt cheap due to bad pin connectors).
 

HMG

H = Heinously, M = Massive, G = Gonad,
When it comes to NES/FC, the CPU and PPU are pretty well segregated, which makes diagnostics easier. Audio and code problems are the CPU's, anything graphic is the PPU. If your games are constantly crashing or the audio freezes, check the CPU.
 

ebinsugewa

Giga Shock!!
I'm with HMG here. If you had misplaced sprites or other graphical distortions I would worry about the PPU. Unfortunately if you can't find a toaster locally I'm not sure where you'd buy a CPU from. I know Mike's Arcade has 2A03Hs but I think those are VS. System etc. only.
 

FAT$TACKS

Not Average Joe., Not Average Homeowner., Not Aver
Tools to get into it are scheduled to be here tomorrow.. so hopefully I'll have some good news soon.
 

FAT$TACKS

Not Average Joe., Not Average Homeowner., Not Aver
Got the tool I needed in today.

Sadly, after re-seating things it still does not work.

Not much else I can do so looks like I'll have to have it looked at.
 

Kiel

All About Shooters Mod., If you fuck with me, I'll
Problem solved! It was indeed the CPU, works just fine after replacing it with another one.
 

Voultar

Kabuki Klasher
Every Famicom/NES that passes by my shop, (regardless of the repair) receives a set of these as a standard.

2uojm1u.jpg
 

FAT$TACKS

Not Average Joe., Not Average Homeowner., Not Aver
Just for fun here is an update. When the unit arrived this time it would not power on. Opened it up and everything that could be loose was. I guess the postal system has it in for me. Oh.. that guy.. fuck him.

Works great and I'm looking forward to getting to play some games now.
 

Skips

Giga Shock!!
Just for fun here is an update. When the unit arrived this time it would not power on. Opened it up and everything that could be loose was. I guess the postal system has it in for me. Oh.. that guy.. fuck him.

Works great and I'm looking forward to getting to play some games now.

Now you just gotta pop an RGB kit in that bitch and you will be golden!
 
Top