Sony Trinitron PVM 20M2MDE top of picture skewed.

anarchyutopia

Bashful Neophyte
Hello everyone,

I recently bought a Sony Trinitron PVM 20M2MDE and a Scart to BNC adapter to use with my Neo Geo AES.

I used it for the first time and as you can see from the images below it is a bit skewed at the top. The NeoGeo works perfectly plugged directly via scart into another TV.

I've ordered another Scart to BNC adapter in case that is the issue, does anyone know if a setting could correct this?

IMG_0558.jpg

IMG_0553.jpg
 

anarchyutopia

Bashful Neophyte
Some further diagnostics here. On overscan, the skewing disappears, on underscan it is still there which leads me to think it is an issue with the SCART to BNC adapter. I don't think it is magnetic interference on the monitor itself because it is a medical grade monitor, I could be wrong though.

Overscan

overscan.jpg

Underscan

underscan.jpg
 

Dochartaigh

Another Striker
If my memory serves AES uses a non-standard sync signal (many consoles do). Try an Extron RGB box (maybe $15-20 off eBay, although the top tier units can be nearly $100) with the SERR dipswitch turned on.

Your monitor could also have an issue, but it's most likely the above. Plus those Extron RGB boxes are super useful for many different things too.
 

DaisyAge

B. Jenet's Firstmate
It's also worth trying some bnc termination caps. Usually 75 Ohms. You would just want one for each of the 'OUT's including sync
 

Dochartaigh

Another Striker
It's also worth trying some bnc termination caps. Usually 75 Ohms. You would just want one for each of the 'OUT's including sync
I've only had that make the picture too light or less contrasty as I want, but I guess it's possible it might do something else weird to sync maybe...

The PVM-20M2 auto-terminates though, and while that feature could be broken I've owned a ton of these and it has always worked.
 
Last edited:

DaisyAge

B. Jenet's Firstmate
I've only had that make the picture too light or less contrasty as I want, but I guess it's possible it might do something else weird to sync maybe...

The PVM-20M2 auto-terminates though, and while that feature could be broken I've owned a ton of these and it has always worked.

Screenshot 2021-01-24 163115.png

These are for a WEGA Trinitron set but see if there's similar adjustments in the service menu. Looks like the top pincushion setting might help out
 
Top