My neo is not working :(

Gowcaizer

Armored Scrum Object
Joined
May 30, 2005
Posts
260
well it happened after almost 15 years for very first time :oh_no: it just doesnt turns on, not being a hardware guy and because it was a gift and i dont want to buy another one, I wanted to ask, Who can really fix a Neo Geo AES here? :help:
 

Xian Xi

JammaNationX,
15 Year Member
Joined
Dec 1, 2005
Posts
27,751
Sup Sol.

A lot of people can fix it but what exactly were you doing before it died? Did you try another power supply?
 

channelmaniac

Mr Neo Fix-it
15 Year Member
Joined
Nov 29, 2005
Posts
4,275
+1 on checking the power supply, especially if it's not doing a single thing on the screen.
 

Gowcaizer

Armored Scrum Object
Joined
May 30, 2005
Posts
260
Thank you guys, I just tried with one of those multivoltage ac adapters and it turned on again, so now i know that at least that is part of the problem, but i tried about 6 different aes and no one worked i just see either a black screen or a screen with many errors on it, damn :oh_no: what do you think? is it possible that is because of the wrong ac adapter voltage or something like that? :conf:, thanks!!
 

Xian Xi

JammaNationX,
15 Year Member
Joined
Dec 1, 2005
Posts
27,751
Make sure the power supply is the correct voltage AND tip polarity. Neo is center negative.
 

rattanee

n00b
Joined
May 15, 2010
Posts
14
I've never handled an AES so no idea about it's consumption, but you may want to check if your replacement powersupply can output the same amps as the previous... not enough amps could also stop games from booting correctly.
 

channelmaniac

Mr Neo Fix-it
15 Year Member
Joined
Nov 29, 2005
Posts
4,275
Most multi-voltage adapters won't have enough current to run the AES.
 
Top