Kyotaro cabinet monitor help needed

LWK

Earl of Sexyheim
Got this weird issue where sometimes the monitor just doesnt turn on. When it does turn on, it looks fine. The internals have a plug hooked to a power strip type connector. Any advice? Should I reroute it to the power supply by slicing into that cable? I think it'd work every time, if I just plugged that cable into a direct outlet outside of the cabinet and made it all one switch. It's a weird issue for sure.
 

LWK

Earl of Sexyheim
I'd really like to know what the cause as is for it not powering, does anyone here have pictures of the internals of a kyotaro cabinet?
 

arcade game

Galford's Armourer
I'd really like to know what the cause as is for it not powering, does anyone here have pictures of the internals of a kyotaro cabinet?
Here you go, this is a old picture I have when I was taking apart my kyotaro29
nothing special to see here, only thing missing in this picture is
the power suply, basically black wire for monitor chassis and grey cable for fluorescent light, that's it
next time when you cabinet doesn't turn on check your power suply to se if it's on, if it is on the probably a cold solder joint on your chassis
 
Last edited:

LWK

Earl of Sexyheim
Repaired. Cold joint. I think it was the worst type of cold joint as it was topside cold to the ac connector.
 

LWK

Earl of Sexyheim
I repaired this. I reflowed the entire chassis, and did a full recap. It solved it. If it was some cold joint and causing HV shut down, this FIXED my issue, it powers every time so far without fail. Lemme warn you though, if you are unlucky enough to have a Nanao MS8-29FSG/FAK. You might fry off those traces on the smaller boards unless you got a temperature controlled soldering set up. I have jumpers like crazy on this thing. Kyotaro came out in 1993, and its 2014, so I shotgunned it.
 
Last edited:

loegan43

I've served my time in the Dark Army., Have you?,
Congrats LWK. Glad you got it up and working consistently again.
 
Top