Blast City Club

codecrank

Whip's Subordinate
Joined
May 2, 2011
Posts
1,750
So I finally got a Sun PSU thanks to Tyranix and thanks to 300wins for hooking me up with a power extension cable, finally got it all setup and it works great :D

View attachment 20767
Not as clean as I wanted it and there is NO WAY to mount it all on the board :(

nice and clean :D if you want a new USB A->B cables, I have a box full at work I'll just mail you one.

interesting , you have the bass city panel lock bracket, yet you also have the stainless steel anti-tipping footer, where did you find the footer ??? :)
 

dgame

Cheng's Errand Boy
Joined
Jun 6, 2012
Posts
112
That footer comes on the Bass Fishing. It is used to attach the cabinet to the pedestal.
 

Kid Panda

The Chinese Kid
Joined
Jun 13, 2010
Posts
12,507
Panda, that looks real good. How did you go about getting power to the sun psu? I ran a cable out the back to the service outlet, but would prefer to connect it internally.
You know that 3 pin connector on the I/O board? 300wins hooked me up with a extension cable that he had made and it was extra so he hooked me up. It looks pretty easy to make so you could just get the plugs and make yourself one :D

nice and clean :D if you want a new USB A->B cables, I have a box full at work I'll just mail you one.

interesting , you have the bass city panel lock bracket, yet you also have the stainless steel anti-tipping footer, where did you find the footer ??? :)

The USB cable came with the I/O, that's why it's so dirty :lolz: I'd like to get a USB cable that was shorter and had a smaller plug sheath on it, you may not be able to tell, but the cable is pretty much right up against the mobo. The footer was actually on my cab when I got it, I also have the standup spacer as well. Will most likely chuck that thing in the trash as I'll never use it.
 

kuze

Naomi Yamazaki's Wingman
Joined
Apr 20, 2013
Posts
2,404
Nice setup kp! It does rather look like the Sun PSU could be crammed on there though... Has anyone managed it before?
 

everten

Edo Express Delivery Guy
Joined
Sep 2, 2012
Posts
342
You know that 3 pin connector on the I/O board? 300wins hooked me up with a extension cable that he had made and it was extra so he hooked me up. It looks pretty easy to make so you could just get the plugs and make yourself one :D

Yeah, I think skate told me you could get power there too. I just need to find the right connector.
 

HDRchampion

Before you sell me something, ask how well my baby
Joined
Mar 30, 2010
Posts
4,338
Does anyone have a CPS2 18 in 1 PCB? I seem to be having an issue with it w/ my blast city cab. The 18 in 1 works on my Atomiswave & Astro City but for some reason a no go on the Blast. Anyone have this issue? I get the Exception Error screen.
 

Reclaimer

Haomaru's Blade Shiner
Joined
May 17, 2014
Posts
682
So I finally got a Sun PSU thanks to Tyranix and thanks to 300wins for hooking me up with a power extension cable, finally got it all setup and it works great :D

Looking nice!

Why do you need that sweet sun though, doesn't the cab PSU power the naomi? All the ones I've seen power a Naomi + netdimm straight from the cab.
 

codecrank

Whip's Subordinate
Joined
May 2, 2011
Posts
1,750
The USB cable came with the I/O, that's why it's so dirty :lolz: I'd like to get a USB cable that was shorter and had a smaller plug sheath on it, you may not be able to tell, but the cable is pretty much right up against the mobo. The footer was actually on my cab when I got it, I also have the standup spacer as well. Will most likely chuck that thing in the trash as I'll never use it.

yeah I got one an i/o with the cables like that from hklegends, super grimy and all :)

this might even save you some room :D
http://www.dhgate.com/product/right-angled-90-degree-usb-2-0-a-male-b-male/148851078.html
Right%20Angled%2090%20degree%20USB%202.0%20A%20Male%20-%20B%20Male%20Printer%20cable%2050cm.jpg

man, if there was a way to mount the psu sideways it could fit I htink
 

Lemony Vengeance

Mitt Romney's Hairdresser,
Joined
Jan 30, 2012
Posts
4,201
Looking nice!

Why do you need that sweet sun though, doesn't the cab PSU power the naomi? All the ones I've seen power a Naomi + netdimm straight from the cab.

The Blast City PSU really struggles with netbooting, at least in my cab. I would get booting problems probably 70% of the time. I added a sun PSU to mine and it now boots without issue 100% of the time :)
 

Jonmkl

Rasputin's Rose Gardener
Joined
Aug 29, 2012
Posts
713
sexy things

Lovely stuff panda! It's really nice to see some clear, well lit shots of the inside of a blast too, especially one this clean. Doesn't seem like there's enough of this stuff online. I've been mildly obsessing over cab wiring myself, hopefully I can get mine looking this nice.

I'll have to keep that in mind about the PSU lemony, if I run into any issues.

Edit: Question, what are the levels on the Blast I/O DC output? +5V and +12V?
 
Last edited:

codecrank

Whip's Subordinate
Joined
May 2, 2011
Posts
1,750
Edit: Question, what are the levels on the Blast I/O DC output? +5V and +12V?

3.3v , 5v, 12v ( 5v and 3.3v are adjustable )

I have 2 blasts, one runs my naomi + carts/netboots no problems. the other needs voltage levels adjustments everytime i swap the naomi in.

capacitors get old over time, more quickly with increased temperatures. both of my PSUs had a dead fan when I got them so that didn't help... one day I'll recap it and see if that fixes it.
 
Last edited:

Westcb

Give an Azn, A Break Here!,
Joined
May 17, 2012
Posts
1,190
3.3v , 5v, 12v ( 5v and 3.3v are adjustable )

I have 2 blasts, one runs my naomi + carts/netboots no problems. the other needs voltage levels adjustments everytime i swap the naomi in.

capacitors get old over time, more quickly with increased temperatures. both of my PSUs had a dead fan when I got them so that didn't help... one day I'll recap it and see if that fixes it.


I recapped my Astro and NAC power supplies, I been meaning to get around to the blasts next. If I get around to doing mine before you I'll make us some capkits :-) if you jump in before me... get me the cap values bud.


Sent from my iPad using Tapatalk
 

everten

Edo Express Delivery Guy
Joined
Sep 2, 2012
Posts
342
I just moved my blast down in to the basement and the monitor flaked out and stopped showing red. I switched to the built in VGA cable instead of running through the I/O and everything looks normal again after adjusting the contrast and brightness a bit. Maybe a loose wire on the jamma harness, didn't bother to troubleshoot.

The picture on the screen looks a hell of a lot better using the built in VGA. Does the Capcom I/O degrade the image quality? Everything looks sharper, better contrast, etc.
 

codecrank

Whip's Subordinate
Joined
May 2, 2011
Posts
1,750
my buddy got some new stuff for his blast.

FA Nippon mesh tops , matching buttons and overlay.
15214870903_3f18bf1269_c.jpg

got it all put together tonight, looks different for sure, not so jolly but aesthetically pleasing.

15695262869_974e7ff5c5_b.jpg


it was a bitch to cut all those holes.. the stuff is thick, but adhesive is crap.

and yes, I told him to finish cleaning his cab :lolz:
 
Last edited:
Top