Blast City Club

codecrank

Whip's Subordinate
Joined
May 2, 2011
Posts
1,750
mmmmmmmmmmmmmmmmm m&m minis


Also working on a Ikari warriors panel, but after several beers Dan decided to make me a left handed Ikari panel :-x so that will be on hold for a bit haha

no way man, you said Let's make a Buriki One panel ;)

really nice to finally meet you in person Wes, you'll have to stop by again next time you're in town !
 

todosnk

Crossed Swords Squire
10 Year Member
Joined
Mar 31, 2010
Posts
187
Thanks :D I really enjoy fixing and cleaning bit by bit :)

I received a new amp today. When I took the PSU out to replace it, I found the following:

amp1.jpg

Left one is the "new" one, right one is the "old one". There is difference on lenght between those, and when I mount the new one inside the PSU, it gets really, really tight - you can see it close and touching the other metal piece.

is this normal? I guess the amp I received today is a new revision? Will it work on my Blast or do I need a backout plan? :D

I will not power it on until someone confirms it is safe :D

See how tight it fits now:

amp2.jpg

EDIT: tried right now and works perfectly, finnally sound is back!

@Codecrank, I received your 001 loom today as well. I will be trying it tonight :)
Do I need to plug all wires, or is there any part that I should not be plugging (I guess there is no mismatch possible since all the plugs are different, but just want to be sure that I plug the correct ones) :D
 
Last edited:

codecrank

Whip's Subordinate
Joined
May 2, 2011
Posts
1,750
cool !

the large aluminum heatsinks don't conduct any electricity. doesn't matter if they touch the PSU case. you can always cut it down if you're paranoid.

about the 001 loom. you can't really screw up... see the wiki for details.

hope that take care of it :D
 

todosnk

Crossed Swords Squire
10 Year Member
Joined
Mar 31, 2010
Posts
187
Cool :D

Just did the 001 loom :). I set the speaker selection to "speaker" since I will still use jamma boards for a while.

Found these two extra plugs in the 001 loom that are not in the original harness. Where do these two connect to?
Not needed?

IMG_20150126_194202.jpg
 

Chempop

BESTEST Buttrider in chat.Officially No.10 at Schm
Joined
Oct 12, 2010
Posts
3,024
Glad sound is back! The 001 loom has those two white JVS plugs that you obviously wouldn’t connect to anything if you are just running JAMMA.
 

todosnk

Crossed Swords Squire
10 Year Member
Joined
Mar 31, 2010
Posts
187
:D :D :D

The 001 loom is working perfectly fine, thanks codecrank!
I am really thankful for all your support guys. Things would have not turned out that good without your advice and support.

I'll be doing a Blast City guide in spanish sometime later on :D
 
Last edited:

grendelrt

Super Spy Agent
Joined
Apr 22, 2014
Posts
623
I you can use those 2 power plugs on a Naomi setup for power if you are not net booting or using a gd Rom (should just go sun PSU if you are)
 

codecrank

Whip's Subordinate
Joined
May 2, 2011
Posts
1,750
I you can use those 2 power plugs on a Naomi setup for power if you are not net booting or using a gd Rom (should just go sun PSU if you are)

you can netboot just fine without a SUN psu, it all depends on the milage on your blast's PSU ;)
 

300wins

Conan The Librarian,
Joined
May 29, 2003
Posts
1,631
you can netboot just fine without a SUN psu, it all depends on the milage on your blast's PSU ;)

The problem with doing that is that is puts extra wear and tear on the Blast psu. Sun psu are a little easier to get (as well as being cheaper to get shipped) than a Blast psu.
Though I was guilty of running a netboot on my Blast psu for a while when I had a dozen Blast cabs. :eek:
 

grendelrt

Super Spy Agent
Joined
Apr 22, 2014
Posts
623
The problem with doing that is that is puts extra wear and tear on the Blast psu. Sun psu are a little easier to get (as well as being cheaper to get shipped) than a Blast psu.
Though I was guilty of running a netboot on my Blast psu for a while when I had a dozen Blast cabs. :eek:

Yeah I had read that it was hit or miss depending on the condition of the PSU, if its putting that much strain on it I would rather pay 40 bucks for a sun psu and not worry about it. The other advantage is my Blast PSU is set up for MVS and CPS2 and my Sun is set up for Naomi, which means I dont have to futz around with the voltages.
 

sparksterz

Camel Slug
Joined
May 2, 2013
Posts
510
Agreed...it cost me about $120 to get my back-up Blast City PSU shipped through Celga post fees. Much more worth it to spend only $45 and strap a SUN PSU into the mix.
 

Westcb

Give an Azn, A Break Here!,
Joined
May 17, 2012
Posts
1,190
Agreed...it cost me about $120 to get my back-up Blast City PSU shipped through Celga post fees. Much more worth it to spend only $45 and strap a SUN PSU into the mix.


Or spend 10 bucks and use a pc power supply you might have in your closet :-)
ImageUploadedByTapatalk1422414558.539507.jpg
 

Lemony Vengeance

Mitt Romney's Hairdresser,
Joined
Jan 30, 2012
Posts
4,201
The issue with this is that some (most) PC PSUs don't have an adjustable 5v rail. The highest wattage psu may be able to run your Naomi no problem, but with a netdimm, they may struggle. I should know, I've tried that as well. He SUN PSU is still king.
 

kuze

Juzoh's Gym Trainer
10 Year Member
Joined
Apr 20, 2013
Posts
2,470
The issue with this is that some (most) PC PSUs don't have an adjustable 5v rail. The highest wattage psu may be able to run your Naomi no problem, but with a netdimm, they may struggle. I should know, I've tried that as well. He SUN PSU is still king.

It actually doesn't require a high wattage PSU (175w works fine for me), but no adjustable 5v line is definitely a limitation with standard PC PSUs.
 

Lemony Vengeance

Mitt Romney's Hairdresser,
Joined
Jan 30, 2012
Posts
4,201
It actually doesn't require a high wattage PSU (175w works fine for me), but no adjustable 5v line is definitely a limitation with standard PC PSUs.

I'm running a 115W PSU I put in my HD cab and it netboots without issue. It ALSO has a pot for the 5v Rail. :D
 

Westcb

Give an Azn, A Break Here!,
Joined
May 17, 2012
Posts
1,190
Got me some new speakers for one of my blasts tonight, the set in there were falling apart so hope these hold up better.ImageUploadedByTapatalk1422668515.592184.jpgImageUploadedByTapatalk1422668524.041665.jpg
 

bartre

Haomaru's Blade Shiner
10 Year Member
Joined
Oct 27, 2009
Posts
681
very nice!
where'd you end up getting em?

only places i could find that actually had em were asking $100 per speaker.......:thevt:
 

Westcb

Give an Azn, A Break Here!,
Joined
May 17, 2012
Posts
1,190
very nice!

where'd you end up getting em?



only places i could find that actually had em were asking $100 per speaker.......:thevt:


Arcade parts shop, they don't sell to the public though so I enlisted some help :-) not sure how much of a PITA it was for him to get these for me so I'll let him speak up if he can get more or not.
 

Lemony Vengeance

Mitt Romney's Hairdresser,
Joined
Jan 30, 2012
Posts
4,201
Arcade parts shop, they don't sell to the public though so I enlisted some help :-) not sure how much of a PITA it was for him to get these for me so I'll let him speak up if he can get more or not.

I think I know who helped :)
 

todosnk

Crossed Swords Squire
10 Year Member
Joined
Mar 31, 2010
Posts
187
Received the ArcadeVGA 5000 and PSU fan replacement this week :)

Finally I could plug the Hyperspinned' PC to the Blast, and thanks to the 001 loom get stereo audio from it too!
I am truly happy now with the Blast, image is really good (Windows boots at 640x480 and mame gets the original games' resolutions), sounds amazing on stereo games, control wise really comfortable... I am in love again :D
Plugged the VGA through JPAC, and set only 31khz jumper on it, while doing the same on the Blast.
Played last night with friends for a couple of hours, it was so much fun, and got a Final Fight original marquee for free :D

"Only" things left now are to get the extra 2 button harness (on the way), deal with convergence (I am not really in hurry, even as it is now, it gives the monitor a sort of "retro" appearance too :D ), and set up 80% of the remaining emulators on Hyperspin :D :D

The fun part continues!

IMG_20150201_144846.jpg
IMG_20150201_145133.jpg
IMG_20150201_145252.jpg
IMG_20150201_145219.jpg

I'd be interested in some spare speakers too, we never know when we will need them in the future :D
 
Last edited:

ReplicaX

Unholy Custom Rank.,
10 Year Member
Joined
Aug 23, 2008
Posts
2,420
Received the ArcadeVGA 5000 and PSU fan replacement this week :)

Finally I could plug the Hyperspinned' PC to the Blast, and thanks to the 001 loom get stereo audio from it too!
I am truly happy now with the Blast, image is really good (Windows boots at 640x480 and mame gets the original games' resolutions), sounds amazing on stereo games, control wise really comfortable... I am in love again :D
Plugged the VGA through JPAC, and set only 31khz jumper on it, while doing the same on the Blast.
Played last night with friends for a couple of hours, it was so much fun, and got a Final Fight original marquee for free :D

Looking good!
 
Top