Watchdog reset ?

_rm_

Giga Shock!!
I'm a total noob in terms of repairs, but i think you can check this:

grab a logic probe and probe the reset pin as soon as you power the board up. The pin should go low for a brief moment and then High. If it's stuck low or always high, you must follow the traces back and probably one of the near IC's (a 7407 for example) is dead or has a static output.

Hope this helps
 
Last edited:

pulstar

Mickey's Coach
Is the watchdog reset screen a special error screen in Primal Rage? Could be work RAM related or one of the ICs connected between the CPU and the work RAM.
 

White Devil

Hardened Shock Trooper
Is the watchdog reset screen a special error screen in Primal Rage? Could be work RAM related or one of the ICs connected between the CPU and the work RAM.

i did a ram test, i actually did all the tests possible within the board, this is the only one that came up

http://imgur.com/9HaBYpt

heres a pic of the actual error screen

http://imgur.com/kTVqbp4

I'm a total noob in terms of repairs, but i think you can check this:

grab a logic probe and probe the reset pin as soon as you power the board up. The pin should go low for a brief moment and then High. If it's stuck low or always high, you must follow the traces back and probably one of the near IC's (a 7407 for example) is dead or has a static output.

Hope this helps

it will help when i develop some mild form of an understanding as to what any of that means. i'm still a major noob here. though i appreciate the time you took to respond
 

pulstar

Mickey's Coach
It looks like ram 0-0 is throwing an error. You'd have to find what IC that is and do as _rm_ says and get the logic probe on it and the ICs connected to it.
 

White Devil

Hardened Shock Trooper
Will this do the trick?

It looks like ram 0-0 is throwing an error. You'd have to find what IC that is and do as _rm_ says and get the logic probe on it and the ICs connected to it.

I'm a total noob in terms of repairs, but i think you can check this:

grab a logic probe and probe the reset pin as soon as you power the board up. The pin should go low for a brief moment and then High. If it's stuck low or always high, you must follow the traces back and probably one of the near IC's (a 7407 for example) is dead or has a static output.

Hope this helps


Is this what I need? Or would you gentlemen recommend something else?

Elenco Electronics LP-560 Logic Probe https://www.amazon.com/dp/B000Z9HAP4/ref=cm_sw_r_awd_22C7ub1MK0TSE
https://www.amazon.com/dp/B000Z9HAP4/ref=cm_sw_r_awd_22C7ub1MK0TSE

Also, I disconnected the audio line to RCA converter and it seems to have stopped. I am going to let it run for a bit longer later to confirm that it's not just a coincidence.
 

pulstar

Mickey's Coach
I'd say it changes from PCB to PCB. You should be able to get into the test menu by pressing the test button and choosing the tests you want.

Did you have a look at the operators' manual? MOB Checksum is Moving Objects Checksum. Can you get into the game now? Does it have any sprite problems?
 

White Devil

Hardened Shock Trooper
I was able to get into the game before just I wouldn't be able to finish more than two matches before the watchdog screen would happen, in some cases it would come up during the first match.
Before I put the speaker line converter on I only saw that screen when I adjusted the 5V dial. And that happens twice like a month ago
 

pulstar

Mickey's Coach
Quite a strange little error there. Is it always after that amount of time that the error will show? Are any of the ICs abnormally hot afterwards? If you turn it off then straight on again, does the error come up faster?
 

White Devil

Hardened Shock Trooper
Quite a strange little error there. Is it always after that amount of time that the error will show? Are any of the ICs abnormally hot afterwards? If you turn it off then straight on again, does the error come up faster?

It did happen faster enter it reset but after I took the speaker line to RCA converter off it ran for over an hour just fine. Then I had to go to work and turned it off.
 

White Devil

Hardened Shock Trooper
So I took the audio converter off and no problem. I re did the Molex connecter thinkig I may have crossed some wires and it worked great for 30 minutes at a time. Then the screen.
Could it be sucking power?
I am ordering the logic probe so I will be following the advice above soon
 
Top