S-video and stereo output from Japanese Neo-Geo console?

Phungus

Timid Neo Newbie
Like the subject says...

I currently only have a mono audio/RCA video output cable for my Japanese Neo Geo console. Are special modifications needed for S-video and stereo output, or is there somewhere I could find a stereo cable? I already saw the guy selling mods for $100 but would like to find an easier way...haven't heard what the developer BIOS allows you to do either.

Thanks in advance.
 

JMKurtz

Tech Support Moderator,
Yes, special work is needed to get SVideo from the Neo system. You already have Stereo (from the headphone jack only). The A/V port on the back is MONO only. When I do the "stereo" mod, it's simply putting RCA jacks on the back of the system and picking up the audio signals, which just about anyone could do, however, the SVideo mod is a bit more complicated and requires a good underatanding of electronics to do. It's not a simple PSX style mod where you just solder a couple wires.

The Developers Debug Bios allows you to get into a game while it's running. You can change things like language, mode (mvs or home), and a bunch of other settings that are unique to each game. You can also access DEBUG DIP settings, which allows you access to game debugging info & settings (like level skipping, full power, etc). These settings are different for each game
smile.gif


Jeff
 

Phungus

Timid Neo Newbie
Thanks for the quick response.

That sounds awesome, as long as the output is of true S-video quality without any distortion. My only reservation is having holes drilled into the back of my beloved system...
frown.gif


Thanks again,
Dylan
 

Phungus

Timid Neo Newbie
By the way, how is the S-video quality, and how many holes are drilled into the back of the Neo Geo with this mod?

Thanks,
Dylan
 

JMKurtz

Tech Support Moderator,
The SVideo picture is considerably sharper than the composite or RF output - no dot crawl and the colors are more balanced, but of course, not as good as RGB.

For the SVideo mod, just one hole. For the Stereo jacks, 2 more, a total of 3. I use all surface mounted parts now so there are NO visible screws and all are VERY CLEAN and professional looking. I use top of the line parts for better performance (screw-lock SVideo jack and gold plated RCA color coded audio jacks).

For those that get the 4X bios mod (2 switches - one for ENG/JAP one for MVS/HOME), I've found a new surface mount switch to use for that too, so no screws on the switches now either!

Jeff
 

Phungus

Timid Neo Newbie
So the developer's debug BIOS and the 4x BIOS are separate? Does the 4x BIOS have all of the functionality of the debug BIOS? Is it the same price?

Does the neo-geo function exactly as before, or are there BIOS intro screens, etc. that come up?

Thanks,
Dylan
 

RyoGeo

Global Moderator, Voice of Reason,
Hey, Jeff. I'm confused now too. Pardon my ignorance, but I thought all of the BIOS stuff was available from an on screen interface. I am confused by the 4x switch to which you are now refering. When I get my fricking yard in I am planning on getting a MOD from you so I wanted to get the skinny on the switch. I was planning on getting the S, audio and onscreen bios mod, but may want the 4x as well.

Thanks for this BBS. This is awesome!
 

JMKurtz

Tech Support Moderator,
The 4X Bios is the very same thing as the normal Debug Bios, except for it has 2 switches hooked up to it so that you can POWER your machine in a certain mode of choice rather than having to do it through the menu each time.

So, if you like JAP/MVS one week, you set it to start in that mode. If you like ENGLISH/HOME the next week, you set it to that.

It's more of a convience feature, but you're not missing anything if you don't have it -- all the functionality is still there in the 4X as in the Original Debug Bios.

I hope this helps a little
smile.gif


Jeff
 

RyoGeo

Global Moderator, Voice of Reason,
Actually, it helps a lot. That's exactly what I wanted to know.

Thanks!
biggrin.gif
 
I bought a US System about 9 months ago & it already came with a Mod switch. However it doesn't seem to work with newer games. When I switch it "ON" and power up the system, the screen either goes black or I get red & white lines. Plus it makes a ticking sound thru the tv. Is it suposed to work with all of the games? Do I have a bad chip or is it just outdated? Any suggestions will help...
Thanx
 
Top