Recent distorted sound in a AES cart

HMG

H = Heinously, M = Massive, G = Gonad,
Joined
Apr 3, 2011
Posts
4,969
Game uses PROGBK1, four V ROMs. It was working perfectly recently, then all of a sudden most (but not all) of the music and sound effects are distorted garbage.

PROGBK1 connector is as clean as it will ever be. Could this be a bad jumper, bad PCM chip or bad V ROM?

Tested in two AES systems, same issue in both.
 

jesesfbi

Ninja Combat Warrior
Joined
Jan 23, 2012
Posts
525
Game uses PROGBK1, four V ROMs. It was working perfectly recently, then all of a sudden most (but not all) of the music and sound effects are distorted garbage.

PROGBK1 connector is as clean as it will ever be. Could this be a bad jumper, bad PCM chip or bad V ROM?

Tested in two AES systems, same issue in both.
Th jumper and PCM usually don't go bad so I'll lean towards a bad VRom. What game is it?
 

Xian Xi

JammaNationX,
Joined
Dec 1, 2005
Posts
27,702
Could be V rom, PCM or LS139. You need to pull the vroms and verify them.
 

GadgetUK

Ace Ghost Pilot
Joined
Sep 27, 2013
Posts
1,320
You can try measuring the O (data bus) pins from ground and vcc for resistance. They should have similar resistance levels (to the other pins) in both directions - this can sometimes help point to which chip is at fault. I've proven that recently on my King of Monsters that had garbage sound. The difficulty with that approach is where 2 or more chips output to the same bus - it can be tricky working out which chip is the cause until you remove them from the board. Of course if you have EPROMS it's more likely that bit state has changed in one of them and it just needs reprogramming, that said there's a big difference in the effect of an EPROM losing bit state (few random corrupt sounds etc) and this type of failure where most if not all of the time you hear garbage. I think that's typically caused by one of the chips outputting garbage or incorrect TTL levels on the data bus regardless of whether its being asserted etc.
 
Last edited:

HMG

H = Heinously, M = Massive, G = Gonad,
Joined
Apr 3, 2011
Posts
4,969
Thanks for the suggestions guys, I'll pull the V ROMs and check them out. I don't have an EPROM programmer yet, I can always try swapping the ROMs with an MVS cart for the time being. I hope the PCM chip is good. Hopefully this will be an easy fix.
 

smkdan

Galford's Armourer
Joined
Dec 30, 2009
Posts
452
Can you tell if all of the PCM sound or is distorted is some of it playing back properly? If it's FM synth or the square wave (which isn't used as much, mainly the chiptuney credit insert sounds and Nazca games) then it won't be affected by the VROM parts on the cart so all of that should still sound fine. What about the rest? It can help narrow down the possible causes.
 

HMG

H = Heinously, M = Massive, G = Gonad,
Joined
Apr 3, 2011
Posts
4,969
Some but not all of the sound effects and music are distorted. Voice samples seem to be buried under everything else. No other cart has an issue and the sound is bad in two AES consoles so the problem is probably in the cartridge.
 
Top