NEOSD AES Support thread !

Sunken

Bashful Neophyte
Joined
Mar 19, 2013
Posts
16
I've checked all 4 versions of Garou MOTW and the second intro is missing (I only have the Terry & Geese intro).

My Neo have a Japanese stock BIOS and Neo SD with 1.06 firmware.
 

aha2940

AH, A, COLUMBIAN!,
Joined
Dec 15, 2013
Posts
2,520
I've checked all 4 versions of Garou MOTW and the second intro is missing (I only have the Terry & Geese intro).

My Neo have a Japanese stock BIOS and Neo SD with 1.06 firmware.

Same here.
 

neodev

Neosd Tech
Joined
Nov 28, 2016
Posts
256
Same here.

It seems garou is confusing the continuous highscore save code and causing it to reload the backup ram every loop, thus always showing the same intro. If you set the save mode to Game Change or Off you should see it. We'll look into it.
 

Razoola

Divine Hand of the UniBIOS,
Staff member
Joined
Nov 12, 2002
Posts
4,630
There will be many games with the same issue. Its imperritive that backupRAM is saved at the end of attract mode and then reloaded. This has big implications, espicially on multislot hardware. Games store alot more than just highscores in backupRAM. As you have discovered there is an attract mode counter for example with will cause the same game demo seen to play over and over instead of changing each cycle. Many also place the sound code buffer there and some games even place raster code in this region too.

I found the same issue with NeoGeoLand but its an easy fix so there is no worries about it not being fixed.
 

neodev

Neosd Tech
Joined
Nov 28, 2016
Posts
256
There will be many games with the same issue. Its imperritive that backupRAM is saved at the end of attract mode and then reloaded. This has big implications, espicially on multislot hardware. Games store alot more than just highscores in backupRAM. As you have discovered there is an attract mode counter for example with will cause the same game demo seen to play over and over instead of changing each cycle. Many also place the sound code buffer there and some games even place raster code in this region too.

I found the same issue with NeoGeoLand but its an easy fix so there is no worries about it not being fixed.

Yes, but it's not a backupram save issue, but that garou is clearing a supposedly unused part of the ram in the bios area where I'm storing some state to know if I it's the first time (to load) or not (to save) the ram to the sd.
The fix is just a matter of moving this state var to a different address.
 

Razoola

Divine Hand of the UniBIOS,
Staff member
Joined
Nov 12, 2002
Posts
4,630
Yes, but it's not a backupram save issue, but that garou is clearing a supposedly unused part of the ram in the bios area where I'm storing some state to know if I it's the first time (to load) or not (to save) the ram to the sd.
The fix is just a matter of moving this state var to a different address.

Do you not have a spare internal RAM location you can use?
 

Morden

Somewhere in Europe.,
Joined
Jul 5, 2005
Posts
711
There will be many games with the same issue. Its imperritive that backupRAM is saved at the end of attract mode and then reloaded. This has big implications, espicially on multislot hardware. Games store alot more than just highscores in backupRAM. As you have discovered there is an attract mode counter for example with will cause the same game demo seen to play over and over instead of changing each cycle.

I was just about to report that the issue isn't limited to MotW. I've noticed looped attract mode in World Heroes Perfect, where the same demo fight would display each and every time [and play out in the exact same way, so I guess they're scripted, not cpu vs cpu].
 

Sunken

Bashful Neophyte
Joined
Mar 19, 2013
Posts
16
I don't know if people have tried V-Liner but the game can't boot (the 2 sets) and The Irritating Maze controls don't work as it's intended to be played with a trackball.
 

Morden

Somewhere in Europe.,
Joined
Jul 5, 2005
Posts
711
I don't know if people have tried V-Liner but the game can't boot (the 2 sets) and The Irritating Maze controls don't work as it's intended to be played with a trackball.

I can confirm the V-Liner problem. Just tried it on MV1-FZ. The Neo puts itself in a reset loop, but the only thing I get is the Uni BIOS version info screen, then reset, Uni screen, reset and so on. Both sets. I do remember it booting on a previous firmware. As for Irritating Maze, this is not a NeoSD issue, and as far as I'm aware, there is a cheat mapping the controls to a stick in later versions of the Uni BIOS. I'm still on 2.0.
 

Sunken

Bashful Neophyte
Joined
Mar 19, 2013
Posts
16
I didn't knew about the Unibios hack for the trackball but that would be a great addition to the NEOSD.
 

heihachi

Super Spy Agent
Joined
Jul 11, 2016
Posts
621
I've been having the flickering pixel issue that some have mentioned through out the thread, but it only happens intermittently. Have people figured out what exactly causes this? My AES is a JP 3-6 with replacement power supply, but issue has popped up using the stock supply as well. NeoSD is on the 1.06 firmware. I've had no similar issues with the MVS NeoSD running on an Omega.
 

Morden

Somewhere in Europe.,
Joined
Jul 5, 2005
Posts
711
I didn't knew about the Unibios hack for the trackball but that would be a great addition to the NEOSD.

You mean to have NeoSD patch the game for stick controls? I think you're better off getting a Uni BIOS. I don't see why a Neo Geo owner wouldn't, to be honest. I don't need to mention what it does, but it does A LOT, and whether it's Irritating Maze you want to play, or something else entirely, but with cheats or a "pause menu" for MVS, it's a must have.
 

Shipwreck_00

Armored Scrum Object
Joined
Mar 1, 2016
Posts
259
All I can say is that I've had the NeoSD now for a little over a month and I'm completely satisfied with everything with it. I can't wait to see if some cracks into it and makes it so you can play the NGPC games on it. How awesome would it be to play the NGPC games on the tv.
 

pixeljunkie

Whilst Drunk., I Found God., Booze = Bad.,
Joined
Dec 12, 2003
Posts
5,782
I haven't updated my FW yet - how necessary is it? Does it speed up load times at all?
 

Rot

Calvin & Hobbes, ,
Staff member
Joined
Jul 8, 2003
Posts
11,368
I haven't updated my FW yet - how necessary is it? Does it speed up load times at all?

Pixel pal...

Don't you even read the threads... before you ask a question?

xROTx

PS. If it was a nubster asking this question... they'd get killorz...

...just putting it out there...
 

pixeljunkie

Whilst Drunk., I Found God., Booze = Bad.,
Joined
Dec 12, 2003
Posts
5,782
Pixel pal...

Don't you even read the threads... before you ask a question?

xROTx

PS. If it was a nubster asking this question... they'd get killorz...

...just putting it out there...

That was my bad...I blame alcohol
 

FBX

Quiz Detective
Joined
Aug 7, 2017
Posts
88
So my thread question got locked in the tech forum, but I'm starting to think my issue is my AES3-3 console itself. What the problem is: I noticed black (sometimes white) flickering random pixels in some games I've tested on the NEOSD. The intro to SVC Chaos was showing a fair amount, but now that I've let in run in attract mode for several minutes, they are significantly reduced in frequency. I've already cleaned the contacts a few times, and the console booted to blue screen just fine without a game.
 

neodev

Neosd Tech
Joined
Nov 28, 2016
Posts
256
So my thread question got locked in the tech forum, but I'm starting to think my issue is my AES3-3 console itself. What the problem is: I noticed black (sometimes white) flickering random pixels in some games I've tested on the NEOSD. The intro to SVC Chaos was showing a fair amount, but now that I've let in run in attract mode for several minutes, they are significantly reduced in frequency. I've already cleaned the contacts a few times, and the console booted to blue screen just fine without a game.

Hello

Can you check and post (here or PM) the versions shown in neosd options menu for CHA and PROG ?
 

FBX

Quiz Detective
Joined
Aug 7, 2017
Posts
88
Hello

Can you check and post (here or PM) the versions shown in neosd options menu for CHA and PROG ?

PROG: 1D2F
CHA: BDC4

I see there's been a newer release of the software for NEOSD, so I will update that to see if it helps. Although I'm more inclined to believe the problem may be physical.

Edit: I stand corrected! Updating the firmware to the latest seems to have fixed the issue. I just loaded up SVC Chaos and there were no artifacts this time. My apologies about the false alarm, and thanks for the update!

Edit 2: A friend told me this is a known issue with some AES consoles, and that the trick is to power-cycle the console. He says the issue really is with my console and not the NEOSD.
 
Last edited:

Happosai

Timid Neo Newbie
Joined
Mar 8, 2017
Posts
6
hi there, I've a simple question : how to scale up the size of the neobuilder UI ? I can't see all the UI

test.jpg
 

Rot

Calvin & Hobbes, ,
Staff member
Joined
Jul 8, 2003
Posts
11,368
hi there, I've a simple question : how to scale up the size of the neobuilder UI ? I can't see all the UI

View attachment 46262

How about you read the fact that no one uses the neobuilder on NG.com...

And if you fucking read the forum correctly you'd find that there was a solution to this...

xROTx

PS. I am feeling a bit "aggressive" this evening... my advice... heed all warnings given and READ the fucking forum...

Don't be a lurking bitch...
 

brandonx76

Timid Neo Newbie
Joined
Feb 24, 2017
Posts
5
Hi - having a Neo Geo SD problem - system won't boot with the Neo SD...I had a power outage during an 'erase flash' / 'load rom' process I believe. My system works ok with a a regular cartridge...so I think the problem is with Neo SD. Any suggested steps to recover appreciated. Thank you!
 
Top