Neo Geo AES video problem

gtsamour

Twinkle Star Sprite
Joined
Oct 28, 2007
Posts
33
If i try to open the cartridge we can see anything can help to risolve the problem?
Well i dont see why not. There are videos on youtube on how to open one without causing damage, its pretty easy. Take photo as soon as you open it so you know exactly how to put it back.
 

salvo85

New Challenger
Joined
Apr 2, 2021
Posts
23
I have a question can be the problem in the 2 slots, i don’t know for example unsoldered part on the slots? In this case the diagnose test reveal this type pf problems?
 

gtsamour

Twinkle Star Sprite
Joined
Oct 28, 2007
Posts
33
I have a question can be the problem in the 2 slots, i don’t know for example unsoldered part on the slots? In this case the diagnose test reveal this type pf problems?
No, the diagnostic cannot detect such things. I dont think the problem is a cracked solder point of the slots, anything is possible but you have to go with the most probable, which in this case is a bad cart.
The only way to be certain is to either find another game or another aes console to try.
 

salvo85

New Challenger
Joined
Apr 2, 2021
Posts
23
Hi,

i successfull open the cartridge and i see this:

contact.jpgcontact2.jpgcontact3.jpgcontact4.jpgcontact5.jpg

as you can see everywhere the contact seems ruined (lost the golden contact) so i presume that whe i insert the cart in the console there isn't the correct contact and the correct transmission among them.
You can confirm this theory? if yes you have any idea if it is repairable?

thanks
 

gtsamour

Twinkle Star Sprite
Joined
Oct 28, 2007
Posts
33
Here is a link with scans of a legit cart of Fatal Fury 2 for you to compare (its easier for you since you have it on hand)

From what I can see I think that someone has tined the contacts using solder, a soldering iron and solder wick. This is a method when the contacts are very corroded or damaged somehow. This isn't bad. I have done it on other retro computer expansion slots myself.
So, the cart has been definitely opened in the past by someone else. Was it sold to you as "working" or "untested" ?
The contacts don't lose their gold copper color on their own.

The best way to clean dirty contacts since you have the cart open and have very good access to them, is to rub them with a pencil rubber (the white one prefferably since its softer, or the orange one)

After you clean them as much as you can, them rub the contacts with alcohol.

If that doesn't help then it's probably a bad cart.

Also check for anything suspicious on the other side of the boards. Do the boards look like they have been tampered with (besides the contacts)
 

Xian Xi

JammaNationX,
Joined
Dec 1, 2005
Posts
27,684
You need a stronger PSU, get something with at least 2A output if 9-13v.
 

salvo85

New Challenger
Joined
Apr 2, 2021
Posts
23
You need a stronger PSU, get something with at least 2A output if 9-13v.
If im not in error the original psu was Pro-Pow-E and Pro-Pow3 with:

Original power adapter : 9 -> 11V (unregulated => around ±3V) 1A max
 

Xian Xi

JammaNationX,
Joined
Dec 1, 2005
Posts
27,684
You're comparing a very high quality power supply with the Chinese built one you have now that doesn't even output close to 1A when tested. You'll be lucky to even get 500mA out of it.
 

gtsamour

Twinkle Star Sprite
Joined
Oct 28, 2007
Posts
33
What Xian Xi is saying might be absolutely true.

I'm using a 10V 1.2A PSU and the AES is working perfectly but my PSU is made by SEGA.

Whatever you try be VERY careful of the polarity otherwise you'll fry the console. You need center negative.
 

gtsamour

Twinkle Star Sprite
Joined
Oct 28, 2007
Posts
33
Which psu sega is your for what console
Model No : 1602-05
10V 1.2A
Center negative


There are a few different model numbers with the exact same specs.
You absolutely need center negative and 10V 1.2A

The one in the photo you posted is for the Megadrive 2 and is NOT what you need, it also has the wrong polarity,
 
Last edited:

salvo85

New Challenger
Joined
Apr 2, 2021
Posts
23
Updates: i bought the psu correct:
D910CD3E-8702-40B6-944F-E39080C0105B.jpeg

to find this i bought entire mega drive 1 and in the end i try again to start AES without cart always blue screen, with cart nothing always gargabe
 

salvo85

New Challenger
Joined
Apr 2, 2021
Posts
23
Sum up, i try to clean with the pencil rubber all the electric contact and cleaned ti with alcohol.
I replace the psu with sega psu always screen blue without cartridge always garbage.
The cartridge was used and tested OK.
For other test i don’t have other aes and in this moment i don’t have any cartridge but i bought a new one but will arrive in 13th april.
Do you have other ideas? Or test or do you want other photos...

thanks everyone for your support
 

gtsamour

Twinkle Star Sprite
Joined
Oct 28, 2007
Posts
33
What do you mean "The cartridge was used and tested OK"?
Did they test it in the shop where you bought the Megadrive and it worked?
 

salvo85

New Challenger
Joined
Apr 2, 2021
Posts
23
No sorry for the misundestanding, i wanted to answer your old question, when i bought the game they said me that tested before to send me
 

gtsamour

Twinkle Star Sprite
Joined
Oct 28, 2007
Posts
33
No sorry for the misundestanding, i wanted to answer your old question, when i bought the game they said me that tested before to send me
Oh I see.

Well I guess all you can do now is wait for the other game to come. Unless someone else suggests to try something different.
 

DaisyAge

B. Jenet's Firstmate
Joined
Jun 10, 2018
Posts
420
You could try putting in the cart and starting the AES with top case off and then try slightly pressing on chips to see if you get a different result. Whichever chips cause new things to show up you should write down and then try to replace.
 

salvo85

New Challenger
Joined
Apr 2, 2021
Posts
23
If i understand correctly you want that i put the cart in the aes without the cover, with only the base support, and press the chips on the two pcb? Is not dangerous for the components?
 

DaisyAge

B. Jenet's Firstmate
Joined
Jun 10, 2018
Posts
420
No press on the chips on your neo geo AES. As long as your fingers are dry its fine. Keep the cart together.
 

Neo Alec

,
20 Year Member
Joined
Dec 7, 2000
Posts
9,101
Well, of you do end up swapping the bios, you'd might as well put in the smkdan Diagonstic Bios. I'd be curious to see what it reports back.
 

salvo85

New Challenger
Joined
Apr 2, 2021
Posts
23
Hi to everybody,

some upgrades, after more tests on the cartridge i contacted the seller explained all the problems and tests that we did and he onestly ask me to resend him the game and give me back the money because also he thought that the problem was the cartridge, also if he said that he tests the game and worked before send me.
In meanwhile i bought another game Fatal fury Special from another buyer on ebay and arrived today and......
it WORKED!!!
Immediately i insert the cart and start the console it works
I'm so gracefull to your help and support and i'm so very happy that the problem is not the console.
With calm i controlled the new cart and notice that all contacts have the gold electric contact and are all clean.
I'm so very happy to have this wonderfull fun machine now the next step is buy games but the problem is MONEY!!! they are very expensive (i have also the neo geo CD and the games are more cheap in compare).
I think to buy a MVS to AES converter to save money on the MVS cart, do you use some converter? do you have experience?

Thaks all
 

Xian Xi

JammaNationX,
Joined
Dec 1, 2005
Posts
27,684
Hi,

i successfull open the cartridge and i see this:

View attachment 46767View attachment 46768View attachment 46769View attachment 46770View attachment 46771

as you can see everywhere the contact seems ruined (lost the golden contact) so i presume that whe i insert the cart in the console there isn't the correct contact and the correct transmission among them.
You can confirm this theory? if yes you have any idea if it is repairable?

thanks
If that's how the cart was when you opened it, no wonder why it wasn't working. The PROG and CHAR boards were swapped. When you open an AES/MVS cart, you'll either see the top of the PROG board or the bottom of the CHAR board. If you see the top of the CHAR board then the PCBs were swapped.
 

DaisyAge

B. Jenet's Firstmate
Joined
Jun 10, 2018
Posts
420
Lmfao Xian Xi always dropping the knowledge. Three pages and this guy is the only one to notice that the boards are swapped. Try it out and let us know if that fixes it.
 
Top