Neo geo AES graphic glitch

theboy995

Bashful Neophyte
Joined
May 4, 2017
Posts
14
Hi guys, I have a problem with my AES, it's a serial under 13.xxx and a NEC motherboard. I recently bought baseball stars 2 and I have graphical errors with the game, any solution? Thank you !!

9602A698-1BBE-499F-B258-DD65E00B6199.jpeg
 

maki

Krauser's Shoe Shiner
Joined
Jan 1, 2022
Posts
231
clean the pins on the cart and the slot on the AES

do other games work fine -> most likely the game

I like to test NeoGeo systems with a 161-in-1 multicart, Metal Slug 5, Matrimelee, Garou etc., all games with lots of memory and hard requirements for timings, then there is the DIAG Bios, very helpful
 

theboy995

Bashful Neophyte
Joined
May 4, 2017
Posts
14
clean the pins on the cart and the slot on the AES

do other games work fine -> most likely the game

I like to test NeoGeo systems with a 161-in-1 multicart, Metal Slug 5, Matrimelee, Garou etc., all games with lots of memory and hard requirements for timings, then there is the DIAG Bios, very helpful
no, that didn't work, it also happens to me with metal slug below a horizontal line and in neo turf masters when I throw the ball some black dots appear in the upper left
My console has a brown video card, could that be the problem? should i remove it and add quartz? Should I replace the 100uf capacitors with the 470 ones? I have a non-original psu, I should buy the original, could that be the problem? so many questions... I don't know what to do

Thank you
 

wyo

Mayor of Southtown
10 Year Member
Joined
May 22, 2013
Posts
8,641
Could be related to power supply. Check PSU voltage, clean/replace PSU input on console.
 

theboy995

Bashful Neophyte
Joined
May 4, 2017
Posts
14
Could be related to power supply. Check PSU voltage, clean/replace PSU input on console.
measure the voltage and it seems correct, 5v and peak. Would I have to buy the original or would this not be the problem? Thanks a lot
 

maki

Krauser's Shoe Shiner
Joined
Jan 1, 2022
Posts
231
no, that didn't work, it also happens to me with metal slug below a horizontal line and in neo turf masters when I throw the ball some black dots appear in the upper left
sounds like its your AES

I had something similar with a NEO-AEC:

Its not your PSU IMO, its your AES that needs some fixing.
If you're not really experienced with a soldering iron etc., I strongly recommend not to poke around and have someone else fix it for you, these ain't things to practise on IMO.
 
Top