NEO-AES3-5 video and sound glitches

daifuku74

Timid Neo Newbie
Joined
Mar 21, 2020
Posts
1
Hello everyone. I have this machine trolling me for a few weeks now and I definitely need advice please. 😢
It starts with glitched video and occasional noise before "stabilizing" and showing the neo geo logo and booting games.
Game either boots fine or the text is incorrectly displayed (and that does it also on the neo geo intro logo when it happens), letters are kind of incomplete.
Here is an example of the problem. The video shows when text is bad.


I only have one game cartridge for testing. I've taken it apart and cleaned it completely. It was not dirty or worn out in any way.

Here is what I've tried so far:
Tried with original bios with no cartridge inserted.
I had dark blue screen most of the time after the glitched video, rarely green, and red once or twice.

tried with a known good power supply 9V 2A negative center
tried with a brand new quality shielded video cable
problem still the same.

suspected the bios so I removed the original BIOS, put some round pin IC sockets and installed an Unibios 4 that I programmed myself.
problem is still the same.
I can sometimes see during the glitched video a brief green screen with EXCEPTION ERROR HANDLING, but I can never have the display stable enough to read the details at this point. It's a pity because that would maybe help.

I tried also the smkdan diagnostic bios.
It reports "all tests" passed.

I tried LOTS of continuity tests, between the main elements (bios, 5814 chips etc). Thanks to that very forum and the kindness of its members, I found many lists with all the corresponding pins to tests. No problem in traces detected.
I also tested continuity in all signals that go between LSPC2-A2 and NEO-B1, here again, no bad trace detected.

I put the 5814 chips also on round pin IC sockets.
I replaced the rest line capacitor with a new one, and also the main power filter one.
I also replaced 3 or 4 ceramic caps that looked dirty on their pin, but still the same.
I reflowed pretty much everything, bios pins, one 74HC04, LS254 (these two chips report fine in the eeprom burner running logic tests)
LSPC2-A2, NEO-B1, NEO-D0, NEO-E0, NEO-C1, NEO-GO, all CX chips, all cart slot pins, AV port and etc

When doing voltage tests, I found a place that seems to make the glitch go away when touched with a meter probe or screwdriver.
It is the red zone in the schematics below. That C54 has been replaced already, and there is no bad trace from there. Resistors around are reporting good values.
I do not need to push down, just touch the cap pin, and it makes the video "stabilize", and I can see the unibios white screen with no cartridge.

I do not understand why, but it may be a clue for more experienced troubleshooters.

I also need to mention this board is quite curved. The pins of the cartridge slot are soldered closest to the board on the left and right edges,
and with more distance in the middle. It is this way from the factory for sure, and used to work with no issues.

If you have any clue, I'd be glad. I hope this machine can be revived fully. Thanks for your time and input.

aes35meter.png
 
Last edited:
Top