MegaSD support thread

city41

Genam's Azami Sharpener
Joined
Dec 27, 2010
Posts
1,510
Figured I'd kick this off.

So far my MegaSD works great for the most part. Two issues I've not been able to resolve

- some slight graphical glitches in CD games. Mostly happens on the BIOS screen. Possibly this is normal? (I haven't owned a Sega CD in over a decade...)

- in game reset with up+start held for a few seconds does not work at all for me. Also in game menu with a quick up+start does not work. In game reset is always on, in game menu has to be enabled in the options. I've tried in many games, both CD and cartridge with no luck.

I'm playing on an Analogue MegaSG
 

mikejmoffitt

Mickey's Coach
Joined
Feb 6, 2014
Posts
578
I'm receiving mine today, supposedly. What I'm curious to know is whether or not the Cartridge + CDDA mode works; Flux uses this.

As for graphical glitches, my Mega CD doesn't have any real glitches in the BIOS, other than the quirks of scaling something down to such a small size not necessarily looking wonderful.
 

city41

Genam's Azami Sharpener
Joined
Dec 27, 2010
Posts
1,510
Updating to the latest firmware for MegaSG (the Analogue console) fixed all the issues I was having. Perfection now! Woo!
 

Grendell

Another Striker
Joined
Jul 7, 2013
Posts
326
And if you also use the 8bitdo m30 2,4ghz gamepad you should update the firmware of the pad and receiver, had extrem laggi controls from time to time

So just sayin, If someone runs mega sg + mega SD + 8bitdo the gamepad is at fault
 

RAZO

Kyo's Flame
Joined
Dec 2, 2006
Posts
8,445
I'm having this weird glitch going on the main menu of the Mega SD. The little select arrow flickers on the top corner of the screen. Sometimes it crashes as well. I'm running on a Japanese Mega Drive. Tried formatting the SD card and copying everything again and it's still doing it.

Does anyone know what it might be?

Don't know if maybe I just got a defective unit.
 
Last edited:

RAZO

Kyo's Flame
Joined
Dec 2, 2006
Posts
8,445
Never mind. My md cart slot just needed a little cleaning.
 
Top