Lots of flickering and missing GFX - Vendetta & Magical Cat Adventure

Atro

Who?,
Good evening gentlemen. :cool:

Yesterday I was able to score these 2 pcb's for dirt cheap ( knowingly they were bad ) , but they sorta alive.

I never this kind of issue on any other board, so any clues on where to look first would be gladly appreciated.

I've spent a great part of this shinny afternoon with a magnifying lens looking for broken traces.
Clean the boards. Reseated the (ep)roms and etc.

Something is clearly wrong with them, and the problems are similar, so there's no need to split it in 2 threads.

I'll start with Vendetta.
There's inconsistency in the color test to begin with.
foto0190.jpg

It shows missing colors, but on later pics they seem to appear and/or blend.

foto0194.jpg

They're also wrong/out of place. Blood has a red shirt, not green.
Text layer seems good for the most part.
foto0193.jpg

Sound is dead also. But that part, I'll figure out later on way or another. I'll source spares for that unless it's a bad custom around it.

Test/boot shows no signs of bad RAM/ROM :

foto0189.jpgfoto0191.jpg


As for Magical Cat Adventure, it's more or less the same, except that most of the enemy sprites do not show and the cat is flickering badly ( as well as a lot of objects ). Sound and inputs are good. The pcb is almost new.

foto0196.jpgfoto0197.jpgfoto0199.jpgfoto0200.jpg

Any input is kindly appreciated. :buttrock:
 

bustedstr8

Trollbox Trade Federation,
For Vendetta colors my guess would be lifted pins on the GPU or bad TTL (Fujitsu Plague) causing you to be missing certain color bits.

All Konami boards from that era seem to use the same type of setup for grafx.

GPU>Mux>Ram>Latches>Buffer>DAC modules. I would start at each DAC and work my way back.
 

Atro

Who?,
For Vendetta colors my guess would be lifted pins on the GPU or bad TTL (Fujitsu Plague) causing you to be missing certain color bits.

All Konami boards from that era seem to use the same type of setup for grafx.

GPU>Mux>Ram>Latches>Buffer>DAC modules. I would start at each DAC and work my way back.

Which one is the GPU? The 053247? 053251? I spotted some nasty pins, but I've seen worse and rockin'...
It has a lot of Goldstars. No signs of Fujitsus tho.
 

bustedstr8

Trollbox Trade Federation,
Korean boards...ruh roh :p

I think the GPU is the 053251 on that board. The other paired chips are your sprite and tile generators.
 
Top