Hantarex 9000 issues (shunk image and heavy sparking)

Jae686

Cheng's Errand Boy
Good Evening.

One day , after not using my cab for a while, heavy sparking was observed on the back of the CRT.
(The sparking was probably caused due to dust and moisture buildup around the HV plug behind the CRT).

The dust was cleaned away, but the image has shrunk on both axis, and the colour had a heavy green tint to it.

After a while (some months), I've turned it on again just to discover that, although the image is still shrunk, the colours are ok again.

But then some popping is heard on the back of the CRT (but the image is still displayed normally during the popping).

Below is a photo of the monitor (sorry for the crappy quality)

Hantarex_Issue.jpg

Any ideia on what could it be ?
 

pulstar

Mickey's Coach
Best case scenario is that it'll be some caps that need replacing. Worst case, it could be the flyback on its way out. I'd replace the caps first (if it hasn't already had a cap kit done).
 

Jae686

Cheng's Errand Boy
Thank you for your reply.

All the caps but one were replace 3-4 years ago, therefore I believe I will replace the flyback. Its there anything I might do, besides regular cleaning of the back of the PCB, to avoid such incidents on the future ?
 

1up

Galford's Armourer
My 25" mtc9110 has similar problems. I am going to try a cap replace.

Good news is, these hantarex chassis seem to be common here in Portugal, finding parts won't be difficult.
 

Jae686

Cheng's Errand Boy
My 25" mtc9110 has similar problems. I am going to try a cap replace.

Good news is, these hantarex chassis seem to be common here in Portugal, finding parts won't be difficult.

I was actually able to get a equivalent Flyback (a few years back) at a electronics store.
 

Jae686

Cheng's Errand Boy
Good Evening.

I've managed to replace the flyback transformer. The heavy sparking was due not to flyback itself, but instead it was due to a rigid film of dirt under the suction cup.
After proper cleaning the sparking was not observed.

But the image is still small. Any ideias on what might be the cause?

Best Regards.
 

Jae686

Cheng's Errand Boy
Good Morning.

@Liam : I've followed your chart and I was able to repair the green tint issue. (I've traced to the TR202).
DSC_4798.jpg

Regarding the shrunk image, I've was able to get around it by further adjusting the monitor.
IMG_20150710_112752.jpg

Although I get distortion on the bottom end when I re-size the image to fill the whole screen.

IMG_20150710_113513.jpg


Best Regards

P.S. : Distortion at the bottom :

ki2.jpg
 
Last edited:

Jae686

Cheng's Errand Boy
Also, the monitor works fine with the Killer Instict 2 board, but it shuts down with the Hyper 64 and the ST-V board.
And there was I celebrating !

DONE : Replace all the electrolytic caps. No change.

Now a faint but high pitch tone comes from the monitor.

During H-freq adjustments the HV turned off. (Like what happened with the Hyper64 connected)
 
Last edited:
Top