Genesis DOESn't work right...

Moon Jump

Alfred Garcia's Butler
Joined
Jun 1, 2003
Posts
5,904
Well, I got some new Genesis and Master System games this weekend and I was trying them out on my ol' model 1 Genesis and it's been acting funny.

When I first started I had the Power Base Converter on it and I was able to play some Master System games without any troubles, Alf, Ghostbusters, Shinobi, they all worked fine. Then I took the base off and tried some Genesis games.

Out of all I tried only Virtua Racing worked. The system powers up and I get the license screen and it doesn't boot the game up. I have no idea why the Power Base and Virtua Racing works but my other games don't.

I took the system apart and shot the inside with some canned air. I also took an old credit card, clean rag and some 80-20 rubbing alcohol and cleaned the cart slot and let it dry and I've got the same results. Only Virtua Racing works. It doesn't like Earthworm Jim, Comix Zone, Sonic, just Virtua Racing.

Anybody know what's up? I've got it hooked up through the RF going into a Plasma screen. The system has worked fine in the past and never gave me any troubles. I always make sure all of my games are cleaned before I use them. I'm going to try again this afternoon to see if I can figure out what's up with this thing.
 

Yodd

Iori's Flame
Joined
Feb 7, 2002
Posts
8,210
Sounds like the games themselves need cleaned rather than the console cart slot.
 

ggallegos1

Cholecystectomy Required.,
Joined
Oct 1, 2013
Posts
4,364
I use brasso to polish the pins in my carts To a nice shine it works very well for the very grungy carts. Make sure you open the carts and clean carefully to avoid the board.
 

Wolfie79

Quiz Detective
Joined
Sep 17, 2011
Posts
86
hmmm both the converter and vr are bigger in size, and the pins might be slightly wider, could it be you got loose contacts? Do you leave a game cart inside ur genesis when not in use? U might just need to make some pressure upwards or towards you with 1 of those games that doesnt work to see it that is the issue, if so it can be easily fixed with a very tiny screwdriver by gently pulling the pin contacts towards each other in ur genesis slot
 

ApolloBoy

330 Mega Shock!!
Joined
Feb 15, 2012
Posts
330
I use brasso to polish the pins in my carts To a nice shine it works very well for the very grungy carts. Make sure you open the carts and clean carefully to avoid the board.
If you use Brasso be super careful with it, as it can actually take the finish off the contacts if you're too vigorous with it.
 

Yodd

Iori's Flame
Joined
Feb 7, 2002
Posts
8,210
If you use Brasso be super careful with it, as it can actually take the finish off the contacts if you're too vigorous with it.

Also make sure after using Brasso on the contacts that you wipe the contacts again with a swab and some isopropyl alcohol.

Brasso leaves behind a film that should be cleaned off.
 

zaneiken

B. Jenet's Firstmate
Joined
Jun 21, 2013
Posts
411
I use Brasso and isopropyl alcohol on all used carts. I then store the games in zip-lock bags.
 

JasonToddLives

Armored Scrum Object
Joined
Nov 27, 2013
Posts
263
Are you using the original power supply? (Model 1602-1) I don't know why Virtua Racer would be the only Genesis game to work, just throwing out ideas.
 

skinny503

NAM-75 Vet
Joined
Sep 22, 2013
Posts
1,003
I have a model VA7 laying around that I could send you if your interested, Or I could sell you my personal one that is av, s-video, jpn/eng and 50/60hz switches installed for $60 shipped!
 

Nerdygrrl

Krauser's Shoe Shiner
Joined
Jul 24, 2011
Posts
232
I get that if a cart I pick up/use is dirty. Sometimes, I'll grab something new put it aside and forget that I haven't cleaned the contacts.

As others have mentioned, a little rubbing alcohol and some q-tips goes a long way.
 
Top