Does this CPS2 need phoenixing?

mookie3three

Mr. Big's Thug
Joined
Apr 12, 2013
Posts
203
Hi,

Does this need phoenixing? I though it would show a solid blue if it was dead?

2urqi3k.jpg


Cheers
 

Tyranix95

Chang's Grocer
Joined
Jun 30, 2010
Posts
4,593
Looks like you've got a couple of things going on there.

May want to open the case and check the battery with a multi-meter, first.

See if it has any charge left.

---

And while you're at it, you may also want to dld the suicide tester rom file--burn it--and use it to check the board.
 

_rm_

Street Hoop Star
Joined
Aug 7, 2012
Posts
1,414
Doesn't look dead to me.
Check for bent pins between the A and B boards.

The "dead image" isn't necessary Blue, but it's always a solid color screen.
 

mookie3three

Mr. Big's Thug
Joined
Apr 12, 2013
Posts
203
Hi, it does the same thing on another A board. And other b boards work fine on both A boards. Unfortunately I don't have EPROM reader or burner. Te voltage on the battery was OK when I checked it a week or ago but I'll check again. I seem to remember it reading the voltage slower on this battery. What I mean by that is it would read maybe a 1v, then take Another few seconds to reach 3.6v. Whereas batteries on my other CPS2 boards would read 3.6v in a split second.
 

Xian Xi

JammaNationX,
Joined
Dec 1, 2005
Posts
27,679
Hi, it does the same thing on another A board. And other b boards work fine on both A boards. Unfortunately I don't have EPROM reader or burner. Te voltage on the battery was OK when I checked it a week or ago but I'll check again. I seem to remember it reading the voltage slower on this battery. What I mean by that is it would read maybe a 1v, then take Another few seconds to reach 3.6v. Whereas batteries on my other CPS2 boards would read 3.6v in a split second.

That could just be flux preventing an instant connection with the probe.
 

Tyranix95

Chang's Grocer
Joined
Jun 30, 2010
Posts
4,593
50/50.

---

Find somebody down under with a burner and get a cps2 tester rom.

---

I've seen a CPS2 "B" board do funky shit like that before one week, then boot up fine the next--but it was a Phoenixed board.
 
Last edited:

xb74

Baseball Star Hitter
Joined
Mar 6, 2012
Posts
1,257
Hey mookie

Send me a Pm and I can put you in touch with a friend of mine who can phoenix boards and diagnose a fair few problems with cps2 stuff. He is also a wizard with neo geo equipment as a side note.
 

Dion

Known Scammer, NeoGeoFreak Co-Founder
Joined
Aug 24, 2000
Posts
2,070
Hmm. Looks like it is trying to boot but it is freezing during.
 

neojago

Timid Neo Newbie
Joined
Dec 16, 2013
Posts
5
Sounds like the battery is the problem. Like said before, get a tester ROM but you most likely have suicided.
 

Dion

Known Scammer, NeoGeoFreak Co-Founder
Joined
Aug 24, 2000
Posts
2,070
Sounds like the battery is the problem. Like said before, get a tester ROM but you most likely have suicided.

The suicide screen looks nothing like this on CPS2.
 
Top