Damaged chip in Neo Geo MV-1C

Sho G.

Pari-Dakar Rally Driver
Joined
Apr 30, 2011
Posts
67
Hello everyone. I have recently received a Neo Geo MV-1C and after observing it I have seen that it has a raised chip pin. Could it be an accidental hit or could the previous owner do it for some reason? Should I try soldering it or can it work just fine like that? I have not had time to connect it to a TV and test it.

uc
 
Last edited:

DaisyAge

B. Jenet's Firstmate
Joined
Jun 10, 2018
Posts
419
That's a palette ram chip so unless you like fucked up colors and such I'd carefully push it back into position and solder it :) Might as well reflow the whole chip to be safe and check others on the board while you're there.
 

Sho G.

Pari-Dakar Rally Driver
Joined
Apr 30, 2011
Posts
67
That's a palette ram chip so unless you like fucked up colors and such I'd carefully push it back into position and solder it :) Might as well reflow the whole chip to be safe and check others on the board while you're there.
Thank you very much for the information. I'll try to align the pin and go over all the welds.
 

distropia

Igniz's Servent
Joined
Apr 28, 2010
Posts
1,068
That's a palette ram chip so unless you like fucked up colors and such I'd carefully push it back into position and solder it :) Might as well reflow the whole chip to be safe and check others on the board while you're there.
Let me point out a 74ls05 is not a palette ram chip, is a Hex Inverter. The palette ram is inside the big neo-grz chip in that mv1C ;)
 
Top