AES Select button loading Universe Bios in Game Menu.

greedostick

George Spiner's Caddy
Joined
Aug 11, 2003
Posts
4,375
OK, got my RGB cables today so I can test this AES im trying to see if needs repaired. My custom arcade stick is doing some weird stuff.

It does work in my supergun.

I followed the neo pinout here,

http://old.pinouts.ru/Game/NeoGeoJoystick_pinout.shtml

checked my connections, made sure they were in the right place, and secure. I am using a breakout board.

Here's the issue. Pressing Start in the game title brings up the universe bios menu, not select + start. Then all the buttons become inoperable except Start. This includes the directions, select, and A B C D.

To get them to work I must unplug the controller. Anytime the universe bios in game menu loads, or goes away, I must unplug the controller.

Right now I am in AES mode, there is a 4 credit default in sam sho 2, but I can not press start. Testing in my supergun again, everything is working.

Where should I go from here?

Oh, and I have button D set to 4, and pins 2 and 10 are not used. I am using ground 1, but not the +5 ground, as I hear that's just for CD controllers.
 
Last edited:

greedostick

George Spiner's Caddy
Joined
Aug 11, 2003
Posts
4,375
OK, discovered something.

Controller socket 2 works perfect.

Controller 1 socket though is still doing weird stuff.

I figured out that start loads the Universe bios, and start + select will actually start up the game from the title.

Is this normal? Or should it be the other way around?

At least I got it working so I could see if I still am having this shadow issue in RGB, which I am. Looks great on my XRGB mini though.
 

aha2940

AH, A, COLUMBIAN!,
Joined
Dec 15, 2013
Posts
2,520
OK, got my RGB cables today so I can test this AES im trying to see if needs repaired. My custom arcade stick is doing some weird stuff.

It does work in my supergun.

I followed the neo pinout here,

http://old.pinouts.ru/Game/NeoGeoJoystick_pinout.shtml

checked my connections, made sure they were in the right place, and secure. I am using a breakout board.

Here's the issue. Pressing Start in the game title brings up the universe bios menu, not select + start. Then all the buttons become inoperable except Start. This includes the directions, select, and A B C D.

To get them to work I must unplug the controller. Anytime the universe bios in game menu loads, or goes away, I must unplug the controller.

Right now I am in AES mode, there is a 4 credit default in sam sho 2, but I can not press start. Testing in my supergun again, everything is working.

Where should I go from here?

Oh, and I have button D set to 4, and pins 2 and 10 are not used. I am using ground 1, but not the +5 ground, as I hear that's just for CD controllers.

I take it you do not have another stick to test. Maybe the start button on the AES is seeing as constantly pressed? that would explain some of the stuff you are seeing.

Regards.
 

Xian Xi

JammaNationX,
Joined
Dec 1, 2005
Posts
27,682
In the AES, sometimes the ferrite beads get corroded and cause problems like this or it's the resistor network, if it isn't either of those it only leaves the NEO-C1. And sometimes the RAM going bad will do the same thing. Check the color on boot with no cart with a stock bios.
 

greedostick

George Spiner's Caddy
Joined
Aug 11, 2003
Posts
4,375
I actually figured it out. Feel pretty dumb, had the quick disconnect on the bottom instead of the middle tab.

Still working on this shadow issue though. Where would one find a new psu that supplies clean power?

Here's my model. I don't care about OEM, as long as it really works.

NEO GEO
PRO POW
AC 100V 50/60Hz 38VA
DC5V 3A
 
Last edited:
Top