Recent content by Kodos

  1. K

    Neo Geo 1 slot screen goes black after a few minutes

    I replaced the battery on the main board just to prevent future problems there and checked all the connections. I didn't really find anything. My main suspicions now is something heat related. I think the game board is ok so it it has to be something on the CRT side of things. It will run for a...
  2. K

    Neo Geo 1 slot screen goes black after a few minutes

    Updated info, I removed ROM and powered it up while timing it. Grid was on screen for 20 minutes then went black. I inserted ROM and went into diagnostic. Everything seemed to check out so I went back into game mode. I played for over 30 minutes with no issue so don't know if it is activity...
  3. K

    Neo Geo 1 slot screen goes black after a few minutes

    Agreed that the thing I touched is the most likely candidate. Unless I can find something obvious like a lose connector or something I fear I'm going to need the help of someone who can test and service the board. Obviously my attempt to do that was incomplete. I'm not sure I want to buy...
  4. K

    Neo Geo 1 slot screen goes black after a few minutes

    I don't have any additional spare parts to work with. I figure the likely candidate is the QNIC CGM-2500 that I removed and worked on but I had a friend with good soldering skills do the cap replacement and the board looked good prior to reinstalling it. It also fixed the screen problem I was...
  5. K

    Neo Geo 1 slot screen goes black after a few minutes

    It is original unmodified logic board and original SNK ROM. Magician Lord is loaded now but I have tried KoF 95 and King of the Monsters 2. I saw your post on the other forum. I'm new to the online Neo Geo community. I have lucked out that the cabinet has be working for over 25 years and now I...
  6. K

    Neo Geo 1 slot screen goes black after a few minutes

    I have a 1 slot Neo Geo MVS that is starting to show its age. I initially had some screen issues with lost colors and blurred images that was attributed to caps on the CRT control board. I purchased the kit for a QNIC CGM-2500 and replaced all the caps including the filter cap. After...
Top