Results 1 to 12 of 12

Thread: Neo Geo MVS MV-1A - Pink Screen

  1. #1
    NEST Puppet
    RyuX's Avatar
    Join Date
    Sep 2018
    Location
    Austria

    Posts
    179

    Question Neo Geo MVS MV-1A - Pink Screen

    Hey guys.

    I recently purchased a broken MV-1A.
    It looked pretty good - no battery leak - quite clean but I only get a Pink Screen.

    When pushing around the board the color might change but ultimately I can never get through even with the diagnostic bios.

    I measured some of the Caps and got only 500 Ohms from 5V to Ground - not sure if this is normal for this board.

    Maybe anyone had a similar issue ?
    I just want to ask around before I start replacing the RAM Chips etc. until I can get it to post into the diagnostic rom.

    Thanks guys.

  2. #2
    NEST Puppet
    RyuX's Avatar
    Join Date
    Sep 2018
    Location
    Austria

    Posts
    179
    Hey there..

    Well little did I know what was ahead of me...
    I replace all the RAM Chips - the CPU - check all traces and replaced every other chip imaginable except for the NEO-BUF (because I have none).
    So I switched NEO-BUFs around from one position to another and now I am able to get at least a watchdog response.
    Man these M1A Boards suck.
    Any cheap way to get NEO-BUFs ?


  3. #3
    Kula's Candy
    DasiyAge's Avatar
    Join Date
    Jun 2018
    Location
    United States

    Posts
    305
    Quote Originally Posted by RyuX View Post
    Hey there..

    Well little did I know what was ahead of me...
    I replace all the RAM Chips - the CPU - check all traces and replaced every other chip imaginable except for the NEO-BUF (because I have none).
    So I switched NEO-BUFs around from one position to another and now I am able to get at least a watchdog response.
    Man these M1A Boards suck.
    Any cheap way to get NEO-BUFs ?

    https://www.tindie.com/products/furr...f-replacement/
    Best one there is

  4. #4
    NEST Puppet
    RyuX's Avatar
    Join Date
    Sep 2018
    Location
    Austria

    Posts
    179
    Hey.. Yeah I found these on google before as well. Still have to decide if I want to invest into this board or rather keep it as a spare part donor for my Neo Geo CD. Anyways ordering a couple of NEO-BUFs won't hurt.

  5. #5
    NEST Puppet
    RyuX's Avatar
    Join Date
    Sep 2018
    Location
    Austria

    Posts
    179
    Bad Luck as of now.. I replaced all of the NEO-BUFs with the Furrtek Replacements but first still got a similar Watchdog and now currently I am back to a all WHITE Screen.
    So decided to change back the 68k to the original one - same result.

    Currently giving it a dishwasher treatment and will then dry it properly and troubleshoot again and post some pictures of the current state

  6. #6
    NEST Puppet
    RyuX's Avatar
    Join Date
    Sep 2018
    Location
    Austria

    Posts
    179
    So as of right now I replaced all the RAM.. swapped around all of the LS / HC ICs with spares and cleaned the board really well.. all of the NEO-BUFs are new but still.. the board seems dead.
    I inspected all of the traces and also can't find any corrosion or broken traces or short circuits anywhere.

    122588056_777496976432230_3558870027748725635_n.jpg

    At the moment I get this when turning on.
    Not sure if this is supposed to mean that the CPU is ok or not - this is getting depressing (like almost every other Neo Geo Repair I had previously. lol)



    Any hints or someone had something similar on theirs ?

  7. #7
    NEST Puppet
    RyuX's Avatar
    Join Date
    Sep 2018
    Location
    Austria

    Posts
    179
    and after just half an hour... back to the pink screen I had in the first place.

    So the problem might not be related to any of the parts that I replaced.
    Since the pink screen is stuck I have no watchdog active.

    Feeling a little like giving up at this point. I have no spares of the bigger packages like the MGA or GRC

    122475994_2113050192159911_2169372209899555615_n.jpg

  8. #8
    H = Heinously
    M = Massive
    G = Gonad
    HMG's Avatar
    Join Date
    Apr 2011
    Location
    Canada

    Posts
    4,706
    Might have to keep this one for parts sadly

  9. #9
    NEST Puppet
    RyuX's Avatar
    Join Date
    Sep 2018
    Location
    Austria

    Posts
    179
    Always very sad when this happens.. only had 2 Boards that I wasn't able to fix yet and it always goes into the box of shame.
    I just don't have enough proven working spare parts I guess. Well - this board still is good as a donor for my Neo Geo CD, at least that.

  10. #10
    Kula's Candy
    DasiyAge's Avatar
    Join Date
    Jun 2018
    Location
    United States

    Posts
    305
    FWIW I have an MV1FZS for parts I can I send you for cost of shipping. It's missing the 68k and a few pallette ram chips but everything else is there

  11. #11
    NEST Puppet
    RyuX's Avatar
    Join Date
    Sep 2018
    Location
    Austria

    Posts
    179
    Thank you for your kind offer. How much would shipping of the PCB alone be to Austria / Europe ? I Guess it would be quite expensive ?

  12. #12
    Kula's Candy
    DasiyAge's Avatar
    Join Date
    Jun 2018
    Location
    United States

    Posts
    305
    Oh I didn't even realize you were in Europe. Yeah honestly buying board off ebay or aliexpress would be cheaper.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •