Results 1 to 3 of 3

Thread: Help with N64 RGB Mod

  1. #1
    Another Striker
    Evan's Avatar
    Join Date
    May 2016
    Location
    Your trash can

    Posts
    325

    Help with N64 RGB Mod

    A while back I did an n64 rgb mod on an older version of the n64. The specific parts I used was the DIY THS7314 board and for a while it worked fine. But I unplugged it for a bit, and used composite on a crt for a bit. When I tried to use the rgb another time its no just a black screen. The upscaler im using is the GBS 8200 which i know works as I used it with another console and it works fine. I also know the n64 works as it works through composite. Lastly I know that the sync signal is fine, as it recognizes when i pulg in the cable for sync. Any help would be great.
    Alright, back again with THE IMMORTAL JOHN HANCOCK

  2. #2

    Neo Alec's Avatar
    Join Date
    Dec 2000
    Location
    USA

    Posts
    8,609
    I did one of these mods on a launch N64 as well. Check that the amp is getting power, I guess. Get a multimeter and check for activity on the RGB lines.
    https://basementbrothers.net/

  3. #3
    Hollywood Hulk Gohan GohanX's Avatar
    Join Date
    Sep 2001
    Location
    Hollywood, CA

    Posts
    10,828
    When rgb worked before were you using the same scaler?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •