Results 1 to 7 of 7

Thread: Bust A Move Again cart with corrupt pictures

  1. #1
    . avramce's Avatar
    Join Date
    Sep 2019
    Location
    Seattle, WA

    Posts
    74

    Bust A Move Again cart with corrupt pictures

    Hi all, I recently purchased a Bust A Move Again cart, cart has a Holo label and all the ICs on the board match mvs-scans.

    I booted up the carts and saw that the background layers and title logo have corrupted graphics. The sprites on the other hand look fine:

    https://imgur.com/a/c3WXG6N

    I booted up the same game on my 161, and did not see these issues. I have already tried cleaning off the pins and reseating the cart, but no luck. Any suggestions aside from desoldering the C-roms and verifying them on my programmer?

  2. #2
    Maxima's Barber
    shadowkn55's Avatar
    Join Date
    Dec 2006
    Location
    SoCal

    Posts
    2,359
    Check for cracked solder joints on the roms.

  3. #3
    . avramce's Avatar
    Join Date
    Sep 2019
    Location
    Seattle, WA

    Posts
    74
    Any ROMs in particular? I spot checked all the joints, no obvious bad joints. I gave all the C-Roms a reflow, didn't change anything. All that is left to reflow is the M1, S1 and V1+2. I'd assume the P-rom can't contribute to that, and the Unibios check on the cart said the CRC for the P-rom is good.

  4. #4
    Maxima's Barber
    shadowkn55's Avatar
    Join Date
    Dec 2006
    Location
    SoCal

    Posts
    2,359
    S1 is also related to graphics. If you are going to start popping out roms to verify, start with S1 and the C roms. M1 and V1/2 are sound related so there is no need to mess with those.

  5. #5
    . avramce's Avatar
    Join Date
    Sep 2019
    Location
    Seattle, WA

    Posts
    74
    Yep, pulled the ROMs and found out that the C4 was bad. A little sad that my cart won't have original ROMs, but still happy to have this cart in my collection.

  6. #6
    .
    Join Date
    Jan 2020
    Location
    ruanda

    Posts
    120
    Quote Originally Posted by avramce View Post
    Yep, pulled the ROMs and found out that the C4 was bad. A little sad that my cart won't have original ROMs, but still happy to have this cart in my collection.
    also snk repaired carts were repaired with eproms if needed.

  7. #7

    Neo Alec's Avatar
    Join Date
    Dec 2000
    Location
    USA

    Posts
    8,607
    Quote Originally Posted by avramce View Post
    Yep, pulled the ROMs and found out that the C4 was bad. A little sad that my cart won't have original ROMs, but still happy to have this cart in my collection.
    A repair is a broken official cart brought back to life! Lots of carts will need repairs eventually.
    https://basementbrothers.net/

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •