Results 1 to 6 of 6

Thread: Forum and MVS noob . Wanna introduce myself and maybe pick everyone's brain.

  1. #1
    .
    Join Date
    Feb 2020
    Location
    Seattle

    Posts
    4

    Forum and MVS noob . Wanna introduce myself and maybe pick everyone's brain.

    Hello everybody,

    I just acquired my first Neo cabinet and I heard this is the place to get tech help, ask questions and just generally shoot the shit when it comes to Neo collecting. First thing first I took the back panel off my rig and saw that some patchwork wiring was done to the power supply. Can anyone make heads or tails of this?
    Attached Images Attached Images

  2. #2
    Edo Express Delivery Guy
    Jeffpin's Avatar
    Join Date
    Sep 2012
    Location
    CT

    Posts
    346
    Can’t see everything, but looks like the original power supply died and is being bypassed to a new one.

  3. #3
    Geese's Thug
    ack's Avatar
    Join Date
    Apr 2009
    Location
    Seattle, WA

    Posts
    289
    That kinda looks like what my neo geo cabinet came with for powersupply mess. I suspect what happened is the original powersupply failed (dc side). Instead of replacing it, they took the AC output from it and ran it into the other powersupply. The AC output from the bad powersupply is likely also going to that transformer to power the monitor.

  4. #4
    Morden's Lackey
    NexusX's Avatar
    Join Date
    Jul 2017
    Location
    Houston, Tx

    Posts
    353
    Just looks like the original PSU died and they wired up a newer one to it.

  5. #5
    .
    Join Date
    Feb 2020
    Location
    Seattle

    Posts
    4
    Thanks for the reply's. Sounds like I dont have anything to worry about.

  6. #6
    Dogg-Father
    Neodogg's Avatar
    Join Date
    Nov 2002
    Location
    Cincinnati, OH

    Posts
    3,295
    Get a multimeter to make sure your rails are putting out correct voltages +5 is the main one. Adjust it accordingly, >5.2 and things can go bad, this should be measured under load...speaking of putting out and under load, your mum says hi...

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •