Results 1 to 6 of 6

Thread: MegaSD support thread

  1. #1
    Chin's Bartender
    city41's Avatar
    Join Date
    Dec 2010
    Location
    San Jose area

    Posts
    1,551

    MegaSD support thread

    Figured I'd kick this off.

    So far my MegaSD works great for the most part. Two issues I've not been able to resolve

    - some slight graphical glitches in CD games. Mostly happens on the BIOS screen. Possibly this is normal? (I haven't owned a Sega CD in over a decade...)

    - in game reset with up+start held for a few seconds does not work at all for me. Also in game menu with a quick up+start does not work. In game reset is always on, in game menu has to be enabled in the options. I've tried in many games, both CD and cartridge with no luck.

    I'm playing on an Analogue MegaSG

  2. #2
    Raiden's Valet
    mikejmoffitt's Avatar
    Join Date
    Feb 2014
    Location
    San Jose, CA

    Posts
    581
    I'm receiving mine today, supposedly. What I'm curious to know is whether or not the Cartridge + CDDA mode works; Flux uses this.

    As for graphical glitches, my Mega CD doesn't have any real glitches in the BIOS, other than the quirks of scaling something down to such a small size not necessarily looking wonderful.

  3. #3
    Chin's Bartender
    city41's Avatar
    Join Date
    Dec 2010
    Location
    San Jose area

    Posts
    1,551
    Updating to the latest firmware for MegaSG (the Analogue console) fixed all the issues I was having. Perfection now! Woo!

  4. #4
    Another Striker

    Join Date
    Jul 2013
    Location
    Germany

    Posts
    313
    And if you also use the 8bitdo m30 2,4ghz gamepad you should update the firmware of the pad and receiver, had extrem laggi controls from time to time

    So just sayin, If someone runs mega sg + mega SD + 8bitdo the gamepad is at fault

  5. #5
    Formerly Raz_Hoe.
    RAZO's Avatar
    Join Date
    Dec 2006
    Location
    New Jersey

    Posts
    6,874
    I'm having this weird glitch going on the main menu of the Mega SD. The little select arrow flickers on the top corner of the screen. Sometimes it crashes as well. I'm running on a Japanese Mega Drive. Tried formatting the SD card and copying everything again and it's still doing it.

    Does anyone know what it might be?

    Don't know if maybe I just got a defective unit.
    Last edited by RAZO; 12-05-2019 at 11:45 PM.

  6. #6
    Formerly Raz_Hoe.
    RAZO's Avatar
    Join Date
    Dec 2006
    Location
    New Jersey

    Posts
    6,874
    Never mind. My md cart slot just needed a little cleaning.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •