Results 1 to 8 of 8

Thread: Neo Geo Pocket Color Issue

  1. #1
    .
    Join Date
    May 2019
    Location
    United States

    Posts
    3

    Neo Geo Pocket Color Issue

    Greetings. So I just recently fired up my NGPC and was looking to enjoy some games. I replaced the CR2032 battery and put in fresh AAs. I set the time, language, etc. Then after the NGPC boot screen, the system just randomly shuts off by itself.

    I have no idea why this is happening. I noticed that if I turn off the NGPC manually during the boot screen intro and turn it on right after, the game does load, but for only about 3 seconds then powers off again.

    I've tried different batteries but it always gives the same result: the NGPC turns off by itself after the boot screen when a game is inserted.

    I tried just not putting a cartridge in and it boot to the system menu fine and stayed there for 10 minutes before manually turning it off without any mishaps.

    Is there a solution to this or is my NGPC possibly dying and won't load game carts anymore?

    Thanks in advance for any help!

  2. #2
    Cholecystectomy Required.
    ggallegos1's Avatar
    Join Date
    Oct 2013
    Location
    Milford, CT

    Posts
    3,567
    Check to see if there was any battery corrosion with either the AAs or CR2032. Then clean the hell out of the cart slot and your games,maybe those will work a bit.
    "I am the master of my fate. I am the captain of my soul."
    Switch FC 0965 2531 6217

    Quote Originally Posted by ObeyMyEgo View Post
    ggallegos1 Is a cock sucking faggot. That is all.

  3. #3
    Astra Superstar
    titchgamer's Avatar
    Join Date
    May 2018
    Location
    United Kingdom

    Posts
    813
    Yeah I would start by cleaning the cart slot and carts.

    Blow the dust etc out with a air duster then use electrical contact cleaner on the contacts.

  4. #4
    Big Bang Pro Wrestler
    Vectorman0's Avatar
    Join Date
    Dec 2004
    Location
    CT - USA

    Posts
    1,026
    Does the system shut off with no interaction, or does it shut off when you move/jostle it? Although this doesn't sound like your issue, I have seen systems that randomly shut off in the past, and it was usually because the battery springs were loose and not holding a tight connection. I would also check them for corrosion.

  5. #5
    .
    Join Date
    May 2019
    Location
    United States

    Posts
    3
    Quote Originally Posted by titchgamer View Post
    Yeah I would start by cleaning the cart slot and carts.

    Blow the dust etc out with a air duster then use electrical contact cleaner on the contacts.
    Quote Originally Posted by ggallegos1 View Post
    Check to see if there was any battery corrosion with either the AAs or CR2032. Then clean the hell out of the cart slot and your games,maybe those will work a bit.
    Quote Originally Posted by Vectorman0 View Post
    Does the system shut off with no interaction, or does it shut off when you move/jostle it? Although this doesn't sound like your issue, I have seen systems that randomly shut off in the past, and it was usually because the battery springs were loose and not holding a tight connection. I would also check them for corrosion.
    I've tried cleaning out the slot and games with contact cleaner and alcohol and nothing's changed. There doesn't seem to be any battery corrosion on either the AAs or CR2032 contacts. It still keeps the settings and time after being off for a while. It then shuts off by itself with no interaction whatsoever after the bootscreen if a cartridge is inserted.

    Just to clarify, the CR2032 battery is inserted into the console with the text side facing outwards correct? i.e. you see "Energizer" on the + side facing you after putting in the battery. I want to make sure it's not a weird instruction printed on the plastic where you're supposed to do the opposite of what it tells you to do.
    Last edited by Hansuke; 05-12-2019 at 02:53 PM. Reason: typos

  6. #6

    Neo Alec's Avatar
    Join Date
    Dec 2000
    Location
    USA

    Posts
    8,314
    Yep, that's how you insert the CR2032. Auto switching off like that is the same behavior for when the main AA batteries are low. The power light will also blink. You might want to try other batteries just to rule it out. You may want to get an AC adapter to try that.
    Last edited by Neo Alec; 05-13-2019 at 10:01 AM.

  7. #7
    .
    Join Date
    May 2019
    Location
    United States

    Posts
    3
    Quote Originally Posted by Neo Alec View Post
    Yep, that's how you insert the CR2032. Auto switching off like that is the same behavior for when the main AA batteries are low. The power light will also blink. You might want to try other batteries just to rule it out. You may want to get an AC adapter to try that.
    Yea, I've already tried different batteries and there hasn't been any change. I don't have an AC adapter to try that option, but that wouldn't explain why it stays on when a game isn't inserted.

  8. #8
    Setsuna's Owl Keeper
    WoodyXP's Avatar
    Join Date
    Apr 2006
    Location
    San Antonio, TX

    Posts
    3,629
    It sounds like a power issue. The system has enough juice to boot up, but not enough to play games. Crack it open and inspect the capacitors.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •