Results 1 to 7 of 7

Thread: Neo Super Candy 29 - Failing PSU HELP

  1. #1


    Join Date
    Aug 2000
    Location
    NC
    Posts
    676

    Neo Super Candy 29 - Failing PSU HELP

    SO I've had this thing for 18 years and it has given great service, and continues to, BUT worried the PSU may be going, and I'm not a pro at hardware so looking to you all.

    SO perfect performance with a 1 slot, flawless, so thats still good.

    BUT with a 4 slot 1 or 2 slots routinely have garbled graphics that go in and out, YES I have had the board checked twice and each time runs flawlessly on their cab without symptom. I have tried ALL variations of carts, still no go.

    THE PSU POT IS TURNED ALL THE WAY UP symptom still there

    Any ideas for a fix? New power supply? If so where to get? How much and how hard to install? Links always helpful.

    OR is there a voltage converter that I could just go through to get to US current?

    Thanks so much everybody

    Lee (garg7)

    Old School Garg's Neo Temple

    PS the more I think about it 4 slots have ALWAYS been wonky over the years, thought was dirty carts, worn cart slots, but last 3 years its worse, 2 slots play flawlessly , 1 or 2 others have garbled graphics
    Last edited by gargoyle7; 05-02-2019 at 03:14 PM.
    I own a Real Battle Action Game

    "I Love The Smell of Napalm & Home Carts in The Mornin'"

  2. #2


    Join Date
    Aug 2000
    Location
    NC
    Posts
    676
    https://vetco.net/products/500-watt-...RoCAesQAvD_BwE

    would this do it?

    BTW the cab plug is US 3 prong
    I own a Real Battle Action Game

    "I Love The Smell of Napalm & Home Carts in The Mornin'"

  3. #3
    Angel's Love Slave
    daskrabs's Avatar
    Join Date
    Aug 2010
    Location
    Phatal Philly

    Posts
    1,052
    1) If 1-slots work, your cab is prob wired for JAMMA, not MVS. 2) You should use a multimeter to check your voltage. 3) You're going to damage something if you turn your PSU 5v pot all the way up. 4) A 100v voltage stepper is not a substitute for a power supply.
    Sony PVM Club, Blast City Club, Egret II Club, Neo Candy Club
    WTB: Neo Geo MVS-U4 or MVS-U4/29

  4. #4


    Join Date
    Aug 2000
    Location
    NC
    Posts
    676
    thanks daskrabs, nah certain it is wired for MVS, 4 slot ran well for many years. Actually the POT was turned up all the way when I got it. If I turn it down, the board starts up, then just dies. Can someone walk me through checking with a multimeter? Thanks
    I own a Real Battle Action Game

    "I Love The Smell of Napalm & Home Carts in The Mornin'"

  5. #5
    Angel's Love Slave
    daskrabs's Avatar
    Join Date
    Aug 2010
    Location
    Phatal Philly

    Posts
    1,052
    Quote Originally Posted by gargoyle7 View Post
    thanks daskrabs, nah certain it is wired for MVS, 4 slot ran well for many years. Actually the POT was turned up all the way when I got it. If I turn it down, the board starts up, then just dies. Can someone walk me through checking with a multimeter? Thanks
    https://www.youtube.com/results?sear...supply+voltage
    Sony PVM Club, Blast City Club, Egret II Club, Neo Candy Club
    WTB: Neo Geo MVS-U4 or MVS-U4/29

  6. #6


    Join Date
    Aug 2000
    Location
    NC
    Posts
    676
    turns out was a loose connector on the board, changing angle and tightening pins has it back working 100% BUT board no longer holds scores and settings in memory
    I own a Real Battle Action Game

    "I Love The Smell of Napalm & Home Carts in The Mornin'"

  7. #7
    Sieger's Squire
    thegreathopper's Avatar
    Join Date
    Jun 2002
    Location
    London England

    Posts
    962
    The battery is worn out and possible leaking, replace ASAP.
    Fight war not wars.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •