Results 1 to 9 of 9

Thread: ATX 24 Pin stuck like the friggen dickens

  1. #1
    Chin's Bartender
    awbacon's Avatar
    Join Date
    Jan 2009
    Location
    CHicago

    Posts
    1,557

    ATX 24 Pin stuck like the friggen dickens

    Ok, "like the dickens" just means = all the damn way.

    I cannot get the 24pin atx cable out of my motherboard.

    Before anyone asks...

    yes, the safety latch is disengaged and remains so as I attempt full removal.

    It's just in there like a banshee. Wasn't even that hard to insert....but now...holy hell.

    I've tried massaging it, slight pressure with a flathead screwdriver, firm rocking motions, swearing at it, and everything else in between.

    Ideas? it lifts out like 10-15% and then bam...just doesn't want to move any further.

  2. #2
    H = Hot
    M = Macho
    G = Gay
    HeavyMachineGun's Avatar
    Join Date
    Apr 2011
    Location
    Canada

    Posts
    3,962
    Has it been stuck for longer than four hours?

    All kidding aside, try a hair dryer, that can help with jammed connectors.

  3. #3
    Chin's Bartender
    awbacon's Avatar
    Join Date
    Jan 2009
    Location
    CHicago

    Posts
    1,557
    Quote Originally Posted by HeavyMachineGun View Post
    Has it been stuck for longer than four hours?

    All kidding aside, try a hair dryer, that can help with jammed connectors.
    Lol it’s been stuck for exactly four hours. I installed to test fit a cable run, and the fucker won’t come back out!

    Weirdly my wife doesn’t own a hair dryer. Curly hair

  4. #4
    drunk downunder!
    aka. Muff Diver.
    lachlan's Avatar
    Join Date
    Feb 2005
    Location
    A Hard Earned Thirst

    Posts
    11,067
    While your dick is stuck I'll ask you this... is it chinese cheapy cheap or quality built?



    !!

  5. #5
    Chin's Bartender
    awbacon's Avatar
    Join Date
    Jan 2009
    Location
    CHicago

    Posts
    1,557
    Quote Originally Posted by lachlan View Post
    While your dick is stuck I'll ask you this... is it chinese cheapy cheap or quality built?
    Isn’t everything cheap Chinese shit? I mean both are reputable brands but still made in China

  6. #6
    Kula's Candy

    Join Date
    Jan 2018
    Location
    warlock/brightwarrior class heavy destroyer upgrade, E.A.S. Styx.

    Posts
    293
    had this issue on a hp motherboard.
    atx plug sat on the socket no issue, smooth as kasmir silk.
    no luck in removing the coupling without pissing about trying to flex the plug in various ways, using all manner of things.
    thin strong spikes such as jeweller scrwedrivers helped to pry it free.
    filed down the coupling, no issues since.
    [edit]
    keys.
    Last edited by Amiga1200; 03-09-2018 at 09:26 AM.

  7. #7
    drunk downunder!
    aka. Muff Diver.
    lachlan's Avatar
    Join Date
    Feb 2005
    Location
    A Hard Earned Thirst

    Posts
    11,067
    Quote Originally Posted by awbacon View Post
    Isn’t everything cheap Chinese shit? I mean both are reputable brands but still made in China
    It's possible you went too deep.



    !!

  8. #8
    Chin's Bartender
    awbacon's Avatar
    Join Date
    Jan 2009
    Location
    CHicago

    Posts
    1,557
    Quote Originally Posted by lachlan View Post
    It's possible you went too deep.
    Heheh

  9. #9
    Chin's Bartender
    awbacon's Avatar
    Join Date
    Jan 2009
    Location
    CHicago

    Posts
    1,557
    No but for real I’ll have to separate them via small flathead screwdrivers I believe, then file down the connectors. At some point

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •