Results 1 to 5 of 5

Thread: Sony Trinitron (Wegas) KV-27FS13 geometry issues, need some help!

  1. #1
    .
    Join Date
    Jan 2018
    Location
    Uruguay

    Posts
    3

    icon19.gif Sony Trinitron (Wegas) KV-27FS13 geometry issues, need some help!

    Hello! I bought a few days ago a Sony Trinitron TV, model KV-27FS13 for retrogaming and it has some big geometry issues, specially when brighter images are shown on screen. Im attaching pictures of the issue and also a txt with the parameters on the service menu that as far as i know affect the geometry.
    And here is 2 videos showing the problem


    https://youtu.be/MUg611rvWN0

    https://youtu.be/hXrRvzE9-lA

    If i change the brightness level to the minimum as you can see, the issue is less noticeable, you may also notice some blurred letters, specially on the top left of the screen.
    I changed the values for the geometry based on the service manual for the tv and i can't seem to solve the problem, i hope you can help me guys.

    Thanks!!
    Attached Images Attached Images
    • File Type: jpg 1.jpg (1.75 MB, 34 views)
    • File Type: jpg 2.jpg (1.77 MB, 35 views)
    • File Type: jpg 3.jpg (1.80 MB, 34 views)
    • File Type: jpg 4.jpg (1.81 MB, 34 views)
    • File Type: jpg 5.jpg (1.89 MB, 32 views)
    • File Type: jpg 6.jpg (1.66 MB, 31 views)
    Attached Files Attached Files

  2. #2
    Yamazaki's Pupil
    ballzdeepx's Avatar
    Join Date
    Sep 2004
    Location
    Nakatomi Towers

    Posts
    2,719
    I had some similar issues on a PVM and it ended up being bad capacitors.

  3. #3
    .
    Join Date
    Jan 2018
    Location
    Uruguay

    Posts
    3
    Quote Originally Posted by ballzdeepx View Post
    I had some similar issues on a PVM and it ended up being bad capacitors.
    Thanks for the reply, and that was just the answer I was not hoping for, a physical problem.
    I was just tinkering again on the service menu with the geometry values, and there is no way I can get a nice geometry, for example if I get something relatively good looking using one of the pictures I attached as examples, as soon as I load a game and there is a bright image the geometry gets broken again, but on a screen with darker colors and low brightness everything looks ok, I guess I'll keep looking.
    If anyone else have more ideas they are welcome!

  4. #4
    Schlonginator II: Judgment Dong
    GohanX's Avatar
    Join Date
    Sep 2001
    Location
    Next to your mom

    Posts
    9,674
    Do a full recap first before you tinker with anything else.

  5. #5
    .
    Join Date
    Jan 2018
    Location
    Uruguay

    Posts
    3
    Quote Originally Posted by GohanX View Post
    Do a full recap first before you tinker with anything else.
    OK, so before modifying anything in the service menu I saved all the original values (at least the values saved on the tv when i bought it) and based on the service manual of the tv I changed the values that affect the geometry of the image. Using a crosshatch patter from Marvel vs Capom on the PSX I tried to fix it, this is the best i got

    https://imgur.com/Y3qqqSN


    Now in some games, you get stuff cut out of the screen, if i adjust the vertical and horizontal size that fixes the problem, but then the geometry issues are even more evident on the edges.
    Here you can see some examples, on the image with the Capcom logo you can see the edges, all crooked and irregular

    https://imgur.com/Y3qqqSN
    https://imgur.com/eAtijHd
    https://imgur.com/BRJlpww
    https://imgur.com/FnaCrw6

    No matter what values I adjust from the geometry, something keeps looking wrong, which makes me think this is not a configuration problem but instead an issue with a failing component like ballzdeepx said

    Edit: I just now realized what you meant by a full recap, I feel like an idiot. I never opened a tv, so I don't know if im capable of doing that, maybe i should find someone who can do it, could that be the problem? Bad capacitors?
    And again thanks.
    Last edited by Galaga_; 01-27-2018 at 12:11 PM. Reason: I feel like an idiot

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •