Page 2 of 2 FirstFirst 12
Results 26 to 29 of 29

Thread: Just got my AES, video output seems dim, insides look questionable, advice?

  1. #26
    Die Gans

    Join Date
    Nov 2001
    Location
    Germany

    Posts
    3,876
    Since you're working on your console anyway: Make sure to check your power supply. My original one puts out ~17V nowadays.
    Originally Posted by kernow:
    Serious, serious problems man, you have them.

  2. #27
    New Challenger
    Ricard350's Avatar
    Join Date
    Oct 2017
    Location
    Cold Lake, Alberta

    Posts
    28
    Quote Originally Posted by supergoose View Post
    Since you're working on your console anyway: Make sure to check your power supply. My original one puts out ~17V nowadays.
    I read that old PSU like the original one, are unregulated and if you check voltage with no load applied, It will give higher voltage that what it is supposedly rated for.

  3. #28
    Bashful Neophyte
    SirRockALot's Avatar
    Join Date
    Oct 2017
    Location
    DE

    Posts
    14
    Yeah, that would indeed be not terribly unusual for the linear, unregulated PSUs used on consoles like AES, Mega Drive, SNES etc. The voltage regulators used in these consoles generally also have quite a range of acceptable input voltages.

    Any more comments / suggestions on the solder job? ;-)
    scanlines are horizontal jailbars

  4. #29
    JammaNationX
    Xian Xi's Avatar
    Join Date
    Dec 2005
    Location
    Waipahu, Hawaii

    Posts
    27,473
    Quote Originally Posted by supergoose View Post
    Since you're working on your console anyway: Make sure to check your power supply. My original one puts out ~17V nowadays.
    The non 5v console can handle up to 45v with the LM2576 inside.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •