Results 1 to 1 of 1

Thread: need help with 25k7191 monitor with no blue

  1. #1
    . BlueRidge's Avatar
    Join Date
    Oct 2017
    Location
    Asheville, NC

    Posts
    1

    need help with 25k7191 monitor with no blue

    Ok.. recently purchased a Neo Geo MVS 1-slot arcade machine not working.. I already pulled the neo geo board and cleaned it up.. removed the leaking battery which appeared to be only leaking on the top of the battery no acid got on the board.. i replaced the missing power supply and it boots up and plays fine.. however.. the screen doesnt look right.. kinda dark.. so i went to the test screen and the blue square is missing.. i tried to adjust the pots for the blue gun and nothing happened.. so after researching i am checking the transistors on the neck board.. this looks to have been an issue before because you can tell someone replaced the 2sc3229 transistor before and also fixed the trace for that same transistor on the circuit board.. i need help knowing how to test the tube before i pull this neck board and try to fix it.. the neck board is marked P448.. there could be another trace broken on the board as the transistor moves and you can see it pulling the trace on both legs from the board.. any help greatly appreciated.. pics to follow... also if i cannot fix this issue with the neck board.. is there a replacement neck board available for a 25k7191 (k7000) or is the P448 or equivalent available..


    thanks in advance..

    neogeo-neckboard.jpg

    neogeo-noblue.jpg
    Last edited by BlueRidge; 10-21-2017 at 12:49 PM.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •