Results 1 to 6 of 6

Thread: Unibios Help on a ChipMax2

  1. #1
    Bub & Bob's Bub
    Dinodoedoe's Avatar
    Join Date
    May 2002
    Location
    Las Vegas, NV

    Posts
    1,688

    Unibios Help on a ChipMax2

    I'm usually pretty good at figuring things out but it looks like I hit a wall. I don't know why I keep getting program errors and at this point, I'm certain I'm doing something wrong. I was working with a Toshiba TC571024D eprom and I purchased two AMD AM27C1024 eproms. I keep getting load failures and if I do get a good successful load, it doesn't work on my MV-1FZ. Does anyone here familiar with the MaxLoader program?

  2. #2
    Hardened Shock Trooper

    Join Date
    May 2003
    Location
    Stockholm

    Posts
    443
    I'm using a Topmax2 myself. When burning a bios I do the following:
    *Select device (CTRL+F7) Find your device and select it.
    *Blank check (CTRL+B) ("No" if "Device signature does not match. Abort?" to force the test), Repeating a few times because I'm paranoid.
    *Load file to buffer
    *Program device (CTRL+P) ("No" if "Device signature does not match. Abort?")
    *Verify device (CTRL+V) ("No" if "Device signature does not match. Abort?")


    If you've downloaded the bios from Razoolas site it's already Big Endian so no byte swap is needed. If you get any errors along the way let the eprom sit in the eraser for 10min or so to let the UV light erase it and redo it.
    Last edited by Pingu; 10-04-2017 at 01:19 PM. Reason: additional stuff

  3. #3
    Bub & Bob's Bub
    Dinodoedoe's Avatar
    Join Date
    May 2002
    Location
    Las Vegas, NV

    Posts
    1,688
    Yeah, I did that and I still keep getting a programming error. Please See below:

    -Finding USB device.
    CM2E4409 found.
    -Done.
    -USB 2.0 connected.
    -Filling buffer.
    -Done.
    -AMD Am27C040 selected.
    -Buffer checksum : 07F80000h
    -Buffer checksumCRC-16 : 00007040h
    -Buffer checksumCRC-CCITT : FCFD6A4Bh
    -Buffer checksumCRC-XMODEM : DFF82070h
    -Buffer checksumCRC-32 : 504BF849h
    -Buffer checksumCRC-MM : F9636FFAh
    -AMD Am27C1024 selected.
    -AMD Am27C1024 selected.
    Blank check ok.
    --------------------------------> 0.39 Sec.
    Blank check ok.
    --------------------------------> 0.39 Sec.
    Blank check ok.
    --------------------------------> 0.39 Sec.
    -Filling buffer.
    -Done.
    -File loading...
    \\atm-fs-01\Win7-Users$\nbias\Desktop\uni-bios.rom
    -File load success.
    -Buffer checksum : 009EC62Ah
    -Buffer checksumCRC-16 : 0000044Ah
    -Buffer checksumCRC-CCITT : F9FC8BB4h
    -Buffer checksumCRC-XMODEM : B294B680h
    -Buffer checksumCRC-32 : A4E8B9B3h
    -Buffer checksumCRC-MM : 2394E0E0h
    Blank check ok.
    Program error.
    Chip addr:0000000h data:0000h
    Buffer addr:0000000h data:FFFFh
    --------------------------------> 1.36 Sec.
    Verification error.
    Chip addr:0000001h data:FFFFh
    Buffer addr:0000002h data:F300h
    --------------------------------> 0.34 Sec.
    Blank check ok.
    --------------------------------> 0.39 Sec.
    Blank check ok.
    --------------------------------> 0.41 Sec.
    Blank check ok.
    Program error.
    Chip addr:0000000h data:0000h
    Buffer addr:0000000h data:FFFFh
    --------------------------------> 1.31 Sec.
    ------------------------------------------------
    Log Date : 2017-10-05 12:47:24
    --- Product info ---
    Product : ChipMax2
    Max Loader version : 5.2s
    --- Device info ---
    Manufacturer : AMD
    Device Name : Am27C1024
    Organization : 10000h x 16 bit
    Package : DIP 40
    AdapterName : None
    --- Counter ---
    Total : 2
    Success : 0
    Failure : 2
    --- Checksum ---
    Checksum : 9EC62Ah
    --- Auto option: 841f ---
    Erase [X]
    Blank [O]
    Program [O]
    Verify [O]
    Security [X]
    --- Config option ---
    Buffer Clear Before File Loading [O]
    Erase Before Programming [X]
    Blank Check Before Programming [O]
    Verify After Reading [X]
    Verify After Programming [O]
    Byte Order Swapping [X]
    Device Insert Test [O]
    Device Id Check [O]
    Sound [O]
    ------------------------------------------------
    -File saving...
    -File saving...

  4. #4
    Blame madman
    You Know You Want To.
    madman's Avatar
    Join Date
    Jun 2007
    Location
    Boston

    Posts
    5,393
    Perhaps you got some bad chips? The only errors I've encountered with that software is when an eprom isn't fully erased, or sometimes I've had to reseat the eprom before it'll program. Otherwise, no issues.

    [wyo] 9:37 pm: i am fully aware FL sucks. it's a shitty low budget california

  5. #5
    Tesse's Maintainence Man
    skate323k137's Avatar
    Join Date
    Jan 2013
    Location
    Earth, Dimension C137

    Posts
    2,949
    May just be a defective rom. Seems it's failing verify. You can always try another chip. I use 27c4096 now with the image stacked 4x.

  6. #6
    Bub & Bob's Bub
    Dinodoedoe's Avatar
    Join Date
    May 2002
    Location
    Las Vegas, NV

    Posts
    1,688
    I bought two new chips and same thing. No clue why it's not working. I can program 8 bit chips all day with no issues, but I'm having nothing but headaches with the 16 bit chips.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •