Results 1 to 10 of 10

Thread: Triforce Update

  1. #1
    Raiden's Valet
    Morden's Avatar
    Join Date
    Jul 2005
    Location
    Neo Geo World

    Posts
    585

    Triforce Update

    I booted Virtua Striker 4 v. 2006 on my Triforce and it gave me a following message:

    "Boot/Firm version does not fulfill game the spec. Please enter game test to update."

    Once I go to the game test, sure enough, there is an update option, but what does it do, exactly? I'm guessing it updates the Triforce firmware itself, but with what?

    I'm using the same net DIMM on my Naomi boards and on the Triforce. Were I to update, would netbooting be affected in any way?

    Edit: I went into the system update menu. It reads:

    Update Boot Program
    Current version: 1.07
    Latest version: 3.01

    Again, the only thing I'm really concerned about is the update affecting netbooting in any way.
    Last edited by Morden; 09-19-2017 at 06:02 PM.

  2. #2
    Crossed Swords Squire
    Geekman1222's Avatar
    Join Date
    Jun 2017
    Location
    Nearest Data Center

    Posts
    192
    Quote Originally Posted by Morden View Post
    Update Boot Program
    Current version: 1.07
    Latest version: 3.01

    Again, the only thing I'm really concerned about is the update affecting netbooting in any way.
    Thats intresting is it updating the system or the Dimm board because to netboot you must surely be on a higher dimm board version than 1.07
    This is curious

  3. #3
    Raiden's Valet
    Morden's Avatar
    Join Date
    Jul 2005
    Location
    Neo Geo World

    Posts
    585
    Quote Originally Posted by Geekman1222 View Post
    Thats intresting is it updating the system or the Dimm board because to netboot you must surely be on a higher dimm board version than 1.07 This is curious
    It's the "boot" of the Triforce itself, not the NetDIMM. Also, I have recently found out that you can change Triforce and Chihiro regions from the system menu. What I haven't seen mentioned anywhere, though, is the fact that Triforce Type 1 keeps track of your region changes, displaying a number at the bottom of the screen if the option is accessed. I wonder if there's some limit to how many times you can change your region, like in old PC DVD drives.

  4. #4
    Bashful Neophyte
    kioku25's Avatar
    Join Date
    Jan 2011
    Location
    Germany

    Posts
    11
    Apologies for bumping the thread, but I'm in much the same situation as the OP and need some help. I was trying to play Virtua Striker 4 v. 2006 on my Triforce Type 1 and just like the OP was prompted to update the BOOT/FIRM. So I went into the GAME TEST and updated the MAIN BOOT from v. 1.07 to v. 3.01. After the update completed successfully, I was urged to reboot the Triforce and sure enough, it now displays 3.01 in TEST MODE.

    Unfortunately the game still keeps displaying the above message: "BOOT/FIRM VERSION DOES NOT FULFILL THE GAME SPEC. PLEASE ENTER GAME TEST AND UPDATE." and refuses to boot. Trying to repeat the update process only yields a message basically saying that everything is already up to date.

    Does anyone have an idea what went wrong here, or how I can get the game to boot?

  5. #5
    Raiden's Valet
    Morden's Avatar
    Join Date
    Jul 2005
    Location
    Neo Geo World

    Posts
    585
    Quote Originally Posted by kioku25 View Post
    Does anyone have an idea what went wrong here, or how I can get the game to boot?
    I'm answering my own question here, but as it turns out, Virtua Striker 4 is not compatible with Triforce Type 1. In fact, very few games are. So given you have the highest possible Type 1 firmware, you'll only ever be able to play F-Zero AX [but not Monster Ride], Gekitou Pro Yakyuu and Virtua Striker 2002. Additionally, F-Zero requires special controls. Sp yeah, if you want to play everything but these, it has to be Type 3.

  6. #6
    Bashful Neophyte
    kioku25's Avatar
    Join Date
    Jan 2011
    Location
    Germany

    Posts
    11
    Ah, that explains it. So I take it the normal Virtua Striker 4 (not v. 2006) is incompatible as well?

  7. #7
    Raiden's Valet
    Morden's Avatar
    Join Date
    Jul 2005
    Location
    Neo Geo World

    Posts
    585
    Quote Originally Posted by kioku25 View Post
    Ah, that explains it. So I take it the normal Virtua Striker 4 (not v. 2006) is incompatible as well?
    Nope. Feel free to consult this list.

  8. #8
    Bashful Neophyte
    kioku25's Avatar
    Join Date
    Jan 2011
    Location
    Germany

    Posts
    11
    Thanks a lot. No wonder that the Type 1s are so cheap these days.

  9. #9
    I'm Settling in Fine.
    Want a Beer?

    Join Date
    Mar 2002
    Location
    Toronto

    Posts
    8,063
    Still cant play it, but you can play it on Nintendont, which runs on a wii.
    Xbox/PSN Gamer Tag: Wizshaw

    Starcraft 2 GamerTag: WizShaw Character Code: 323

    A man is a philosopher of genius only when he succeeds in transmuting the primitive and wholly natural vision into an abstract idea belonging to the common stock of consciousness.



  10. #10
    The Chinese Kid Kid Panda's Avatar
    Join Date
    Jun 2010
    Location
    Panda Islandô

    Posts
    11,516
    Quote Originally Posted by wizkid007 View Post
    Still cant play it, but you can play it on Nintendont, which runs on a wii.
    Yea and at that point I'd rather play Sega Soccer Slam.
    No, just no.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •