Results 1 to 20 of 20

Thread: Golden Axe PCB and Choplifter PCB questions

Hybrid View

Previous Post Previous Post   Next Post Next Post
  1. #1
    Crossed Swords Squire
    JohnnyFever's Avatar
    Join Date
    Jun 2005
    Location
    I'm at WKRP in Cincinatti...

    Posts
    191

    Golden Axe PCB and Choplifter PCB questions

    Hello!

    I have a couple of boards that I'm trying to get going in my blast city cab. It's the same cab where I run my mvs 1-slot. I have the right adapters. The Choplifter has a red light on the board, and this lights up so I'm assuming the board is getting power. I don't get a screen or sound though. The Golden Axe board gives me great sound, good controls, and accepts credits. The picture is very garbled though. Any thoughts? Could it be a voltage issue? This cab runs my Captain America board, RoboCop board, and other boards just fine. I'm pretty new at this, but I'm looking to get better.

    Thanks for the help!

    John
    Just when they think they have all the answers I go and change all the questions." -Rowdy Roddy Piper

  2. #2
    Mickey's Coach
    egg_sanwich's Avatar
    Join Date
    Oct 2012
    Location
    Vancouver, Canada

    Posts
    743
    Do the boards work properly in other cabs?

  3. #3
    Crossed Swords Squire
    JohnnyFever's Avatar
    Join Date
    Jun 2005
    Location
    I'm at WKRP in Cincinatti...

    Posts
    191
    I was told they work in other cabs before I purchased them. I do have another blast city that I run my dreamcast in, and neither of the boards run in that cab. I'm bummed.
    Just when they think they have all the answers I go and change all the questions." -Rowdy Roddy Piper

  4. #4
    Mickey's Coach
    egg_sanwich's Avatar
    Join Date
    Oct 2012
    Location
    Vancouver, Canada

    Posts
    743
    Quote Originally Posted by JohnnyFever View Post
    I was told they work in other cabs before I purchased them. I do have another blast city that I run my dreamcast in, and neither of the boards run in that cab. I'm bummed.
    Sounds like an issue with the boards then. There's nothing unique to a Jamma wired blast city vs other cabs, and it sounds like the common thread are the boards not working.

    Where'd you get them from? Might be best to contact the seller to sort it out.

  5. #5
    Bub & Bob's Bubble Buddy
    Fox1's Avatar
    Join Date
    Feb 2001
    Location
    USA

    Posts
    4,060
    Quote Originally Posted by egg_sanwich View Post
    Sounds like an issue with the boards then. There's nothing unique to a Jamma wired blast city vs other cabs, and it sounds like the common thread are the boards not working.

    Where'd you get them from? Might be best to contact the seller to sort it out.
    Actually it's known that blast cities hate a lot of PCBS..mainly due to the power supply iirc, so I would test it in another non-blast city cabinet first.





    In with the real hardware, out with the bootlegs......who is this I wonder?

    Don't piss off cats or you'll get the Nyanyan Uppercut!

  6. #6
    Mickey's Coach
    egg_sanwich's Avatar
    Join Date
    Oct 2012
    Location
    Vancouver, Canada

    Posts
    743
    Quote Originally Posted by Fox1 View Post
    Actually it's known that blast cities hate a lot of PCBS..mainly due to the power supply iirc, so I would test it in another non-blast city cabinet first.
    Didn't know this. Related to voltages or?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •