Hello everyone, longtime lurker turned member here requesting help from anyone who might know what's going on with my frontloader. I tried posting this much earlier today but something happened and my post disappeared (think I got timed out) so I'm attempting to post this again.

Edit: I know someone else posted about their frontloader today too, if we're having the same problem I apologize for the redundancy!

I've owned a toploader that's had no issues and I just got this frontloader not long ago so I want to get it fixed. It's something I've wanted for a while and the serial number is in the 600s so I'm guessing it might be pretty early production out of the 25,000 or so that were made.

Here's what's going on:

>system turns on fine, boots to main CD screen
>disc tray ejects on command
>insert disc, nothing happens
>disc tray ejects by itself

I popped the top off and noticed that when you insert a disc the drive doesn't lift to engage the magnetic top. I pushed the tray up manually to engage and the disc doesn't turn, keeps stuttering and everytime it stutters it goes back to the NEOGEO CD opening and keeps doing that.

>turn system off and back on
>disc starts turning
>main CD screen says press start to begin
>game loading screen appears
>once load meter gets to 100% the screen goes blank
>returns to NEOGEO CD opening and goes back to the CD menu

I tried removed the disc and tried again only to hear a grinding noise and the disc started stuttering again causing the system to keep turning on and off going back to the NEOGEO CD opening.

I did find a few bits of plastic inside that I have no idea what they were originally attached to, one almost looks like a clip to me.

Anyone know what might be wrong? I can post pics of the bits if need be. Thanks for your help!