Results 1 to 14 of 14

Thread: Neo Geo CD Frontloader Repair Help Please

Hybrid View

Previous Post Previous Post   Next Post Next Post
  1. #1
    New Challenger
    Rasubosu's Avatar
    Join Date
    Sep 2017
    Location
    San Diego

    Posts
    22

    Neo Geo CD Frontloader Repair Help Please

    Hello everyone, longtime lurker turned member here requesting help from anyone who might know what's going on with my frontloader. I tried posting this much earlier today but something happened and my post disappeared (think I got timed out) so I'm attempting to post this again.

    Edit: I know someone else posted about their frontloader today too, if we're having the same problem I apologize for the redundancy!

    I've owned a toploader that's had no issues and I just got this frontloader not long ago so I want to get it fixed. It's something I've wanted for a while and the serial number is in the 600s so I'm guessing it might be pretty early production out of the 25,000 or so that were made.

    Here's what's going on:

    >system turns on fine, boots to main CD screen
    >disc tray ejects on command
    >insert disc, nothing happens
    >disc tray ejects by itself

    I popped the top off and noticed that when you insert a disc the drive doesn't lift to engage the magnetic top. I pushed the tray up manually to engage and the disc doesn't turn, keeps stuttering and everytime it stutters it goes back to the NEOGEO CD opening and keeps doing that.

    >turn system off and back on
    >disc starts turning
    >main CD screen says press start to begin
    >game loading screen appears
    >once load meter gets to 100% the screen goes blank
    >returns to NEOGEO CD opening and goes back to the CD menu

    I tried removed the disc and tried again only to hear a grinding noise and the disc started stuttering again causing the system to keep turning on and off going back to the NEOGEO CD opening.

    I did find a few bits of plastic inside that I have no idea what they were originally attached to, one almost looks like a clip to me.

    Anyone know what might be wrong? I can post pics of the bits if need be. Thanks for your help!

  2. #2
    New Challenger
    Rasubosu's Avatar
    Join Date
    Sep 2017
    Location
    San Diego

    Posts
    22
    Update:

    So I dissected the frontloader best I could and further inspection into the machine showed that the random rattling and plastic bits are mostly from this.

    neogeo2.JPG

    One of the plastic parts holding the disc drive down broke at some point but the integrity of the other three are strong and keep the drive from moving anyways. There are still a couple of really small plastic pieces that I can't figure out where they came from.

    I was able to figure out where the disc drive is failing but short of taking the tray apart (can't seem to figure out how) I won't be able to get into where I need to go to figure out what's wrong. There's a little gear wheel that turns as the tray ejects and closes. The gear wheel is supposed to turn enough to cause the gear or piece that manages the lens tray? (not sure what to call it, sorry) to come up and engage with the magnet at the top of the drive. Something is preventing this from happening for some reason.

    I pushed the lens tray up manually to engage and the disc started spinning like normal with some minor stuttering. Doing this I was able to get an audio CD to play perfectly without any issues. I did the same thing with a game and had mixed results.

    The first time I tried this when I first made this post I wasn't able to get past the 100% at the load meter. This time it went to the title screen and allowed me to select a game mode.

    neogeo5.JPG

    Within the first few seconds of the first game mode it reset. The CD drive then made a grinding noise as it tried to play again. Turned the system on and off and got it working again. This time I selected a different game mode and played into level 2 with no issues then it reset. Third time tried a different game mode and it reset quicker than the second game mode. Tried the second game mode again and it reset quicker. I tried the various modes and the reset points seem to be at random. The disc is near mint and the lens seems to be clean enough to allow me to play through at least several minutes of the game.

    I'm wondering if the plastic pieces that I can't identify came from the disc tray and are what allowed it to lift and engage the magnetic piece at the top. They don't seem like it but what I'll probably end up doing is figuring out how to take the tray apart and check in the spots that I can't get to. Any and all advice is welcome.

    Here are some photos of the tray with the problem area highlighted masterfully in MS Paint. The yellow circle kind of shows the gear wheel that is supposed to turn in a certain way to activate the bottom lens tray circled in red. The red arrows are what that little part needs to do but isn't doing.

    neogeo4point2.jpg

    Here are some other photos of the insides and a photo without the MS Paint doodles.

    neogeo.JPG
    neogeo4.JPG
    neogeo3.JPG


    I'm going to keep at it and see if I can figure it out but hopefully someone can steer me in the right direction because I have no idea what I'm doing lol. I've worked on a lot of consoles but this is the first Neo Geo anything I've opened up.
    Last edited by Rasubosu; 09-13-2017 at 03:20 PM.

  3. #3
    Bashful Neophyte
    CHAOS 0187's Avatar
    Join Date
    Feb 2016
    Location
    Florida

    Posts
    14
    Quote Originally Posted by Rasubosu View Post
    Update:

    So I dissected the frontloader best I could and further inspection into the machine showed that the random rattling and plastic bits are mostly from this.

    neogeo2.JPG

    One of the plastic parts holding the disc drive down broke at some point but the integrity of the other three are strong and keep the drive from moving anyways. There are still a couple of really small plastic pieces that I can't figure out where they came from.

    I was able to figure out where the disc drive is failing but short of taking the tray apart (can't seem to figure out how) I won't be able to get into where I need to go to figure out what's wrong. There's a little gear wheel that turns as the tray ejects and closes. The gear wheel is supposed to turn enough to cause the gear or piece that manages the lens tray? (not sure what to call it, sorry) to come up and engage with the magnet at the top of the drive. Something is preventing this from happening for some reason.

    I pushed the lens tray up manually to engage and the disc started spinning like normal with some minor stuttering. Doing this I was able to get an audio CD to play perfectly without any issues. I did the same thing with a game and had mixed results.

    The first time I tried this when I first made this post I wasn't able to get past the 100% at the load meter. This time it went to the title screen and allowed me to select a game mode.

    neogeo5.JPG

    Within the first few seconds of the first game mode it reset. The CD drive then made a grinding noise as it tried to play again. Turned the system on and off and got it working again. This time I selected a different game mode and played into level 2 with no issues then it reset. Third time tried a different game mode and it reset quicker than the second game mode. Tried the second game mode again and it reset quicker. I tried the various modes and the reset points seem to be at random. The disc is near mint and the lens seems to be clean enough to allow me to play through at least several minutes of the game.

    I'm wondering if the plastic pieces that I can't identify came from the disc tray and are what allowed it to lift and engage the magnetic piece at the top. They don't seem like it but what I'll probably end up doing is figuring out how to take the tray apart and check in the spots that I can't get to. Any and all advice is welcome.

    Here are some photos of the tray with the problem area highlighted masterfully in MS Paint. The yellow circle kind of shows the gear wheel that is supposed to turn in a certain way to activate the bottom lens tray circled in red. The red arrows are what that little part needs to do but isn't doing.

    neogeo4point2.jpg

    Here are some other photos of the insides and a photo without the MS Paint doodles.

    neogeo.JPG
    neogeo4.JPG
    neogeo3.JPG


    I'm going to keep at it and see if I can figure it out but hopefully someone can steer me in the right direction because I have no idea what I'm doing lol. I've worked on a lot of consoles but this is the first Neo Geo anything I've opened up.
    If the tray is opening and closing with the no problem, the I think the mechanism highlighted in yellow is intact. Try taking apart the kit that holds the lens. It is held down by 4 screws with springs. There maybe some pieces of plastic there keeping it from going up and down. Hope this helps some what and good luck!

  4. #4
    H = Hot
    M = Macho
    G = Gay
    HeavyMachineGun's Avatar
    Join Date
    Apr 2011
    Location
    Canada

    Posts
    3,828
    I remember opening the NGCD Front Loader I used to have and thinking to myself, "The CD drive looks exactly like the one in a Sega CD Front Loader".

  5. #5
    Angel's Love Slave
    GadgetUK's Avatar
    Join Date
    Sep 2013
    Location
    UK

    Posts
    1,071
    Looking at the photo with the gear there - looks like a missing tooth to me! If you cannot find a replacement gear, don't give up - consider manufacturing a tooth for it (eg. a tiny piece of epoxy to fill the gap between the teeth, then some very fine work with files once it hardens to build a tooth back up - but success is not guaranteed and patience is the key.

    neogeo4point2.jpg
    Last edited by GadgetUK; 09-17-2017 at 05:59 AM. Reason: Added image
    My YouTube channel contains some MVS repairs and stuff:-
    http://www.youtube.com/user/GadgetUK164

  6. #6
    Bashful Neophyte
    CHAOS 0187's Avatar
    Join Date
    Feb 2016
    Location
    Florida

    Posts
    14
    Good catch on that. I didnt even notice it.

  7. #7
    New Challenger
    Rasubosu's Avatar
    Join Date
    Sep 2017
    Location
    San Diego

    Posts
    22
    Quote Originally Posted by GadgetUK View Post
    Looking at the photo with the gear there - looks like a missing tooth to me! If you cannot find a replacement gear, don't give up - consider manufacturing a tooth for it (eg. a tiny piece of epoxy to fill the gap between the teeth, then some very fine work with files once it hardens to build a tooth back up - but success is not guaranteed and patience is the key.

    neogeo4point2.jpg
    Oh wow, do you think that might be the issue? I'll take a closer look at it once I get home. As far as I know that gear only moves the lens back and forth but that might explain why it stops working mid game. Thanks for pointing that out!

    I'll also try your suggestion Chaos 0187. Still need to figure out why the tray isn't activating.

    I went out of town for a few days so I haven't had much time to tinker with this. Might work some more on it tonight. Thanks for your suggestions everyone!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •