Results 1 to 5 of 5

Thread: Aero City header light not working

  1. #1
    Tung's Hair Stylist
    NeuroticMoose's Avatar
    Join Date
    Feb 2014
    Location
    California

    Posts
    522

    Aero City header light not working

    So today I finally got a light bulb for my aero city and it fit perfectly but when I turned on the cabinet the light wouldn't go on, I checked all the connections and everything looks solid, I even tried moving some of the contacts to the PSU to see if that would work, nothing. So I'm figuring at this point its probably a wonky transformer, is there any way for me to make sure thats the culprit and is it easy enough to replace?

    EDIT: I checked the ballast/transformer thing in the light fixture enclosure with a multimeter and it was getting about 25 volts, which seems like it should be more than enough to power the light, which leaves the light bulb contacts themselves, at least thats what I'm thinking

    Just checked the fixture contacts themselves and was getting .09 volts, I'm not an expert but I'm assuming that's the problem, so are the contacts dead? should I try cleaning them with some deoxit or should I replace them, how would I replace them?
    Last edited by NeuroticMoose; 04-13-2017 at 10:58 PM.

  2. #2
    SouthTown StreetSweeper
    pulstar's Avatar
    Join Date
    Jun 2011
    Location
    Southampton, England

    Posts
    568
    Have you tried replacing the starter?
    My favourite pigeon had a fatal run-in with a cloud...

  3. #3
    Tung's Hair Stylist
    NeuroticMoose's Avatar
    Join Date
    Feb 2014
    Location
    California

    Posts
    522
    Quote Originally Posted by pulstar View Post
    Have you tried replacing the starter?
    I know next tp nothing about fluorescent light fixtures, are you talking about the ballast thing? I checked the voltage on that and it seemed to be putting out a good amount of electricity, or are you talking about the little light socket in the left side of the fixture? I was wondering what the hell that was

    EDIT: I just looked up what a starter is, that could be the problem! my fixture doesn't have a starter in it, any idea where I could get one? the light fixture is for a 15 watt 18 inch aquarium bulb

    Edit: after some searching I found this: https://www.amazon.com/120-Volt-Fluo...+light+starter Will that work?
    Last edited by NeuroticMoose; 04-14-2017 at 07:17 PM.

  4. #4
    Shadow Cutter Dark Jaguar's Avatar
    Join Date
    Jan 2004
    Location
    MASS

    Posts
    21,456
    Yeah, good job! amazon has this available. Get me one while you're at it, lol.

  5. #5
    SouthTown StreetSweeper
    pulstar's Avatar
    Join Date
    Jun 2011
    Location
    Southampton, England

    Posts
    568
    As Dark Jaguar said, that one should be perfect. Hopefully that should fix your problem.
    My favourite pigeon had a fatal run-in with a cloud...

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •