Results 1 to 2 of 2

Thread: Cart repair: Bad P1 ROM replacement?

  1. #1
    . avramce's Avatar
    Join Date
    Sep 2019
    Location
    Seattle, WA

    Posts
    67

    Cart repair: Bad P1 ROM replacement?

    Hi all, recently picked up a Blazing Star cart with clean looking PCB that was claimed as 'for-parts' and after several hours of cleaning and testing with a known working Blazing Star cart, I determined that the P1 rom on the board is dead.

    The IC looks completely new, no signed of damage, resoldering or chipping, but I confirmed by swapping the P1 to my working board, that the game will crosshatch.

    I picked up a EPROM programmer to make myself a UniBIOS and NeoDiag kit, so I went ahead and tried to burn a P1 rom, but realized that the P1 IC is a 42pin, and I only have 40pin EPROMs.

    Am I out of luck here? I've seen plenty of bootlegs using 40pins in P1, but I'm unsure if that is the expectation of the board, or just requires me to change a jumper or resistor placement on the board. Any help would be appreciated:

    https://imgur.com/mkAm4Zm

  2. #2
    . avramce's Avatar
    Join Date
    Sep 2019
    Location
    Seattle, WA

    Posts
    67
    Well, think I answered my own question:
    http://www.neo-geo.com/forums/showth...-42-pin-EPROMs

    I have a TL866II plus from Amazon, so opted to buy an adapter for 27C160 on eBay and purchases appropriate EPROMs for the job:

    http://www.neo-geo.com/forums/showth...-42-pin-EPROMs

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •