Page 6 of 10 FirstFirst ... 2345678910 LastLast
Results 126 to 150 of 248

Thread: PCM Sound & Stability Fixes Multicarts - 120 in 1, 138 in 1, 161 in 1 and others.

  1. #126
    Cheng's Errand Boy

    Join Date
    Jun 2014
    Location
    Barcelona

    Posts
    119
    I have runing at 4,7-4,8v. without issues in my MV2F, what is better for the chips and montherboard, a lower voltage like 4,7v. (without issues) or 5,0v. ?

  2. #127
    Angel's Love Slave
    GadgetUK's Avatar
    Join Date
    Sep 2013
    Location
    UK

    Posts
    1,071
    Normally I would agree, but on the MVS you tend to get crashes or glitches appearing when 5v level drops below 4.8v. I prefer to run it as close to 5v as possible.
    My YouTube channel contains some MVS repairs and stuff:-
    http://www.youtube.com/user/GadgetUK164

  3. #128
    Cheng's Errand Boy

    Join Date
    Jun 2014
    Location
    Barcelona

    Posts
    119
    then in better 4,85 if you dont have crashes or glitches than 5,0 ? Is not bad for the motherboard chips, caps... ?

  4. #129

  5. #130
    Krauser's Shoe Shiner
    donluca's Avatar
    Join Date
    Aug 2015
    Location
    Rome

    Posts
    241
    GadgetUK, I've finished doing the mods on both my 161 and 138 in 1. I haven't put the optional caps yet as I don't want to add unnecessary components.

    So far I've tested some games and all seems good to me (Puzzle Bobble, Matrimelee, Last Blade 2, Nam-1975, Garou, Strikers 1945)

    Can you tell me some games that usually have problems on these carts and what to look for in them?

    One more thing: Giga Power games for some reason boot two times at start (the green thing at the start happens two times in a row). It really doesn't bother me, but is it normal? If there's a quick/easy way to fix that I'll gladly do that.

    Thanks for all your support so far, it's really appreciated!

    P.S.: is it me or is the non-hacked version of SVC missing from both those multicarts?

    EDIT: ok, I've actually noticed a bug in Puzzle Bobble.
    If you hear carefully, you'll find out that the SFX when the ceiling is about to go down (not the one when it actually goes down, the one before that warns you) plays two times in a row, the second one a little bit louder and distorted.
    Is it because the Puzzle Bobble rom is corrupted or... ?
    Last edited by donluca; 09-11-2015 at 11:25 AM.

  6. #131
    AH
    A
    COLUMBIAN!
    aha2940's Avatar
    Join Date
    Dec 2013
    Location
    Colombia

    Posts
    2,425
    Quote Originally Posted by donluca View Post
    GadgetUK, I've finished doing the mods on both my 161 and 138 in 1. I haven't put the optional caps yet as I don't want to add unnecessary components.

    So far I've tested some games and all seems good to me (Puzzle Bobble, Matrimelee, Last Blade 2, Nam-1975, Garou, Strikers 1945)

    Can you tell me some games that usually have problems on these carts and what to look for in them?

    One more thing: Giga Power games for some reason boot two times at start (the green thing at the start happens two times in a row). It really doesn't bother me, but is it normal? If there's a quick/easy way to fix that I'll gladly do that.

    Thanks for all your support so far, it's really appreciated!

    P.S.: is it me or is the non-hacked version of SVC missing from both those multicarts?

    EDIT: ok, I've actually noticed a bug in Puzzle Bobble.
    If you hear carefully, you'll find out that the SFX when the ceiling is about to go down (not the one when it actually goes down, the one before that warns you) plays two times in a row, the second one a little bit louder and distorted.
    Is it because the Puzzle Bobble rom is corrupted or... ?
    Pulstar has issues iwth the sound IIRC. KoF95 intro sounds wrong compared with original cart. Yes, SVC Chaos is not available in multicarts, only the Plus one is. I seem to remember the Metal Slugs had issues too, but can't remember specific details. Not related to sounds, Garou crashes when using TOP of some characters and AeroFighters3 is unplayable due to bullets staying on screen.

  7. #132
    Krauser's Shoe Shiner
    donluca's Avatar
    Join Date
    Aug 2015
    Location
    Rome

    Posts
    241
    Thank you!

    I'll see if I have those issues on my multicarts or if the mods have fixed them.

    I know for sure that Garou has no issues (I've tried that character's TOP attack, can't remember his name, and went ok). Pulstar and the Metal Slugs are ok too.
    Aero Fighters 3 on the 161 in 1 have a bad dump and there's nothing which can be done about it.

    I'll try KoF95 intro on both carts.
    Last edited by donluca; 09-11-2015 at 11:38 AM.

  8. #133
    Angel's Love Slave
    GadgetUK's Avatar
    Join Date
    Sep 2013
    Location
    UK

    Posts
    1,071
    KoF 95 has missing sound on intro on 161 in 1, but on the 138 in 1 its fine. It's important to note that the caps don't fix problems with the ROM dumps used etc. A couple of the Sam Sho games on the 161 in 1 have dodgy animation on one of the characters. I've not found the problem that others get with Aero Fighters 3 on the 161 in 1, maybe because I only play in console mode? For sound problems on the 161 in 1, normally Pulstar for me - most other games are OK most of the time on the 161 in 1. On the 138 in 1, pretty much anything with PCM - Ninja Masters, Neo Turf Masters, Metal Slug 5, Metal Slug 1, Strikers 1945+, Raging Dragons, Last Resort, and many more.

    With regards to 'optional' capacitors, on the 138 in 1 there aren't any - they are all required or you can still get sound glitches.

    EDIT: Regards Puzzle Bobble i've never noticed any sound issues there, but there is a bug on one of the carts (I forget which) where if you play in European mode the title screen isn't right (if I remember), but in US mode its OK. (I might have that the wrong way around).

    There are other issues on these carts generally, like missing samples on League Bowling, missing sample somewhere in the NAM-1975 intro music I think. Cyberlip on the 138 in 1 has some corrupt samples in the intro, but the game is OK. Blazing Star on one of the carts (I forget which) glitches at level 4 or so I think, and later can crash where you cannot complete it. It is OK on one of the carts (138 in 1 I think) though. Rage of Dragons on the 138 in 1 crashed with exception if you run the game in AES mode - suspected copy protection issue. Super Side Kicks on the 138 in 1 is copy protected and so controls stop responding after a few minutes of play. Blues journey on the 161 in 1 has no sound if you boot straight into that game from cold. whereas if you boot another game, then reset using unibios and then select Blues Journey you will then get sound without issue - I suspect that is some initialisation bug related to sound hardware (missing or corrupt code in the Blues Journey ROM, perhaps related to the 'hold start to get back to menu' hack).
    Last edited by GadgetUK; 09-11-2015 at 01:31 PM.
    My YouTube channel contains some MVS repairs and stuff:-
    http://www.youtube.com/user/GadgetUK164

  9. #134
    Krauser's Shoe Shiner
    donluca's Avatar
    Join Date
    Aug 2015
    Location
    Rome

    Posts
    241
    Thanks for the incredibly extensive response!

    In the files you've shared via dropbox there are some caps which are marked as optional on the 138-in-1.

    https://www.dropbox.com/s/nx0fhk0eim...rtfix.zip?dl=0

    If you look at:

    1.jpg (47pF going from the voltage regulator to... ground?)
    3.jpg (47uF to 220uF electrolytic cap)
    5.jpg (same as before)

    Are those caps required even if marked optional?

    By the way, I have a Spanish (EU) bios on my MV-1FZ. Waiting for my Unibios to arrive!

    EDIT: meanwhile... I discovered there were two resistors in place of capacitors! Jesus, I'm marveled that these multicarts manage to work in stock form.

    EDIT 2: even with the misplaced resistors swapped for capacitors, Puzzle Bobble still has the glitch on the "ceiling warning" sound.

    EDIT 3 (hopefully last): I've seen some tiny graphical glitches in some games. KOF2002 and Metal Slug come to mind. These are small, 1 pixel wide white lines that come on screen for a fraction of seconds and then disappear. You have to really put a lot of attention to see them.
    It's exactly the same as these glitches here: https://www.youtube.com/watch?v=rLeHK3kBzSs
    This happens with my 138-in-1 which has the lower board literally covered in flux.
    Should I clean the mess? With what product though? 90% alchool takes forever to remove this thing.
    Last edited by donluca; 09-11-2015 at 05:03 PM.

  10. #135
    Morden's Lackey
    SmokeMonster's Avatar
    Join Date
    Jan 2014
    Location
    South Pacific

    Posts
    373
    Quote Originally Posted by donluca View Post
    EDIT: meanwhile... I discovered there were two resistors in place of capacitors! Jesus, I'm marveled that these multicarts manage to work in stock form.

    Should I clean the mess? With what product though? 90% alchool takes forever to remove this thing.
    Could you show a picture of the two resistors that you found in place of caps? I didn't inspect mine closely enough to catch this.

    I don't know if this is a good way to clean the flux, but I sprayed mine down with Simple Green and used a toothbrush to gently clean it. Then I brushed it with dish soap and rinsed, followed by a final rinse with distilled water. Dry it using compressed air and set it in front of a fan for a day, then clean off any remaining flux with isopropyl.

  11. #136
    Krauser's Shoe Shiner
    donluca's Avatar
    Join Date
    Aug 2015
    Location
    Rome

    Posts
    241
    I'd love to, but I've already removed them and god only knows where they are by now.

    If you want, tomorrow I'll take pictures of where they were but it looks like it's random. GadgetUK found only one in his board in another position.

    Anyway, they're pretty easy to spot if you look closely.

    Resistors are black with tiny grey numbers on them, caps are pink-ish.

    EDIT: actually I've casually found one while cleaning the table, LOL

    IMG_2923.JPG

    Ignore the solder blob behind. I had to boost the brightness a lot to actually make something out of this tiny thing.
    Last edited by donluca; 09-11-2015 at 08:41 PM.

  12. #137
    Zero's Tailor

    Join Date
    Apr 2013
    Location
    PL

    Posts
    719

    Smile

    Added the 3.3V regulator in today:

    2015-09-13 12.07.37.jpg

    The 'QC passed' sticker seems like a bad joke in the light of missing components

    The cart boots and plays fine, will do some testing as an when time allows. I had a brief look at the smd caps in the light of what was said about some caps being replaced with resistors in the 138-in-1 but here on the 161 it seems that this aspect in ok.
    Regards, MtothaJ

  13. #138
    Krauser's Shoe Shiner
    donluca's Avatar
    Join Date
    Aug 2015
    Location
    Rome

    Posts
    241
    Yup, I can confirm there are no misplaced resistors on 161-in-1.

    Yesterday I've put all the optional caps on my 138-in-1 and Puzzle Bobble's ceiling warning SFX still glitches, it's driving me mad!! >

    Maybe it's just a bug on the european version. When I'll get the unibios I'll try switching region and see if that bug still happens. I also want to run CRC checks on all the games in both the 138-in-1 and 161-in-1 to see which games are good and which are bad dumps.

  14. #139
    Angel's Love Slave
    GadgetUK's Avatar
    Join Date
    Sep 2013
    Location
    UK

    Posts
    1,071
    All games on 161 in 1 will report bad CRC with unibios due to P ROMs being hacked to include the 'hold start for 5 seconds menu reset', but nearly all games are original dumps (except for obvious hacks, + versions etc). What might be useful is for us to build a CRC list up, and a table, so we can document which games have issues, and CRC for each, that way people experiencing problem with a game can check their CRC etc.

    Have you tested both versions of Puzzle Bobble, it on 161 in 1 and 138 in 1 I believe? I will test it when I next get time!
    My YouTube channel contains some MVS repairs and stuff:-
    http://www.youtube.com/user/GadgetUK164

  15. #140
    Krauser's Shoe Shiner
    donluca's Avatar
    Join Date
    Aug 2015
    Location
    Rome

    Posts
    241
    I haven't tested the 161-in-1 Puzzle Bobble, might do it later.

    And yeah, a wiki with a table along CRCs and problems would be indeed useful to a lot of users.

    EDIT: Puzzle Bobble on the 161-in-1 is perfect!
    Last edited by donluca; 09-13-2015 at 02:00 PM.

  16. #141
    Cheng's Errand Boy
    nam9's Avatar
    Join Date
    Oct 2014
    Location
    Norway

    Posts
    120
    Quote Originally Posted by MtothaJ View Post
    The 'QC passed' sticker seems like a bad joke in the light of missing components
    Apparently the practice of Muntzing is alive and well in China...

  17. #142
    Krauser's Shoe Shiner
    donluca's Avatar
    Join Date
    Aug 2015
    Location
    Rome

    Posts
    241
    Can anyone confirm that in the 161-in-1 there's a corrupted explosion SFX in Metal Slug 2?

    I was playing it a bit and noticed that one of the explosion SFX played just static.

  18. #143
    Angel's Love Slave
    GadgetUK's Avatar
    Join Date
    Sep 2013
    Location
    UK

    Posts
    1,071
    I don't get that, maybe one of the VROMs is bad on your 161 in 1, or a bad CPLD connection =\
    Edit: all the Metal Slugs are perfect on my 161, 138, 120 and 60.
    Last edited by GadgetUK; 09-13-2015 at 03:39 PM.
    My YouTube channel contains some MVS repairs and stuff:-
    http://www.youtube.com/user/GadgetUK164

  19. #144
    Krauser's Shoe Shiner
    donluca's Avatar
    Join Date
    Aug 2015
    Location
    Rome

    Posts
    241
    It's only one of the many explosion SFXs, you have to listen quite carefully. It's pretty noticeable when you beat the train's boss on Metal Slug 2 (third mission).
    Not a big deal but, damn, now that I noticed it I can't help hearing it every time :P

  20. #145
    Krauser's Shoe Shiner
    donluca's Avatar
    Join Date
    Aug 2015
    Location
    Rome

    Posts
    241
    Another thing I noticed:

    Metal Slug 2 on the 161-in-1 displays text in spanish language in the "how to play" which seems correct to me since my MVS has the EU spanish bios, but the 138-in-1 displays in english.

  21. #146
    Angel's Love Slave
    GadgetUK's Avatar
    Join Date
    Sep 2013
    Location
    UK

    Posts
    1,071
    Tested Puzzle Bobble on 161 in 1 and don't get the sound issue, will check my 138 in 1s later. Also will check MS2 3rd boss later too! Not sure about BIOS, I only use Unibios and always set to European or US and always English on any multicart.
    My YouTube channel contains some MVS repairs and stuff:-
    http://www.youtube.com/user/GadgetUK164

  22. #147
    Zero's Tailor

    Join Date
    Apr 2013
    Location
    PL

    Posts
    719
    AFAIR the one game where I get Spanish text on the 161 in 1 despite European / US Unibios settings is Neo Bomberman.
    Regards, MtothaJ

  23. #148
    Morden's Lackey
    SmokeMonster's Avatar
    Join Date
    Jan 2014
    Location
    South Pacific

    Posts
    373
    I get English text in Bomberman on my 161 (w/Unibios v3.2, US region).

  24. #149
    Zero's Tailor

    Join Date
    Apr 2013
    Location
    PL

    Posts
    719
    Quote Originally Posted by SmokeMonster View Post
    I get English text in Bomberman on my 161 (w/Unibios v3.2, US region).
    neobomberman.jpg

    My settings are Europe / Arcade - would need to double check what the story is on US settings.
    Regards, MtothaJ

  25. #150
    Krauser's Shoe Shiner
    donluca's Avatar
    Join Date
    Aug 2015
    Location
    Rome

    Posts
    241
    Quote Originally Posted by GadgetUK View Post
    Tested Puzzle Bobble on 161 in 1 and don't get the sound issue, will check my 138 in 1s later. Also will check MS2 3rd boss later too! Not sure about BIOS, I only use Unibios and always set to European or US and always English on any multicart.
    Yup, puzzle bobble on the 161-in-1 is perfect.

    Pay attention when you defeat the third boss on the explosions SFX. There's one which on my cart produces only static. It's very short so you have to listen carefully.
    Last edited by donluca; 09-19-2015 at 05:43 PM.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •