Results 1 to 4 of 4

Thread: NEO-MVH MV4 - Repair

  1. #1
    .
    Join Date
    Jul 2017
    Location
    USA

    Posts
    2

    NEO-MVH MV4 - Repair

    Hello, everyone!

    I have an NEO-MVH MV4-based machine that recently stopped working and displays the following error on boot:

    Code:
    WORK RAM ERROR
    
    ADDRESS   WRITE  READ
    00101A0A  5555   4555
    Please correct me if I am wrong, but I understand this may be indicative of a faulty RAM module and/or a bad trace.

    1. Would one of these issues be more plausible/likely than the other?
    2. Are the highlighted modules in the image below the WORK RAM? If so (and assuming this is the issue), would it be correct to replace the module highlighted in purple (H9?), given the results of the READ function?

    neogeo2.jpg

    I am new to this, so any advice/help would be greatly appreciated!
    Last edited by buck; 07-24-2017 at 10:24 PM.

  2. #2
    Banned
    Join Date
    Jul 2017
    Location
    Houston, Tx

    Posts
    108
    Do you have any soldering skills?

  3. #3
    .
    Join Date
    Jul 2017
    Location
    USA

    Posts
    2
    Quote Originally Posted by NexusX View Post
    Do you have any soldering skills?
    I do, though I am certainly not an expert. I realize these are surface mount chips which makes the task significantly more challenging, but I am willing to give it a shot.

    Would you or anyone else be able to shed any light on which WORK RAM module I need to replace? From what I've gathered, the position of the flipped bit can indicate which module is faulty; in this case, I am assuming the culprit is at position H9, but I was hoping to get some confirmation on this (please see my picture). Also, I know it's possible they both may need replacing (and that others issues may exists beyond this that may not be immediately apparent), but obviously I want to take things one step at a time.

    Any guidance is appreciated!
    Last edited by buck; 07-24-2017 at 10:32 PM.

  4. #4
    Banned
    Join Date
    Jul 2017
    Location
    Houston, Tx

    Posts
    108
    If you have hunted down the possible chips that are faulty or may have faulty connections then I suggest busting out a multimeter and checking the traces for circuit continuity.
    If the chips do need replacing then that surface mount soldering is gonna be a pain to redo if its needed. You may get off lucky and just have to bridge a trace. A better question is how much money you want to throw at this repair? Have you sourced out replacement chips if you need them? Or are you going to use some off a parts board?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •