PDA

View Full Version : NeoSD Pro loops back to menu



Gaston
10-18-2020, 01:26 PM
So, bought an NeoSD MVS Pro and right out of the gate I have an issue with games not loading. Running unibios 4.0 on an mvs1fz (tried multiple to exclude hardware) and an 2F. Downloaded the neo builder to create a set of valid neo files and put them on a class 10 sd card. Pro is running 1.7 R8.
When I flash a game- ram or flash and try to load it, the unibios screen is briefly shown after which it soft resets to the neosd menu. Tried many games, rebuilding roms etc. No succes. What could be the problem here?

Gaston
10-18-2020, 02:49 PM
Also; a normal MVS cart boots up just fine so I can confirm it's not the MVS unit. Using Neovalidator 1.06 there is only one neo file with an error but that is because it concerns a homebrew title. 222 titles check out ok and a couple of sets are missing which I don't care about. So it's not the roms. I am inclined to think this is a firmware issue. Last thing I'll try is swapping out the unibios for a regular bios. If that doesn't work, I suspect there is something wrong with the NeoSD.

Gaston
10-19-2020, 07:14 AM
Ok, another update. This is the video of issue I'm running into:


https://youtu.be/ly90TKUI5bY

Setup: My retroelectronic supergun is connected to an arcade powersupply which provides both 12V and +5V (no -5V) to my MVS 1FZ w/ unibios 4which has a battery mod. I tweaked so that it delivers +5.1V to the supergun. I then checked with the MVS1 powered on running the NeoSD (No SD card inserted) what the power draw is of a regular game when it's running. C3 on the Jamma board measures 4.2V Jamma components side, pin D4 measures 5.1V Jamma components side. Regular carts seem to work flawlessly, checked 3 random games. On the control panel side I connected buttons Up, down, left, right, A,B,C,D, Left Player start to the supergun terminal blocks, same for Player 2. Dip switch 7 is set to ON (Freeplay) and the backup ram has been wiped. All tests seem to be fine. I tried switching out different BIOS versions, even stock.


SD card: I am using a generic MicoSD card 16GB, formatted FAT32. Roms are validated using the NeoValidator 1.06. Couple of romsets missing but the rest is fine.

58062

Now, I noticed that the card is locked when I try to wipe it. Tools like diskpart etc. seem to fail. The card is write disabled apparently and no way to delete it(?). It was relatively new but cheap. Since the NEOSd writes back to sd card, this would go wrong. Is it enough to trigger a reboot? Maybe, hoping somebody can tell me. Tried putting it in arcade mode with a flashed game on the card, no succes.


NeoSD MVS Pro: boot to menu, a+d+start in game menu. Arcade = no. Backram set to No but have tried other options. Nothing that causes me to get trapped in an endless bootloop. Flashing games works ok. When I start a game, the NeoSD triggers a reboot straight to Menu.


SUPPORT: Tried opening a ticket over at terraonion but wouldn't you know it, it is impossible to register because nobody activates my account. I guess NG.com is the way to go then!

Gaston
10-19-2020, 12:39 PM
Solved my problem but not because of you useless fucks!

wyo
10-19-2020, 01:09 PM
Lol, what was the solution?

To be fair, only a few people have these so the tech support is going to be very limited outside of TerraOnion themselves.

Gaston
10-19-2020, 02:50 PM
Lol, what was the solution?

To be fair, only a few people have these so the tech support is going to be very limited outside of TerraOnion themselves.

True. It was probably my own fault for using shitty SD cards. Happy to get it working!

2D_Master
10-19-2020, 05:32 PM
Glad you got it sorted out.

Still waiting on my NeoSd pro mvs. Hopefully I won't run into the same problem and even if I do... thanks for sharing the solution.

It was the SD card itself, aye?

Gaston
10-20-2020, 12:55 AM
Yes, in combination with player 1 button short when closing the panel. I noticed.a bent pin so when I fixed that and put a decent sd card in, it worked!