PDA

View Full Version : SSDS3 games issue



Raph4
03-23-2018, 04:05 AM
Hello,

Actually I have one game won't start, it's Jim Power (PC-Engine CD).

I have test two different version:
TruRip backup: ccd/cue/img/sub
standard backup: cue/iso

Game won't load. I have only one black screen after boot-up "press run to start" from Bios message. The LED stays on, it does not blink.

I use this BIOS:
PC Engine CD-Rom System BIOS V3.01


Edit: oups sorry, guys. Game load with BIOS v3.00
Keep my post for info :glee:

pixeljunkie
03-26-2018, 02:51 PM
Hello,

Actually I have one game won't start, it's Jim Power (PC-Engine CD).

I have test two different version:
TruRip backup: ccd/cue/img/sub
standard backup: cue/iso

Game won't load. I have only one black screen after boot-up "press run to start" from Bios message. The LED stays on, it does not blink.

I use this BIOS:
PC Engine CD-Rom System BIOS V3.01


Edit: oups sorry, guys. Game load with BIOS v3.00
Keep my post for info :glee:

Cool, good to know. Now we can all experience the clearly bootlegged Ys 3 tunes on this game.

pixeljunkie
04-01-2018, 11:50 AM
Is there any plans to add a setting to emulate actual CD access speeds for games like Sherlock Holmes? I noticed those refuse to run correctly.

sadelape
04-05-2018, 05:57 AM
Ys I & II (USA) has a weird audio glitch every 10-20 mins. It seems to cut to a distorted-echo for like 2 secs then back to normal.
I have tried different bios and bin-cues/rips but all seem to do it.
Still very playable. No worse than a scratched cd but worth mentioning.

neodev
04-05-2018, 08:36 AM
Ys I & II (USA) has a weird audio glitch every 10-20 mins. It seems to cut to a distorted-echo for like 2 secs then back to normal.
I have tried different bios and bin-cues/rips but all seem to do it.
Still very playable. No worse than a scratched cd but worth mentioning.

Are you using a samsung evo card? Some users reported similar issues. It seems they sometimes become slower for a couple of seconds. Do you have another card to try?, Sandisk for example.

Yodd
04-05-2018, 08:49 AM
Are you using a samsung evo card? Some users reported similar issues. It seems they sometimes become slower for a couple of seconds. Do you have another card to try?, Sandisk for example.

To echo what neodev said, I know forum member Kid Panda mentioned seeing audio problems with the Evo cards too. I believe he switched to a Sandisk and the problems went away.

Kid Panda
04-05-2018, 12:41 PM
Yea the Evo cards were giving me a fit, I would avoid and go Sandisk. I've used two Sandisk now with zero issues.

Rot
04-05-2018, 04:38 PM
The Terraonion forums are now closed to all guests... and non-registered or logged in users....

Wanna bitch about it?... PM me...

xROTx

PS. Don't fuckin' say I didn't warn you fucks...

Next job... is to start filtering the idiots out of my life... and I DEFO hold a grudge...

monads
04-05-2018, 10:16 PM
I've been using the Samsung 256gb Evo+ micro sd card without issues. Are these sounds issues 'game' specific per say???

sadelape
04-06-2018, 02:40 AM
That totally fixed it.
Was using PNY 128 gig.
Now Sandisk Ultra 64 gig without any issues.
Best product ever.

SavagePencil
04-08-2018, 02:52 PM
I was about an hour into Beyond Shadowgate. I was just leaving the first town (walking across the bridge with gargoyles). When I hit the edge of the screen, the game hung. The SD card access light was solid green.

I had to do a full power on/off. When it came back up, all of my save games were erased.

I had gone across that screen edge before, so I don't think it's 100% repro.

Have not had any issues similar to this, but wondering if the solid light might be a clue for the next rev of the firmware.

pixeljunkie
04-11-2018, 10:05 AM
I noticed Super Real Mahjong P5 glitches hardcore when you go to the in-game menu

What's the best program for ripping games? I think I need to start ripping my own collection.

neodev
04-11-2018, 02:59 PM
I was about an hour into Beyond Shadowgate. I was just leaving the first town (walking across the bridge with gargoyles). When I hit the edge of the screen, the game hung. The SD card access light was solid green.

I had to do a full power on/off. When it came back up, all of my save games were erased.

I had gone across that screen edge before, so I don't think it's 100% repro.

Have not had any issues similar to this, but wondering if the solid light might be a clue for the next rev of the firmware.

Are you using a Rev1 or Rev2 board? the firmware in the rev 2 boards has fixes for that issue.

SavagePencil
04-11-2018, 03:13 PM
Are you using a Rev1 or Rev2 board? the firmware in the rev 2 boards has fixes for that issue.

Rev 2.

neodev
04-11-2018, 03:21 PM
Rev 2.

for next firmware, I'm thinking on, instead of overwritting the current backup with the new one, renaming the previous one and creating a new one. So if the save fails, it can be recovered

SavagePencil
04-11-2018, 04:05 PM
for next firmware, I'm thinking on, instead of overwritting the current backup with the new one, renaming the previous one and creating a new one. So if the save fails, it can be recovered

That seems like a reasonable fix. Question: when is the file actually *written* to disk? How do you know when it's done writing and can actually create the file?

neodev
04-11-2018, 04:15 PM
That seems like a reasonable fix. Question: when is the file actually *written* to disk? How do you know when it's done writing and can actually create the file?

Every time a game writes to the backup ram, the FPGA notifies the MCU and the MCU starts a timer, when the game doesn't write for a while (I think it's 2 seconds), the MCU retrieves the backup ram data from the FPGA and writes to disk. If a new write happens while the data is being read, it starts the timer again.

SavagePencil
04-11-2018, 04:26 PM
Every time a game writes to the backup ram, the FPGA notifies the MCU and the MCU starts a timer, when the game doesn't write for a while (I think it's 2 seconds), the MCU retrieves the backup ram data from the FPGA and writes to disk. If a new write happens while the data is being read, it starts the timer again.

So it sounds like in my case, the FPGA hung while it was in the middle of waiting for the timer to end, and thus it wrote an empty file to disk. Instead of renaming the old save, could you wait until a write is complete in a new file and then it's smart enough to use the newly created file?

neodev
04-11-2018, 04:30 PM
So it sounds like in my case, the FPGA hung while it was in the middle of waiting for the timer to end, and thus it wrote an empty file to disk. Instead of renaming the old save, could you wait until a write is complete in a new file and then it's smart enough to use the newly created file?

the MCU only writes to disk once it has the entire data in its own memory, then does a single 2048kb write. The problem with the 1.0 firmware was that, sometimes, if cdda was being streamed, as the SD card reads go through DMA, it wasn't properly waiting till all pending reads were complete before starting the write, and that caused the SD to go to a invalid state and caused any next reads to fail, causing stuck audio and crashes and 0 sized save file. It's now protected but it seems there is still an edge case somewhere. Also when that SD lockup is detected, it tries to recover by resetting the SD card.

SavagePencil
04-12-2018, 10:44 AM
the MCU only writes to disk once it has the entire data in its own memory, then does a single 2048kb write. The problem with the 1.0 firmware was that, sometimes, if cdda was being streamed, as the SD card reads go through DMA, it wasn't properly waiting till all pending reads were complete before starting the write, and that caused the SD to go to a invalid state and caused any next reads to fail, causing stuck audio and crashes and 0 sized save file. It's now protected but it seems there is still an edge case somewhere. Also when that SD lockup is detected, it tries to recover by resetting the SD card.

When it happened to me, the light was solidly on (no flickering). Is that what you had seen in the past, too?

Rot
04-12-2018, 04:09 PM
When it happened to me, the light was solidly on (no flickering). Is that what you had seen in the past, too?

Dear PencilDick... You are now officially on my radar.... (http://www.neo-geo.com/forums/showthread.php?273291-PCE-Super-SD-System-3-Terraonion-New-Product-(Dec-2017)&p=4285947&viewfull=1#post4285947)

Mother fucker...

neodev
04-13-2018, 03:47 AM
When it happened to me, the light was solidly on (no flickering). Is that what you had seen in the past, too?

Yes, that's the same, the SD gets locked and as no read or writes happen, the led is stuck on.

haightc
04-26-2018, 05:56 PM
Playing Mysterious Song on my CoreGrafx there are graphics issues in cut scenes where part of the image tears off.

I have in game trigger turned off but arcade card turned on.

Also when I first tried to boot this game I accident choose system card 3.0 instead of super system card. So I got the expected splash screen of telling me I had the card. So I power cycled the machine, selected the super system card and selected boot last game. The SSD3 did not like this I got a blank screen then it crashed back to the what looked like the menu but with no text populated now button response. So then I power cycled the machine again and in the settings no bios was selected. So I guess lesson learned don't use the boot last game option if you have changed the system card option. I am guessing this is just an overlooked bug though.

I have been playing this on my Super CD-ROM2 connected to my Supergrafx. Having shorter load times between battle is nice, hopefully the next firmware will also reduce the busing sound from SD card access. Audio balance seems a little different then original hardware, not is a bad way really though.

AlxUnderBase
06-22-2018, 08:01 AM
I'm trying to play this "Legend Of Hero Tonma" in this morning and doesn't work ... i got black screen when i pres run to start the game ! :( Anyone can help me to run this game ?

Greetings !

Bios 3.0
White Pc Engine console or CoreGrafx II + Super SD System 3 attached with and without "in game trigger" enabled / disabled
Micro SD 128 gb Sandisk Class 10

Update : After the SSdS3 was updated with "firmware_1.02" the game work with HuCard Dumper - Enabled ! Thank you guys !

FilthyRear
06-22-2018, 08:03 AM
TO has their own forums for issues. Please post there.