View Full Version : cthulhu multi-console pcb

12-28-2014, 11:07 PM
ok, iam trying to make a multi console stick.

I have hooked up a neo geo cable and also wired in a megadrive/genesis pcb as these are not supported.

I have tested both are they work perfect.

the only rj-45 cable I have at the moment is a dreamcast one and I get no response from it.

I have plugged the cthulhu board into my pc and all the joystick/buttons all map fine on it.

I have checked the dreamcast cable and it looks okay, is there anything obivious I should look for?

12-29-2014, 07:02 AM
How do you have the Cthulhu setup/wired? It doesn't have a stock RJ45 port, so did you solder an RJ45 to the board and then run it to a passthrough? How are the other systems wired up alongside? If you have a multimeter you can check pin continuity as well as order to see if the DC cable was wired correctly, but it's unlikely there's a problem there. I supposed it's also theoretically possible you got one that was before DC support was standard and it needs a firmware upgrade? I don't know anything about the timeline of support, just a random idea.

12-29-2014, 08:17 AM
aye it is connected from a rj45 which I soldered on and then to a Neutrik RJ-45 connector, i should have mentioned that.

I ll check what firmware version is on it, I guess its best to update it anyway if there is a newer version.

12-29-2014, 08:25 AM
Yes, always update the Cthulhu first, and it's generally best to use the onboard USB jack instead of a USB cable through the RJ45 jack. Also, make sure you have the MC version, as the PS3/PC only version looks very similar.

The only advice I can offer is to check and double check your soldering. Make sure the DC cable is made correctly. Make sure the soldering of the RJ45 cable is correct. Make sure the board is getting proper 5V and G from the RJ45 jack. One thing to keep in mind with the RJ45 jack is there are 8 solder points, and various RF45 cables will use different RJ45 pins, so as short in one cable may allow one system to work and the other one not work. Generally issues with the Cthulhu boil down to one wire not connected correctly, or shorting out or something. Been there, done that, and it's a pain in the ass to find sometimes.

12-29-2014, 12:11 PM
I didn't realise there where different ones, I have 2 boards, when I plug one into the pc it says pc/ps3 controller and the other one says usb input device. by luck I have used the correct one.

I updated the firmware to 2.3.

done a continuity check from the dreamcast controller pins to the cthulhu board and it all seems fine.

I am going to make a cable for snes and the Saturn and try these also

12-29-2014, 12:29 PM
Yes, there are two different versions, the only difference is a few components. The mc version should show up as "MC Cthulhu" in Windows.

12-30-2014, 07:50 AM
turns out the firmware had not updated properly, done it again and tried it, dreamcast now works

12-31-2014, 06:22 AM

12-31-2014, 06:42 AM
I made a snes and a playstation cable and they both worked, that's what made me think the firmware was wrong.

I can now play snes, playstation, megadrive, neo geo, dreamcast and Saturn from one joystick...sweet

I have extension cables on the way for the nes and gamecube which I plan to turn into cables also

12-31-2014, 09:56 AM
Glad to hear you resolved it.

I've been jacking around with MC Cthulhus for years now and have never got the MC part to work properly for me. Its always the same thing. I make a bunch of cables, do all the modding, soldering and what have you. Shit doesn't work, I check the continuity and tinker around some more but still can't get it going. In the end, I always end up just using them as PS3 PCBs which is pretty pointless since they always go in PS3 sticks lol.

I did get a Dreamcast cable to work once but I didn't crimp it right so it came lose. Ever since then I haven't been able to do it.

However, reading this thread has given me new hope. Could it be possible that my problem is something as simple as a firmware upgrade?

12-31-2014, 10:13 AM
I used this site to do most of my cables, its in French but the pictures mean that doesn't matter. helped alot


if you had a dreamcast one working I would say your firmware was higher than mine but always good to keep it up to date I guess.

I didn't crimp my cables myself, I just took a couple of already made rj45 internet cables, chopped it in half and used them to attack to my cables, not the best to look at but works great and easy to fix
if I hook it up wrong

12-31-2014, 12:54 PM
Whelp it wasn't the firmware.

Also, for a second there I didn't understand what you meant by not crimping your own cables. That's a damn good idea just cutting it and soldering the wires together. I'm gonna try that asap.

The problem i'm having is I don't know whether or not my cables are faulty or if its something else. I've tested the continuity and they seem fine but who knows. I'll use your work around and see if that works for me. Then i'll know for sure.

Thanks for the tip

12-31-2014, 01:17 PM
If you're not sure about the cables buy one from Lemony, that would be a good test.

12-31-2014, 11:12 PM
Yeah I've been thinking about buying a test cable for a long time now.

Just stubborn I guess.

Whatever I'll try one more time then fuck it i'm hitting him up.