PDA

View Full Version : Strange case of graphic issues with samurai spirits MD



ni-ten
12-13-2014, 08:51 AM
The other day i bought a new old stock "samurai spirits" cart for mega drive. My Sega Mega drive 2 (NTSC-J) PC BD MD2 VA0 [04-1993] works absolutely fine with all my other games. But... when playing SS and starting from the character select screen i get a weird pattern of slightly blinking pixels on the upper half of the tv screen, which should not be there. So... i bought another japanese SS cart today and guess what? Same graphic issues as the first one. Is this game kind of incompatible with my MD2 revision? I know the game is rather unusual having 24megs.

ni-ten
12-14-2014, 04:52 PM
I am using a 10v, 850mA aftermarket power supply. Could that be causing issues with this particular game?

ni-ten
12-20-2014, 06:46 AM
Purchasing an original sega power supply does not solve the issue. Anyone else having the same problems with the japanese samurai spirits MD game?

Pingu
12-20-2014, 02:36 PM
Try cleaning the contacts of the game, it could be something simple like that.

Xian Xi
12-20-2014, 03:43 PM
If it's NOS then you might need to clean the cart edge as it may have a film on it preventing connection.

ni-ten
12-25-2014, 01:22 PM
So i took a third copy of the game to a Friends House and the Game Displays the Same Blinking Pixels/Artefacts on his Mega Drive v0 Board. I think ist safe to Say that the japanese Release of ss md is faulty.

Pingu
12-25-2014, 04:28 PM
time to open it up then, there really is just a few things that can be wrong with a genny cart. The small capacitor (which usually is not the problem), a bad mask rom or some connectivity problem, you could check it out with a multimeter. If that doesn't gets you anywhere you pretty much need to burn out a new prom and solder in.

ni-ten
12-26-2014, 04:17 PM
By now i have three copies of samurai spirits MD (japan) from three different sources. Which all three display the very same blinking pixels on two different machines once past the character select screen, a japanese mega drive 2 and a japanese mega drive 1 V0. I cant understand how this game has ever passed QC. And i wonder if the western releases have the same issues? The japanese rom when played on fusion is absolutely flawless. Someone help me understand whats going on here.

Xian Xi
12-26-2014, 05:01 PM
The problem is that you are trying to play Samurai Spirits on an MD and not a Neo Geo like the machine that this forum is dedicated to.

In all seriousness, try opening up the carts and see if there is anything wrong internally, maybe even confirm the rom is good.

ROBO2011
12-27-2014, 04:53 PM
By now i have three copies of samurai spirits MD (japan) from three different sources. Which all three display the very same blinking pixels on two different machines once past the character select screen, a japanese mega drive 2 and a japanese mega drive 1 V0. I cant understand how this game has ever passed QC. And i wonder if the western releases have the same issues? The japanese rom when played on fusion is absolutely flawless. Someone help me understand whats going on here.

My samurai shodown pal game has the same Graphical glitches. I guess it is just the way it is...sorry

Xian Xi
12-27-2014, 05:36 PM
My samurai shodown pal game has the same Graphical glitches. I guess it is just the way it is...sorry

That's what I figured. Maybe the rom on fusion is updated, I'd try swapping in the rom from fusion if it's a different/fixed rom.